summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-07-24 05:44:36 +0000
committerJeroen Roovers <jer@gentoo.org>2015-07-24 05:44:36 +0000
commit5558c7cfc60a585c34021fcad26a7e392bb6d778 (patch)
treec9fc88a850c98c6ee5a5be78413c19a66c5ee9f4 /net-analyzer/wireshark
parentbup (diff)
downloadgentoo-2-5558c7cfc60a585c34021fcad26a7e392bb6d778.tar.gz
gentoo-2-5558c7cfc60a585c34021fcad26a7e392bb6d778.tar.bz2
gentoo-2-5558c7cfc60a585c34021fcad26a7e392bb6d778.zip
With USE=qt5, make sure we discover the correct RCC (bug #555638).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.12.6-rcc.patch52
-rw-r--r--net-analyzer/wireshark/wireshark-1.12.6.ebuild5
3 files changed, 60 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index f82b2b7796e7..bbbdc4ee586e 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.739 2015/07/22 17:34:09 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.740 2015/07/24 05:44:36 jer Exp $
+
+ 24 Jul 2015; Jeroen Roovers <jer@gentoo.org> wireshark-1.12.6.ebuild,
+ +files/wireshark-1.12.6-rcc.patch:
+ With USE=qt5, make sure we discover the correct RCC (bug #555638).
22 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> -wireshark-1.12.4.ebuild:
Drop old insecure version
diff --git a/net-analyzer/wireshark/files/wireshark-1.12.6-rcc.patch b/net-analyzer/wireshark/files/wireshark-1.12.6-rcc.patch
new file mode 100644
index 000000000000..b8290d00c969
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.12.6-rcc.patch
@@ -0,0 +1,52 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1609,11 +1609,37 @@
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+- MIC=moc
++ MOC=moc
+ fi
+ fi
+ fi
+ AC_SUBST(MOC)
++AC_PATH_PROG(RCC, rcc)
++if test "x$RCC" = x
++then
++ AC_PATH_PROG(RCC, rcc-qt4)
++ if test "x$RCC" = x
++ then
++ if test "x$have_qt" = "xyes"; then
++ #
++ # If you want to build with Qt, you'd better
++ # have rcc.
++ #
++ AC_MSG_ERROR(I couldn't find moc or rcc-qt4; make sure it's installed and in your path)
++ else
++ #
++ # We shouldn't fail here, as the user's not
++ # building with Qt, and we shouldn't force them
++ # to have Qt installed if they're not doing so.
++ # "make dist" will fail if they do that, but
++ # we don't know whether they'll be doing that,
++ # so this is the best we can do.
++ #
++ RCC=rcc
++ fi
++ fi
++fi
++AC_SUBST(RCC)
+
+ # Error out if a glib header other than a "top level" header
+ # (glib.h, glib-object.h, gio.h) or certain other headers( e.g.,gmodule.h)
+--- a/ui/qt/Makefile.am
++++ b/ui/qt/Makefile.am
+@@ -116,7 +116,7 @@
+
+ .qrc.rcc.cpp:
+ $(MKDIR_P) $(@D)
+- $(AM_V_RCC)rcc -name `basename $< .qrc` -o $@ $<
++ $(AM_V_RCC)$(RCC) -name `basename $< .qrc` -o $@ $<
+
+ ui_%.h: %.ui
+ $(AM_V_UIC)$(UIC) $< -o $@
diff --git a/net-analyzer/wireshark/wireshark-1.12.6.ebuild b/net-analyzer/wireshark/wireshark-1.12.6.ebuild
index 0f0b96cd09a3..c4d1f2eaf705 100644
--- a/net-analyzer/wireshark/wireshark-1.12.6.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.12.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.12.6.ebuild,v 1.12 2015/07/22 15:32:49 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.12.6.ebuild,v 1.13 2015/07/24 05:44:36 jer Exp $
EAPI=5
inherit autotools eutils fcaps flag-o-matic multilib qmake-utils qt4-r2 user
@@ -97,7 +97,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.99.0-qt5.patch \
"${FILESDIR}"/${PN}-1.99.1-sbc.patch \
"${FILESDIR}"/${PN}-1.12.5-cross-compile.patch \
- "${FILESDIR}"/${PN}-1.99.7-qt-pie.patch
+ "${FILESDIR}"/${PN}-1.99.7-qt-pie.patch \
+ "${FILESDIR}"/${PN}-1.12.6-rcc.patch
epatch_user