summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-06 10:18:41 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-06 10:18:41 +0000
commit3c642ec6231424512ac185d63df1efe58e18b09c (patch)
treec96f27199c38b4e39d03c01eb7c12be398443817 /net-analyzer
parentkill_gconf fix #16923 (diff)
downloadgentoo-2-3c642ec6231424512ac185d63df1efe58e18b09c.tar.gz
gentoo-2-3c642ec6231424512ac185d63df1efe58e18b09c.tar.bz2
gentoo-2-3c642ec6231424512ac185d63df1efe58e18b09c.zip
Mark stable
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/snort/files/snort-1.9.1-configure.patch11
-rw-r--r--net-analyzer/snort/snort-1.9.1.ebuild9
2 files changed, 16 insertions, 4 deletions
diff --git a/net-analyzer/snort/files/snort-1.9.1-configure.patch b/net-analyzer/snort/files/snort-1.9.1-configure.patch
new file mode 100644
index 000000000000..921cc954aeb4
--- /dev/null
+++ b/net-analyzer/snort/files/snort-1.9.1-configure.patch
@@ -0,0 +1,11 @@
+--- /tmp/configure 2003-03-05 10:17:44.000000000 +0000
++++ configure 2003-03-05 10:18:00.000000000 +0000
+@@ -3334,7 +3334,7 @@
+ else
+ echo "$ac_t""yes" 1>&6
+ LDFLAGS="${LDFLAGS} -L${SNMP_LIB_DIR} "
+- CPPFLAGS="${CPPFLAGS} -I${SNMP_INC_DIR} -DENABLE_SNMP"
++ CPPFLAGS="${CPPFLAGS} -DENABLE_SNMP"
+ LIBS="${LIBS} -lnetsnmp"
+ fi
+ fi
diff --git a/net-analyzer/snort/snort-1.9.1.ebuild b/net-analyzer/snort/snort-1.9.1.ebuild
index 8b11427b23be..f9c27e6d1e4c 100644
--- a/net-analyzer/snort/snort-1.9.1.ebuild
+++ b/net-analyzer/snort/snort-1.9.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.1.ebuild,v 1.1 2003/03/04 11:05:42 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.1.ebuild,v 1.2 2003/03/06 10:18:41 aliz Exp $
-IUSE="ssl postgres mysql snmp"
+inherit eutils
+IUSE="ssl postgres mysql snmp"
S=${WORKDIR}/${P}
DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
SRC_URI="http://www.snort.org/dl/${P}.tar.gz"
@@ -11,7 +12,7 @@ HOMEPAGE="http://www.snort.org"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc "
+KEYWORDS="x86 sparc"
DEPEND="virtual/glibc
>=net-libs/libpcap-0.6.2-r1
@@ -32,7 +33,7 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${FILESDIR}/${P}-configure.patch
}
src_compile() {