summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-10 03:01:52 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-10 03:01:52 +0000
commit4ccdfba2c0fa5887e316e63724f88488a6bf78a6 (patch)
tree27971754e539e3343cafa1fa1aab75b2dd1e2dec /net-analyzer
parent2.12 release vbump (diff)
downloadgentoo-2-4ccdfba2c0fa5887e316e63724f88488a6bf78a6.tar.gz
gentoo-2-4ccdfba2c0fa5887e316e63724f88488a6bf78a6.tar.bz2
gentoo-2-4ccdfba2c0fa5887e316e63724f88488a6bf78a6.zip
different fixes
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethloop/ChangeLog11
-rw-r--r--net-analyzer/ethloop/Manifest13
-rw-r--r--net-analyzer/ethloop/ethloop-10-r1.ebuild30
-rw-r--r--net-analyzer/ethloop/files/digest-ethloop-10-r11
-rw-r--r--net-analyzer/ethloop/files/ethloop-10-gcc4.diff20
5 files changed, 63 insertions, 12 deletions
diff --git a/net-analyzer/ethloop/ChangeLog b/net-analyzer/ethloop/ChangeLog
index 11e899dd8bd0..fdcdb903218f 100644
--- a/net-analyzer/ethloop/ChangeLog
+++ b/net-analyzer/ethloop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ethloop
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ChangeLog,v 1.3 2004/08/16 10:17:30 eldad Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ChangeLog,v 1.4 2005/09/10 03:01:52 vanquirius Exp $
+
+*ethloop-10-r1 (10 Sep 2005)
+
+ 10 Sep 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/ethloop-10-gcc4.diff, +ethloop-10-r1.ebuild:
+ Fix hardcoded CC and CFLAGS, include string.h in ethloop.c to avoid warnings
+ and dosbin instead of dobin since this needs root priviledges anyway.
16 Aug 2004; Eldad Zack <eldad@gentoo.org> ethloop-10.ebuild:
x86 stable
diff --git a/net-analyzer/ethloop/Manifest b/net-analyzer/ethloop/Manifest
index 9632a4457452..ddfb6160ec85 100644
--- a/net-analyzer/ethloop/Manifest
+++ b/net-analyzer/ethloop/Manifest
@@ -1,14 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 47976a58b0918bb18022748a3f9732d5 ethloop-10-r1.ebuild 678
MD5 ed5f1c74527a881b5fec25002d8c734f ethloop-10.ebuild 564
MD5 51d476edc344bab8417560c06be2e8ff ChangeLog 560
MD5 3c5ff5e66702ce3fbb010eea8fb1da10 metadata.xml 244
MD5 70d7e3ea63f12f27c86a0ae488756544 files/digest-ethloop-10 56
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFBIIppT+MN7JbqCpMRAixMAJ94D1EqNmaZigSuVpdPYDYsJJSzBQCfexhX
-WyLDydJ1K1I+ekAc54So1NQ=
-=+SLd
------END PGP SIGNATURE-----
+MD5 70d7e3ea63f12f27c86a0ae488756544 files/digest-ethloop-10-r1 56
+MD5 31736f988b4e3a18957fe0e808f53841 files/ethloop-10-gcc4.diff 566
diff --git a/net-analyzer/ethloop/ethloop-10-r1.ebuild b/net-analyzer/ethloop/ethloop-10-r1.ebuild
new file mode 100644
index 000000000000..ec972751ce8f
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ethloop-10-r1.ebuild,v 1.1 2005/09/10 03:01:52 vanquirius Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/ethloop/ethloop10.tgz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ emake || die
+}
+
+src_install() {
+ dosbin ${S}/ethloop
+}
diff --git a/net-analyzer/ethloop/files/digest-ethloop-10-r1 b/net-analyzer/ethloop/files/digest-ethloop-10-r1
new file mode 100644
index 000000000000..bb011a938c3e
--- /dev/null
+++ b/net-analyzer/ethloop/files/digest-ethloop-10-r1
@@ -0,0 +1 @@
+MD5 df0caf522fab6f7324f19cfd2a1b3ea8 ethloop10.tgz 3912
diff --git a/net-analyzer/ethloop/files/ethloop-10-gcc4.diff b/net-analyzer/ethloop/files/ethloop-10-gcc4.diff
new file mode 100644
index 000000000000..9634c232335e
--- /dev/null
+++ b/net-analyzer/ethloop/files/ethloop-10-gcc4.diff
@@ -0,0 +1,20 @@
+diff --exclude='*~' -Naur ethloop.orig/ethloop.c ethloop/ethloop.c
+--- ethloop.orig/ethloop.c 2005-09-09 23:38:18.000000000 -0300
++++ ethloop/ethloop.c 2005-09-09 23:47:22.000000000 -0300
+@@ -13,6 +13,7 @@
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <signal.h>
++#include <string.h>
+
+ int sock;
+
+diff --exclude='*~' -Naur ethloop.orig/Makefile ethloop/Makefile
+--- ethloop.orig/Makefile 2005-09-09 23:38:18.000000000 -0300
++++ ethloop/Makefile 2005-09-09 23:40:47.000000000 -0300
+@@ -1,5 +1,3 @@
+-CC=gcc
+-CFLAGS=-g -O2
+ all: ethloop
+ run: all
+ ./ethloop