summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-19 23:56:13 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-19 23:56:13 +0000
commit5e36c59ed4fe8680141dc0f53dabd47f3960f809 (patch)
tree2fdbf24edd7092af0792ba1670d792d1c447dbb6 /net-analyzer
parentMask net-analyzer/net-snmp-5.6 too. (diff)
downloadgentoo-2-5e36c59ed4fe8680141dc0f53dabd47f3960f809.tar.gz
gentoo-2-5e36c59ed4fe8680141dc0f53dabd47f3960f809.tar.bz2
gentoo-2-5e36c59ed4fe8680141dc0f53dabd47f3960f809.zip
Version bump thanks to euscan.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nfdump/ChangeLog9
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.2.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index 4758a65a72d9..250695108d0d 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nfdump
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.17 2010/09/08 11:09:31 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.18 2011/04/19 23:56:13 jer Exp $
+
+*nfdump-1.6.2 (19 Apr 2011)
+
+ 19 Apr 2011; Jeroen Roovers <jer@gentoo.org> +nfdump-1.6.2.ebuild:
+ Version bump thanks to euscan.
08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> nfdump-1.6.1-r2.ebuild:
Stable on amd64 wrt bug #334479
diff --git a/net-analyzer/nfdump/nfdump-1.6.2.ebuild b/net-analyzer/nfdump/nfdump-1.6.2.ebuild
new file mode 100644
index 000000000000..91975b89390d
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.2.ebuild,v 1.1 2011/04/19 23:56:13 jer Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="http://nfdump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nfdump/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Fails to build readpcap:
+# https://sourceforge.net/tracker/?func=detail&aid=2996582&group_id=119350&atid=683752
+IUSE="compat15 debug ftconv nfprofile sflow"
+
+CDEPEND="
+ ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+ nfprofile? ( net-analyzer/rrdtool )"
+# readpcap? ( net-libs/libpcap )"
+DEPEND="${CDEPEND}
+ sys-devel/flex"
+RDEPEND=${CDEPEND}"
+ dev-lang/perl"
+
+src_prepare() {
+ if use ftconv; then
+ sed '/ftbuild.h/d' -i bin/ft2nfdump.c || die
+ sed 's:lib\(/ftlib.h\):include\1:' -i configure.in || die
+ fi
+ sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
+ eautoreconf
+}
+
+src_configure() {
+ # --without-ftconf is not handled well #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfprofile && echo "--enable-nfprofile") \
+ $(use_enable sflow) \
+ $(use_enable debug devel) \
+ $(use_enable compat15)
+ # $(use_enable readpcap) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}