summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-01-07 15:39:48 +0000
committerPeter Volkov <pva@gentoo.org>2007-01-07 15:39:48 +0000
commit96b8b50b11dfadda08331eccec1105b2bcea30f2 (patch)
tree0e5f66318c62ff5443b70f6485ab1838208d852b /net-analyzer
parentMask app-crypt/cli-crypt (diff)
downloadgentoo-2-96b8b50b11dfadda08331eccec1105b2bcea30f2.tar.gz
gentoo-2-96b8b50b11dfadda08331eccec1105b2bcea30f2.tar.bz2
gentoo-2-96b8b50b11dfadda08331eccec1105b2bcea30f2.zip
Include patches released by upstream. Should close vulnerabilities reported in bug #159278.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog10
-rw-r--r--net-analyzer/cacti/cacti-0.8.6i-r1.ebuild93
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6i-r115
3 files changed, 116 insertions, 2 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index ad4e9551f9ca..f45c105c6277 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.78 2006/11/23 19:46:07 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.79 2007/01/07 15:39:48 pva Exp $
+
+*cacti-0.8.6i-r1 (07 Jan 2007)
+
+ 07 Jan 2007; Peter Volkov <pva@gentoo.org> +cacti-0.8.6i-r1.ebuild:
+ Include patches released by upstream. Should close vulnerabilities reported
+ in bug #159278.
23 Nov 2006; Francesco Riosa <vivo@gentoo.org>
cacti-0.8.6h_p20060108-r2.ebuild, cacti-0.8.6i.ebuild:
diff --git a/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild b/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
new file mode 100644
index 000000000000..ff3c6cbc5e6c
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild,v 1.1 2007/01/07 15:39:48 pva Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+# (patched versions)
+HAS_PATCHES=1
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES="poller_output_remainder
+ dec06-vulnerability-poller-0.8.6i
+ dec06-vulnerability-scripts-0.8.6i
+ import_template_argument_space_removal"
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+# alpha doesn't have lighttpd keyworded yet
+# sparc doesn't have a stable keyword for lighttpd yet
+RDEPEND="!alpha? ( !sparc? ( !apache? ( !apache2? ( www-servers/lighttpd ) ) ) )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ require_php_with_use cli mysql xml
+ elif [ $PHP_VERSION = 4 ] ; then
+ require_php_with_use cli mysql xml expat
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6i-r1 b/net-analyzer/cacti/files/digest-cacti-0.8.6i-r1
new file mode 100644
index 000000000000..5518d1fcba6f
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6i-r1
@@ -0,0 +1,15 @@
+MD5 341b5828d95db91f81f5fbba65411d63 cacti-0.8.6i.tar.gz 1122700
+RMD160 2c5ea7dc594c455c710f8c253a25805883395a2f cacti-0.8.6i.tar.gz 1122700
+SHA256 3998dae625314309c58cea0fc1e48fb08cf4c2973013413f2726cdc5cf1ac6ac cacti-0.8.6i.tar.gz 1122700
+MD5 17b2997b6708a8bcf99c702b6cec047d dec06-vulnerability-poller-0.8.6i.patch 5994
+RMD160 cf60d715e6ae9285c6a0bd562fcd65290dcd1bdb dec06-vulnerability-poller-0.8.6i.patch 5994
+SHA256 4bb02a9022be25a1340e328f3c911a5386a8fb0c23a95285fcc8d8912dacc605 dec06-vulnerability-poller-0.8.6i.patch 5994
+MD5 5ce8da430a63ea8e675d0eef46e8b60a dec06-vulnerability-scripts-0.8.6i.patch 4358
+RMD160 8daaaf3d7d743206551502c3945c81fc689999c1 dec06-vulnerability-scripts-0.8.6i.patch 4358
+SHA256 89d48d5758ef0517f8d34a95dee02662af80efc8f988b87cfbc68c6e169c9f36 dec06-vulnerability-scripts-0.8.6i.patch 4358
+MD5 c56da30a12487610393aa2eaa7fe8c6a import_template_argument_space_removal.patch 634
+RMD160 c0f8a1c135a58cd45a87549d2a170814f6f36337 import_template_argument_space_removal.patch 634
+SHA256 d0a64ebd1fba7a2dcd6e7b6bb08f4dbc39f238b6c492f4874451736344a6e460 import_template_argument_space_removal.patch 634
+MD5 3b7ad717cbf8874fd96ea9f45d97cfbc poller_output_remainder.patch 1891
+RMD160 7aab97b71d5915ca8085174f69318cb223eb6c5e poller_output_remainder.patch 1891
+SHA256 2d8053d90dd363f4822072e58713b7d5f4b23825de4df2e9d429bfb5e8ec8201 poller_output_remainder.patch 1891