summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-19 22:18:51 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-19 22:18:51 +0000
commitb9f288fc1e654aa0ac6f8767592bc775849d47cc (patch)
treeaf9862b2e06bf3bdc3796160588f8bf6fb0504eb /net-analyzer
parentClean up gnome related masks. (diff)
downloadgentoo-2-b9f288fc1e654aa0ac6f8767592bc775849d47cc.tar.gz
gentoo-2-b9f288fc1e654aa0ac6f8767592bc775849d47cc.tar.bz2
gentoo-2-b9f288fc1e654aa0ac6f8767592bc775849d47cc.zip
Version bumps thanks to euscan. Make tcp-wrappers support optional.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/argus-clients/ChangeLog12
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.4.1.ebuild58
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.5.6.ebuild58
-rw-r--r--net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch23
4 files changed, 149 insertions, 2 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index a0f51892648a..5e3b03ee65c4 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/argus-clients
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.16 2010/10/10 11:05:46 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.17 2011/04/19 22:18:51 jer Exp $
+
+*argus-clients-3.0.5.6 (19 Apr 2011)
+*argus-clients-3.0.4.1 (19 Apr 2011)
+
+ 19 Apr 2011; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.4.1.ebuild,
+ +files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch,
+ +argus-clients-3.0.5.6.ebuild:
+ Version bumps thanks to euscan. Make tcp-wrappers support optional.
10 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
argus-clients-3.0.3.8.ebuild:
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.4.1.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.4.1.ebuild
new file mode 100644
index 000000000000..93edea7de4a4
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.4.1.ebuild,v 1.1 2011/04/19 22:18:51 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug geoip mysql tcpd"
+
+#sasl? ( >=dev-libs/cyrus-sasl-1.5.24 )
+MY_CDEPEND="net-libs/libpcap
+ net-analyzer/rrdtool[perl]
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )"
+
+# >=net-analyzer/argus-2.0.6[sasl?]"
+RDEPEND="${MY_CDEPEND}
+ >=net-analyzer/argus-3.0.2"
+
+DEPEND="${MY_CDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ for x in $(find . -name "Makefile.in"); do
+ sed -i "s:\$(CFLAGS):& \$(LDFLAGS) :" $x
+ done
+ epatch "${FILESDIR}"/${P}-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ # $(use_with sasl) \
+ econf \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra* || die "Failed to install ra*"
+ dodoc ChangeLog CREDITS README doc/{CHANGES,FAQ,HOW-TO} || die
+ doman man/man{1,5}/*
+}
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.5.6.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.5.6.ebuild
new file mode 100644
index 000000000000..744bfe876a1b
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.5.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.5.6.ebuild,v 1.1 2011/04/19 22:18:51 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug geoip mysql tcpd"
+
+#sasl? ( >=dev-libs/cyrus-sasl-1.5.24 )
+MY_CDEPEND="net-libs/libpcap
+ net-analyzer/rrdtool[perl]
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )"
+
+# >=net-analyzer/argus-2.0.6[sasl?]"
+RDEPEND="${MY_CDEPEND}
+ >=net-analyzer/argus-3.0.2"
+
+DEPEND="${MY_CDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ for x in $(find . -name "Makefile.in"); do
+ sed -i "s:\$(CFLAGS):& \$(LDFLAGS) :" $x
+ done
+ epatch "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ # $(use_with sasl) \
+ econf \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra* || die "Failed to install ra*"
+ dodoc ChangeLog CREDITS README doc/{CHANGES,FAQ,HOW-TO} || die
+ doman man/man{1,5}/*
+}
diff --git a/net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch b/net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch
new file mode 100644
index 000000000000..a08d974ce893
--- /dev/null
+++ b/net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch
@@ -0,0 +1,23 @@
+--- configure.ac.org 2011-01-28 18:26:54.000000000 +0100
++++ configure.ac 2011-04-20 00:09:37.000000000 +0200
+@@ -121,6 +121,12 @@
+ esac
+
+ AC_QOSIENT_THREADS(V_THREADS)
++
++AC_ARG_WITH(wrappers,
++ [ --with-wrappers build with libwrappers suuport],
++ with_wrappers="$withval",
++ with_wrappers="yes")
++if test "x$with_wrappers" != "xno"; then
+ AC_QOSIENT_TCPWRAP(V_WRAPDEP, V_INCLS)
+ if test ! -z "$V_WRAPDEP"; then
+ if test -f $V_WRAPDEP; then
+@@ -144,6 +150,7 @@
+ AC_DEFINE([HAVE_TCP_WRAPPER], [], [Using Tcp wrappers])
+ WRAPLIBS="$V_WRAPDEP"
+ fi
++fi
+
+ CURSESLIB=""
+