summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-26 09:02:51 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-26 09:02:51 +0000
commitd9a4f6dcc893bec4187afbe203b520fc51b59634 (patch)
treeb43372fa659ddbbf8c7bdf1a80e6df341335ff88 /net-analyzer
parentVersion bump, fixed security issue, bug #251044, thank Bruno Buss for report.... (diff)
downloadgentoo-2-d9a4f6dcc893bec4187afbe203b520fc51b59634.tar.gz
gentoo-2-d9a4f6dcc893bec4187afbe203b520fc51b59634.tar.bz2
gentoo-2-d9a4f6dcc893bec4187afbe203b520fc51b59634.zip
Fix building on 64bit systems due to implicit string prototypes.
(Portage version: 2.2_rc18/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.0.5-text2pcap-protos.patch18
-rw-r--r--net-analyzer/wireshark/wireshark-1.0.5.ebuild3
3 files changed, 25 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 12a9343706e5..c7382675507d 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.143 2008/12/18 18:20:26 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.144 2008/12/26 09:02:51 vapier Exp $
+
+ 26 Dec 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/wireshark-1.0.5-text2pcap-protos.patch, wireshark-1.0.5.ebuild:
+ Fix building on 64bit systems due to implicit string prototypes.
18 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
wireshark-1.0.5.ebuild:
diff --git a/net-analyzer/wireshark/files/wireshark-1.0.5-text2pcap-protos.patch b/net-analyzer/wireshark/files/wireshark-1.0.5-text2pcap-protos.patch
new file mode 100644
index 000000000000..eed2df16a70b
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.0.5-text2pcap-protos.patch
@@ -0,0 +1,18 @@
+defining _XOPEN_SOURCE to nothing means the oldest version which means glibc
+will not provide the strdup() prototype. this leads to an implicit decl which
+leads to a return type of "int" -- 32bits of a ptr on a 64bit arch leads to
+kaboom.
+
+https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=3161
+
+--- text2pcap.c
++++ text2pcap.c
+@@ -90,7 +90,7 @@
+ # define __USE_XOPEN
+ #endif
+ #ifndef _XOPEN_SOURCE
+-# define _XOPEN_SOURCE
++# define _XOPEN_SOURCE 600
+ #endif
+
+ #include <ctype.h>
diff --git a/net-analyzer/wireshark/wireshark-1.0.5.ebuild b/net-analyzer/wireshark/wireshark-1.0.5.ebuild
index 42f3192fbb6b..bcdf43ba02c9 100644
--- a/net-analyzer/wireshark/wireshark-1.0.5.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.5.ebuild,v 1.9 2008/12/18 18:20:26 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.5.ebuild,v 1.10 2008/12/26 09:02:51 vapier Exp $
EAPI=1
WANT_AUTOMAKE="1.9"
@@ -61,6 +61,7 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-0.99.7-asneeded.patch"
epatch "${FILESDIR}/${PN}-0.99.8-as-needed.patch"
epatch "${FILESDIR}/${P}-glib-1-build.patch"
+ epatch "${FILESDIR}"/${P}-text2pcap-protos.patch
cd "${S}/epan"
epatch "${FILESDIR}/wireshark-except-double-free.diff"