summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-06-24 05:31:48 +0000
committerJeroen Roovers <jer@gentoo.org>2015-06-24 05:31:48 +0000
commite005f03124de42fe3e4d864d6a0d90dcbe8a6ebd (patch)
treedce684c96bee043b0e534deee2bc1a20fb94b87b /net-analyzer
parentimprove deps (bug #553096) (diff)
downloadgentoo-2-e005f03124de42fe3e4d864d6a0d90dcbe8a6ebd.tar.gz
gentoo-2-e005f03124de42fe3e4d864d6a0d90dcbe8a6ebd.tar.bz2
gentoo-2-e005f03124de42fe3e4d864d6a0d90dcbe8a6ebd.zip
Emit PIC when USE=qt5 (bug #552440 by octoploid).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/wireshark-1.12.6.ebuild10
-rw-r--r--net-analyzer/wireshark/wireshark-1.99.7.ebuild10
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild10
4 files changed, 26 insertions, 10 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 676a1258232e..224d8e3be6a9 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.729 2015/06/21 06:16:25 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.730 2015/06/24 05:31:48 jer Exp $
+
+ 24 Jun 2015; Jeroen Roovers <jer@gentoo.org> wireshark-1.12.6.ebuild,
+ wireshark-1.99.7.ebuild, wireshark-99999999.ebuild:
+ Emit PIC when USE=qt5 (bug #552440 by octoploid).
21 Jun 2015; Mikle Kolyada <zlogene@gentoo.org> wireshark-1.12.6.ebuild:
x86 stable wrt bug #552434
diff --git a/net-analyzer/wireshark/wireshark-1.12.6.ebuild b/net-analyzer/wireshark/wireshark-1.12.6.ebuild
index c10897592543..97164ede8a4c 100644
--- a/net-analyzer/wireshark/wireshark-1.12.6.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.12.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.12.6.ebuild,v 1.5 2015/06/21 06:16:25 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.12.6.ebuild,v 1.6 2015/06/24 05:31:48 jer Exp $
EAPI=5
-inherit autotools eutils fcaps multilib qmake-utils qt4-r2 user
+inherit autotools eutils fcaps flag-o-matic multilib qmake-utils qt4-r2 user
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="http://www.wireshark.org/"
@@ -127,7 +127,11 @@ src_configure() {
fi
use qt4 && export QT_MIN_VERSION=4.6.0
- use qt5 && export QT_MIN_VERSION=5.3.0
+
+ if use qt5; then
+ export QT_MIN_VERSION=5.3.0
+ append-cxxflags -fPIC -DPIC
+ fi
# Hack around inability to disable doxygen/fop doc generation
use doc || export ac_cv_prog_HAVE_DOXYGEN=false
diff --git a/net-analyzer/wireshark/wireshark-1.99.7.ebuild b/net-analyzer/wireshark/wireshark-1.99.7.ebuild
index 355e345c9183..b53e5c743923 100644
--- a/net-analyzer/wireshark/wireshark-1.99.7.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.99.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.99.7.ebuild,v 1.1 2015/06/19 12:39:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.99.7.ebuild,v 1.2 2015/06/24 05:31:48 jer Exp $
EAPI=5
-inherit autotools eutils fcaps multilib qmake-utils qt4-r2 user
+inherit autotools eutils fcaps flag-o-matic multilib qmake-utils qt4-r2 user
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="http://www.wireshark.org/"
@@ -130,7 +130,11 @@ src_configure() {
fi
use qt4 && export QT_MIN_VERSION=4.6.0
- use qt5 && export QT_MIN_VERSION=5.3.0
+
+ if use qt5;then
+ export QT_MIN_VERSION=5.3.0
+ append-cxxflags -fPIC -DPIC
+ fi
# Hack around inability to disable doxygen/fop doc generation
use doc || export ac_cv_prog_HAVE_DOXYGEN=false
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 96ac8aee3659..1be25e409703 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-99999999.ebuild,v 1.14 2015/06/01 05:46:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-99999999.ebuild,v 1.15 2015/06/24 05:31:48 jer Exp $
EAPI=5
-inherit autotools eutils fcaps git-r3 multilib qmake-utils qt4-r2 user
+inherit autotools eutils fcaps flag-o-matic git-r3 multilib qmake-utils qt4-r2 user
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="http://www.wireshark.org/"
@@ -129,7 +129,11 @@ src_configure() {
fi
use qt4 && export QT_MIN_VERSION=4.6.0
- use qt5 && export QT_MIN_VERSION=5.3.0
+
+ if use qt5; then
+ export QT_MIN_VERSION=5.3.0
+ append-cxxflags -fPIC -DPIC
+ fi
# Hack around inability to disable doxygen/fop doc generation
use doc || export ac_cv_prog_HAVE_DOXYGEN=false