summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-14 20:43:19 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-14 20:43:19 +0000
commit2be1cea64d5ac6328aae405cb176844434e6b96a (patch)
treee3cc4975d9c7d53192e510ee8771e8fa100f1e70 /net-dialup/capisuite/capisuite-0.4.4-r1.ebuild
parentfixed gentoo-specific file context (Manifest recommit) (diff)
downloadgentoo-2-2be1cea64d5ac6328aae405cb176844434e6b96a.tar.gz
gentoo-2-2be1cea64d5ac6328aae405cb176844434e6b96a.tar.bz2
gentoo-2-2be1cea64d5ac6328aae405cb176844434e6b96a.zip
Correct dependencies. Partially solve bug #71187, blocked by #53889.
Diffstat (limited to 'net-dialup/capisuite/capisuite-0.4.4-r1.ebuild')
-rw-r--r--net-dialup/capisuite/capisuite-0.4.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-dialup/capisuite/capisuite-0.4.4-r1.ebuild b/net-dialup/capisuite/capisuite-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..bad7f6b11e24
--- /dev/null
+++ b/net-dialup/capisuite/capisuite-0.4.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.4-r1.ebuild,v 1.1 2004/11/14 20:43:19 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="An ISDN telecommunication suite"
+HOMEPAGE="http://www.capisuite.de"
+SRC_URI="http://www.capisuite.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ virtual/libc
+ net-dialup/capi4k-utils"
+DEPEND="${RDEPEND}
+ media-sound/sox
+ media-libs/tiff
+ virtual/ghostscript
+ virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf --localstatedir=/var \
+ --with-docdir=/usr/share/doc/${P} || die "econf failed."
+ emake || die "parallel make failed."
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed."
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/capisuite
+
+ keepdir /var/spool/capisuite/{done,failed,sendq,users}
+
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+}