summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-20 08:31:58 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-20 08:31:58 +0000
commit4ed0dffc27325a3933bcbe2085b03daf0ff1f0eb (patch)
tree2031cb4b42b631d86bda813592128089db34d26d /net-dialup/mingetty/mingetty-1.07.3.ebuild
parentadd two patches from basic (bug #66718) (Manifest recommit) (diff)
downloadgentoo-2-4ed0dffc27325a3933bcbe2085b03daf0ff1f0eb.tar.gz
gentoo-2-4ed0dffc27325a3933bcbe2085b03daf0ff1f0eb.tar.bz2
gentoo-2-4ed0dffc27325a3933bcbe2085b03daf0ff1f0eb.zip
version bump using Fedora 3 source rpm
Diffstat (limited to 'net-dialup/mingetty/mingetty-1.07.3.ebuild')
-rw-r--r--net-dialup/mingetty/mingetty-1.07.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-dialup/mingetty/mingetty-1.07.3.ebuild b/net-dialup/mingetty/mingetty-1.07.3.ebuild
new file mode 100644
index 000000000000..7b637bd991b5
--- /dev/null
+++ b/net-dialup/mingetty/mingetty-1.07.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/mingetty-1.07.3.ebuild,v 1.1 2004/11/20 08:31:58 mrness Exp $
+
+inherit rpm eutils
+
+MY_WORK=${PN}-${PV%.*}
+S=${WORKDIR}/${MY_WORK}
+MY_P=${MY_WORK}-${PV##*.}
+DESCRIPTION="A compact getty program for virtual consoles only."
+SRC_URI="ftp://rpmfind.net/linux/fedora/core/3/SRPMS/${MY_P}.src.rpm"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~hppa ~amd64 ~alpha ~sparc ~ia64 ~mips ~ppc64 ~s390"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd ${S}
+ epatch ../mingetty-1.00-opt.patch
+}
+
+src_compile() {
+ emake RPM_OPTS="${CFLAGS}" || die "compile failed"
+}
+
+src_install () {
+ dodir /sbin /usr/share/man/man8
+ emake DESTDIR=${D} install || die "install failed"
+}