summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-09-15 20:08:26 +0000
committerAlin Năstac <mrness@gentoo.org>2005-09-15 20:08:26 +0000
commit88dbd58a4aaac34e88347f121297f10c18526668 (patch)
tree8b6c3907589d831bc7626bcac817886583747ef8 /net-dialup/wvdial/wvdial-1.54.0-r1.ebuild
parentMark 1.1.1-r1 stable on alpha (diff)
downloadgentoo-2-88dbd58a4aaac34e88347f121297f10c18526668.tar.gz
gentoo-2-88dbd58a4aaac34e88347f121297f10c18526668.tar.bz2
gentoo-2-88dbd58a4aaac34e88347f121297f10c18526668.zip
append pkg-config --cflags/--libs libwvstreams (#106018)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-dialup/wvdial/wvdial-1.54.0-r1.ebuild')
-rw-r--r--net-dialup/wvdial/wvdial-1.54.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/wvdial/wvdial-1.54.0-r1.ebuild b/net-dialup/wvdial/wvdial-1.54.0-r1.ebuild
new file mode 100644
index 000000000000..e9282e95b649
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.54.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.54.0-r1.ebuild,v 1.1 2005/09/15 20:08:26 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Excellent program to automatically configure PPP sessions"
+HOMEPAGE="http://open.nit.ca/wiki/?page=WvDial"
+SRC_URI="http://open.nit.ca/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ net-dialup/ppp
+ >=net-libs/wvstreams-4.0.2-r1"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-destdir.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} `pkg-config --cflags libwvstreams`" \
+ LIBS="`pkg-config --libs libwvstreams`" || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc COPYING.LIB CHANGES FAQ MENUS README TODO
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Use wvdialconf to automagically generate a configuration file."
+ einfo
+ einfo "Users have to be member of the dialout AND the uucp group"
+ einfo "to use wvdial!"
+ einfo
+}