summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-06-20 09:40:56 +0000
committerAlin Năstac <mrness@gentoo.org>2009-06-20 09:40:56 +0000
commit298bdfc28c686ed2de1d633fe48a303339281484 (patch)
tree5613d1b2f21e88f66621846848765cf84af6a629 /net-dialup/wvdial
parentx11-misc/util-macros: drop old ebuilds (diff)
downloadgentoo-2-298bdfc28c686ed2de1d633fe48a303339281484.tar.gz
gentoo-2-298bdfc28c686ed2de1d633fe48a303339281484.tar.bz2
gentoo-2-298bdfc28c686ed2de1d633fe48a303339281484.zip
Fix compilation error related to glibc-2.10 (#271477).
Migrate to EAPI 2. (Portage version: 2.1.6.13/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-dialup/wvdial')
-rw-r--r--net-dialup/wvdial/ChangeLog10
-rw-r--r--net-dialup/wvdial/files/wvdial-1.60-dirent.patch15
-rw-r--r--net-dialup/wvdial/wvdial-1.60-r1.ebuild43
3 files changed, 66 insertions, 2 deletions
diff --git a/net-dialup/wvdial/ChangeLog b/net-dialup/wvdial/ChangeLog
index 0ab1d7cd3d50..b58425575eb3 100644
--- a/net-dialup/wvdial/ChangeLog
+++ b/net-dialup/wvdial/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/wvdial
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/ChangeLog,v 1.53 2008/12/14 18:38:28 loki_val Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/ChangeLog,v 1.54 2009/06/20 09:40:56 mrness Exp $
+
+*wvdial-1.60-r1 (20 Jun 2009)
+
+ 20 Jun 2009; Alin Năstac <mrness@gentoo.org>
+ +files/wvdial-1.60-dirent.patch, +wvdial-1.60-r1.ebuild:
+ Fix compilation error related to glibc-2.10 (#271477). Migrate to EAPI 2.
14 Dec 2008; Peter Alfredsen <loki_val@gentoo.org> metadata.xml:
Removing myself as maintainer, per email convo with mrness.
diff --git a/net-dialup/wvdial/files/wvdial-1.60-dirent.patch b/net-dialup/wvdial/files/wvdial-1.60-dirent.patch
new file mode 100644
index 000000000000..86f26df41780
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.60-dirent.patch
@@ -0,0 +1,15 @@
+diff -Nru wvdial-1.60.orig/wvmodemscan.cc wvdial-1.60/wvmodemscan.cc
+--- wvdial-1.60.orig/wvmodemscan.cc 2007-07-19 23:22:26.000000000 +0200
++++ wvdial-1.60/wvmodemscan.cc 2009-06-20 11:36:15.000000000 +0200
+@@ -496,10 +496,8 @@
+ }
+
+
+-static int filesort(const void *_e1, const void *_e2)
++static int filesort(const dirent **e1, const dirent **e2)
+ {
+- dirent const * const *e1 = (dirent const * const *)_e1;
+- dirent const * const *e2 = (dirent const * const *)_e2;
+ const char *p1, *p2;
+ int diff;
+
diff --git a/net-dialup/wvdial/wvdial-1.60-r1.ebuild b/net-dialup/wvdial/wvdial-1.60-r1.ebuild
new file mode 100644
index 000000000000..ddf0ce5059bc
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.60-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.60-r1.ebuild,v 1.1 2009/06/20 09:40:56 mrness Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Excellent program to automatically configure PPP sessions"
+HOMEPAGE="http://alumnit.ca/wiki/?WvDial"
+SRC_URI="http://alumnit.ca/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+COMMON_DEPEND=">=net-libs/wvstreams-4.4"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-destdir.patch"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ epatch "${FILESDIR}/${P}-dirent.patch"
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install || die "make install failed"
+
+ dodoc CHANGES FAQ MENUS README TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "Use wvdialconf to automagically generate a configuration file."
+ elog
+ elog "Users have to be member of the dialout AND the uucp group"
+ elog "to use wvdial!"
+ elog
+}