summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2010-09-19 11:31:22 +0000
committerAlin Năstac <mrness@gentoo.org>2010-09-19 11:31:22 +0000
commit287b1f2ed25c64a25a61aa973fc47f491a729d8e (patch)
tree679abc36dd0d3c7f70a638482f637401315dc982 /net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-287b1f2ed25c64a25a61aa973fc47f491a729d8e.tar.gz
gentoo-2-287b1f2ed25c64a25a61aa973fc47f491a729d8e.tar.bz2
gentoo-2-287b1f2ed25c64a25a61aa973fc47f491a729d8e.zip
Fix lns IP allocation by removing flag-o-matic inheritance (FFLAGS is used in Makefile).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild')
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild b/net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..7273d731bc98
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.2.6-r1.ebuild,v 1.1 2010/09/19 11:31:22 mrness Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dnsretry"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-qa-fixes.patch
+ use dnsretry && epatch "${FILESDIR}"/${PN}-dnsretry.patch
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CREDITS README.xl2tpd \
+ doc/README.patents doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/xl2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/xl2tpd/l2tp-secrets"
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}"/xl2tpd-init xl2tpd
+
+ keepdir /var/run/xl2tpd
+}