summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Jones <ashmodai@gentoo.org>2002-05-22 20:16:21 +0000
committerMike Jones <ashmodai@gentoo.org>2002-05-22 20:16:21 +0000
commitb820d92a2f782fde82117d4d74de8650ff93de3a (patch)
treeada958a6d2242be4ef3446655e99f21fce240297 /net-dialup
parentAdded optional MPPE support to pppd. (diff)
downloadgentoo-2-b820d92a2f782fde82117d4d74de8650ff93de3a.tar.gz
gentoo-2-b820d92a2f782fde82117d4d74de8650ff93de3a.tar.bz2
gentoo-2-b820d92a2f782fde82117d4d74de8650ff93de3a.zip
Adding -r9 ebuild to the directory.
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r9.ebuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/net-dialup/ppp/ppp-2.4.1-r9.ebuild b/net-dialup/ppp/ppp-2.4.1-r9.ebuild
new file mode 100644
index 000000000000..e88358a8e66f
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r9.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1-r9.ebuild,v 1.1 2002/05/22 20:16:21 ashmodai Exp $
+
+# modified by Christian Loitsch <gentoo00@loitsch.org>
+# modified by Mike Jones <ashmodai@gentoo.org>
+
+S=${WORKDIR}/${P}.pppoe4
+DESCRIPTION="Point-to-point protocol - patched for pppoe"
+SRC_URI="http://www.shoshin.uwaterloo.ca/~mostrows/${P}-pppoe4.tgz"
+HOMEPAGE="http://www.shoshin.uwaterloo.ca/~mostrows/index.html"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/pppd"
+
+src_compile() {
+
+ use crypt && {
+ zcat ${FILESDIR}/ppp-2.4.1-openssl-0.9.6-mppe-patch.gz | patch -p1
+ patch -p1 < ${FILESDIR}/ppp-2.4.1-MSCHAPv2-fix.patch
+ }
+
+ ./configure --prefix=/usr || die
+
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ Makefile.orig > Makefile
+ cd plugins
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd pppoe
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g :CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../../../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS= -O:COPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+
+ export CC=gcc
+
+ emake || die
+}
+
+src_install() {
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+
+ dodir /etc/ppp/peers
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+
+ dolib.so pppd/plugins/minconn.so
+ dolib.so pppd/plugins/passprompt.so
+ dolib.so pppd/plugins/pppoe/pppoe.so
+ dodir /usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ mv ${D}/usr/lib/*.so ${D}/usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.ppp ppp
+
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+ dohtml ${FILESDIR}/pppoe.html
+
+# This will have to be updated to work with the new net.ppp0
+# # Added a couple scripts to simplify dialing up
+# # borrowed from debian, man they got some nice little apps :-)
+# dosbin ${FILESDIR}/pon
+# dosbin ${FILESDIR}/poff
+# doman ${FILESDIR}/pon.1
+}
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}dev/.devfsd ]
+ then
+ if [ ! -e ${ROOT}dev/ppp ]; then
+ mknod ${ROOT}dev/ppp c 108 0
+ fi
+ fi
+ if [ "$ROOT" = "/" ]
+ then
+ /usr/sbin/update-modules
+ fi
+ einfo "to enable kernel-pppoe read html/pppoe.html in the doc-directory"
+}