summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-06 05:26:11 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-06 05:26:11 +0000
commitd9e1637c60eabc4e612b0509cfb4368aaf599963 (patch)
tree7a85dadc90faded347df7b51cf110092e4976704 /net-dialup
parentadd net-dialup/ivcall:softfax (diff)
downloadgentoo-2-d9e1637c60eabc4e612b0509cfb4368aaf599963.tar.gz
gentoo-2-d9e1637c60eabc4e612b0509cfb4368aaf599963.tar.bz2
gentoo-2-d9e1637c60eabc4e612b0509cfb4368aaf599963.zip
add soft fax support (#88087) and mark stable on x86
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ivcall/ChangeLog8
-rw-r--r--net-dialup/ivcall/Manifest14
-rw-r--r--net-dialup/ivcall/files/digest-ivcall-0.4-r11
-rw-r--r--net-dialup/ivcall/ivcall-0.4-r1.ebuild28
-rw-r--r--net-dialup/ivcall/ivcall-0.4.ebuild4
5 files changed, 41 insertions, 14 deletions
diff --git a/net-dialup/ivcall/ChangeLog b/net-dialup/ivcall/ChangeLog
index 16a994c2c08b..9242b648c756 100644
--- a/net-dialup/ivcall/ChangeLog
+++ b/net-dialup/ivcall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/ivcall
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ivcall/ChangeLog,v 1.2 2005/01/31 23:29:24 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ivcall/ChangeLog,v 1.3 2005/04/06 05:26:11 mrness Exp $
+
+*ivcall-0.4-r1 (06 Apr 2005)
+
+ 06 Apr 2005; Alin Nastac <mrness@gentoo.org> ivcall-0.4.ebuild,
+ +ivcall-0.4-r1.ebuild:
+ Add soft fax support (#88087) and mark 0.4 version stable on x86.
*ivcall-0.4 (01 Feb 2005)
diff --git a/net-dialup/ivcall/Manifest b/net-dialup/ivcall/Manifest
index 446127ee51e4..34adb79d6b99 100644
--- a/net-dialup/ivcall/Manifest
+++ b/net-dialup/ivcall/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 ec39e39bbf3b587f35dbb9ad55c407b8 ivcall-0.4.ebuild 737
+MD5 514b1f3a5f607c16bf784fb0aa50ab8a ivcall-0.4-r1.ebuild 791
+MD5 39619436100b1a4cbd68b115f28acff6 ivcall-0.4.ebuild 736
MD5 c94b0dfdbd5136f198faafda120b63d9 ivcall-0.3.ebuild 736
MD5 00327f34a4df8752d1b9e7c2b2694487 ChangeLog 575
MD5 c1142dc0a0ffc5e8cbaac0db478de330 metadata.xml 252
MD5 f75547c2596e1e493f26174a0940c024 files/digest-ivcall-0.3 61
MD5 1062d5f96c51d0af7a720d98495a0ba3 files/digest-ivcall-0.4 62
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFB/r98jiC39V7gKu0RAj4kAJ40o2x2cAcDU1a0Be+HMOo+lUQssACeMy/j
-oyowWyOIPJuJbXHUIa2PneY=
-=P7zw
------END PGP SIGNATURE-----
+MD5 1062d5f96c51d0af7a720d98495a0ba3 files/digest-ivcall-0.4-r1 62
diff --git a/net-dialup/ivcall/files/digest-ivcall-0.4-r1 b/net-dialup/ivcall/files/digest-ivcall-0.4-r1
new file mode 100644
index 000000000000..3b23a1dd78be
--- /dev/null
+++ b/net-dialup/ivcall/files/digest-ivcall-0.4-r1
@@ -0,0 +1 @@
+MD5 643619c81f83ba0a05aa2497ce12c035 ivcall-0.4.tar.gz 112244
diff --git a/net-dialup/ivcall/ivcall-0.4-r1.ebuild b/net-dialup/ivcall/ivcall-0.4-r1.ebuild
new file mode 100644
index 000000000000..f7105de21559
--- /dev/null
+++ b/net-dialup/ivcall/ivcall-0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ivcall/ivcall-0.4-r1.ebuild,v 1.1 2005/04/06 05:26:11 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Utility for making automated telephone calls via ISDN"
+HOMEPAGE="http://0pointer.de/lennart/projects/ivcall/"
+SRC_URI="http://0pointer.de/lennart/projects/ivcall/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="softfax"
+DEPEND="net-dialup/isdn4k-utils
+ softfax? ( >=media-libs/spandsp-0.0.2_pre10 )"
+
+src_compile() {
+ local myconf="--disable-lynx --disable-xmltoman"
+ econf $myconf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dohtml doc/*.{html,css}
+ dodoc doc/README
+}
diff --git a/net-dialup/ivcall/ivcall-0.4.ebuild b/net-dialup/ivcall/ivcall-0.4.ebuild
index ce9237f081c8..22036f1b4263 100644
--- a/net-dialup/ivcall/ivcall-0.4.ebuild
+++ b/net-dialup/ivcall/ivcall-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ivcall/ivcall-0.4.ebuild,v 1.1 2005/01/31 23:29:24 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ivcall/ivcall-0.4.ebuild,v 1.2 2005/04/06 05:26:11 mrness Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://0pointer.de/lennart/projects/ivcall/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="net-dialup/isdn4k-utils"