summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-09-25 19:17:06 +0000
committerSven Wegener <swegener@gentoo.org>2007-09-25 19:17:06 +0000
commit8359e204255736c48c3564c017ee16f85b291715 (patch)
tree99df1282f4a1000b814add9439ccf905ce540237 /net-dns/avahi
parentNew series for Gnome 2.20 (diff)
downloadgentoo-2-8359e204255736c48c3564c017ee16f85b291715.tar.gz
gentoo-2-8359e204255736c48c3564c017ee16f85b291715.tar.bz2
gentoo-2-8359e204255736c48c3564c017ee16f85b291715.zip
Adjust ipv6 patch for 0.6.21, bug #193646.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-dns/avahi')
-rw-r--r--net-dns/avahi/ChangeLog6
-rw-r--r--net-dns/avahi/avahi-0.6.21.ebuild4
-rw-r--r--net-dns/avahi/files/avahi-0.6.21-no-ipv6.patch35
3 files changed, 42 insertions, 3 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index 85c3cd51a2ec..d0721b12efa2 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.127 2007/09/25 19:14:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.128 2007/09/25 19:17:06 swegener Exp $
+
+ 25 Sep 2007; Sven Wegener <swegener@gentoo.org>
+ +files/avahi-0.6.21-no-ipv6.patch, avahi-0.6.21.ebuild:
+ Adjust ipv6 patch for 0.6.21, bug #193646.
25 Sep 2007; Sven Wegener <swegener@gentoo.org>
+files/avahi-0.6.21-no-browse-domains-segfault.patch, avahi-0.6.21.ebuild:
diff --git a/net-dns/avahi/avahi-0.6.21.ebuild b/net-dns/avahi/avahi-0.6.21.ebuild
index 84f214768ddc..a73a1a41866d 100644
--- a/net-dns/avahi/avahi-0.6.21.ebuild
+++ b/net-dns/avahi/avahi-0.6.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 2000-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.21.ebuild,v 1.6 2007/09/25 19:14:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.21.ebuild,v 1.7 2007/09/25 19:17:06 swegener Exp $
inherit eutils mono python qt3 qt4
@@ -96,7 +96,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.6.1-no-ipv6.patch
+ epatch "${FILESDIR}"/${P}-no-ipv6.patch
epatch "${FILESDIR}"/${P}-dbus-compat.patch
epatch "${FILESDIR}"/${P}-browse-help.patch
epatch "${FILESDIR}"/${P}-service_name_chosen.patch
diff --git a/net-dns/avahi/files/avahi-0.6.21-no-ipv6.patch b/net-dns/avahi/files/avahi-0.6.21-no-ipv6.patch
new file mode 100644
index 000000000000..ef7c33caa5f6
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.21-no-ipv6.patch
@@ -0,0 +1,35 @@
+uClibc systems dont define IPV6_V6ONLY when USE=-ipv6
+
+--- avahi-core/socket.c
++++ avahi-core/socket.c
+@@ -372,6 +372,7 @@
+ }
+
+ int avahi_open_socket_ipv6(int no_reuse) {
++#ifdef IPV6_V6ONLY
+ struct sockaddr_in6 sa, local;
+ int fd = -1, yes, r;
+ int ttl;
+@@ -437,6 +438,7 @@
+ fail:
+ if (fd >= 0)
+ close(fd);
++#endif
+
+ return -1;
+ }
+@@ -936,6 +938,7 @@
+ }
+
+ int avahi_open_unicast_socket_ipv6(void) {
++#ifdef IPV6_V6ONLY
+ struct sockaddr_in6 local;
+ int fd = -1, yes;
+
+@@ -977,5 +980,6 @@
+ if (fd >= 0)
+ close(fd);
+
++#endif
+ return -1;
+ }