summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-12 08:37:18 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-12 08:37:18 +0000
commit012c5be1e84ab8fc2cf4d2af182c5f40df300930 (patch)
tree12329b1628a1ed3ca5c3d9f06dbb221c8dc53084 /net-dns/bind
parentFix X_ShmAttach not declared. Bug #292508 (diff)
downloadgentoo-2-012c5be1e84ab8fc2cf4d2af182c5f40df300930.tar.gz
gentoo-2-012c5be1e84ab8fc2cf4d2af182c5f40df300930.tar.bz2
gentoo-2-012c5be1e84ab8fc2cf4d2af182c5f40df300930.zip
Fix initscript bugs #279568 and #257632.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/bind')
-rw-r--r--net-dns/bind/ChangeLog8
-rw-r--r--net-dns/bind/bind-9.6.1_p1-r1.ebuild306
-rw-r--r--net-dns/bind/files/named.confd-r320
-rw-r--r--net-dns/bind/files/named.init-r7140
4 files changed, 473 insertions, 1 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index cb5ce5343c6f..db73efb119ec 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/bind
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.246 2009/11/12 07:56:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.247 2009/11/12 08:37:18 scarabeus Exp $
+
+*bind-9.6.1_p1-r1 (12 Nov 2009)
+
+ 12 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +bind-9.6.1_p1-r1.ebuild, +files/named.confd-r3, +files/named.init-r7:
+ Fix initscript bugs #279568 and #257632.
12 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org> bind-9.6.1_p1.ebuild:
Fix collision issues. Per bug #276966 and #282565.
diff --git a/net-dns/bind/bind-9.6.1_p1-r1.ebuild b/net-dns/bind/bind-9.6.1_p1-r1.ebuild
new file mode 100644
index 000000000000..f85159319c66
--- /dev/null
+++ b/net-dns/bind/bind-9.6.1_p1-r1.ebuild
@@ -0,0 +1,306 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.6.1_p1-r1.ebuild,v 1.1 2009/11/12 08:37:18 scarabeus Exp $
+
+EAPI="2"
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_PV="${PV/_p1/-P1}"
+MY_P="${PN}-${MY_PV}"
+
+SDB_LDAP_VER="1.1.0"
+
+DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
+HOMEPAGE="https://www.isc.org/software/bind"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz
+ sdb-ldap? ( mirror://gentoo/bind-sdb-ldap-${SDB_LDAP_VER}.tar.bz2 )
+ doc? ( mirror://gentoo/dyndns-samples.tbz2 )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads
+ resolvconf urandom sdb-ldap xml"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ mysql? ( >=virtual/mysql-4.0 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/idnkit )
+ postgres? ( virtual/postgresql-base )
+ threads? ( >=sys-libs/libcap-2.1.0 )
+ xml? ( dev-libs/libxml2 )"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bind )
+ resolvconf? ( net-dns/openresolv )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use threads && {
+ ewarn
+ ewarn "If you're in vserver enviroment, you're probably want to"
+ ewarn "disable threads support because of linux capabilities dependency"
+ ewarn
+ }
+
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
+}
+
+src_prepare() {
+ # bug 278364 (workaround)
+ epatch "${FILESDIR}/${PN}-9.6.1-parallel.patch"
+
+ # Adjusting PATHs in manpages
+ for i in bin/{named/named.8,check/named-checkconf.8,rndc/rndc.8} ; do
+ sed -i \
+ -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ "${i}" || die "sed failed, ${i} doesn't exist"
+ done
+
+ use dlz && epatch "${FILESDIR}"/${PN}-9.4.0-dlzbdb-close_cursor.patch
+
+ # bind fails to reconnect to MySQL5 databases, bug #180720, patch by Nicolas Brousse
+ # (http://www.shell-tips.com/2007/09/04/bind-950-patch-dlz-mysql-5-for-auto-reconnect/)
+ use dlz && use mysql && has_version ">=dev-db/mysql-5" && epatch "${FILESDIR}"/bind-dlzmysql5-reconnect.patch
+
+ # should be installed by bind-tools
+ sed -i -e "s:nsupdate ::g" bin/Makefile.in || die
+
+ # sdb-ldap patch as per bug #160567
+ # Upstream URL: http://bind9-ldap.bayour.com/
+ use sdb-ldap && epatch "${WORKDIR}"/sdb-ldap/${PN}-sdb-ldap-${SDB_LDAP_VER}.patch
+
+ # bug #220361
+ rm {aclocal,libtool}.m4
+ WANT_AUTOCONF=2.5 AT_NO_RECURSIVE=1 eautoreconf
+
+ # bug #151839
+ sed -i -e \
+ 's:struct isc_socket {:#undef SO_BSDCOMPAT\n\nstruct isc_socket {:' \
+ lib/isc/unix/socket.c || die
+
+ # remove useless c++ checks
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf=""
+
+ use dlz && {
+ myconf="${myconf} --with-dlz-filesystem --with-dlz-stub"
+ use postgres && myconf="${myconf} --with-dlz-postgres"
+ use mysql && myconf="${myconf} --with-dlz-mysql"
+ use berkdb && myconf="${myconf} --with-dlz-bdb"
+ use ldap && myconf="${myconf} --with-dlz-ldap"
+ use odbc && myconf="${myconf} --with-dlz-odbc"
+ }
+
+ if use threads; then
+ if use dlz && use mysql; then
+ ewarn
+ ewarn "MySQL uses thread local storage in its C api. Thus MySQL"
+ ewarn "requires that each thread of an application execute a MySQL"
+ ewarn "\"thread initialization\" to setup the thread local storage."
+ ewarn "This is impossible to do safely while staying within the DLZ"
+ ewarn "driver API. This is a limitation caused by MySQL, and not"
+ ewarn "the DLZ API."
+ ewarn "Because of this BIND MUST only run with a single thread when"
+ ewarn "using the MySQL driver."
+ ewarn
+ myconf="${myconf} --disable-linux-caps --disable-threads"
+ ewarn "Threading support disabled"
+ epause 10
+ else
+ myconf="${myconf} --enable-linux-caps --enable-threads"
+ einfo "Threading support enabled"
+ fi
+ else
+ myconf="${myconf} --disable-linux-caps --disable-threads"
+ fi
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug #158664
+ gcc-specs-ssp && replace-flags -O[23s] -O
+ export BUILD_CC="${CBUILD}-gcc"
+ econf \
+ --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --with-libtool \
+ $(use_with ssl openssl) \
+ $(use_with idn) \
+ $(use_enable ipv6) \
+ $(use_with xml libxml2) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc CHANGES FAQ KNOWN-DEFECTS README || die
+
+ if use idn; then
+ dodoc README.idnkit || die
+ fi
+
+ if use doc; then
+ dodoc doc/arm/Bv9ARM.pdf || die
+
+ docinto misc
+ dodoc doc/misc/* || die
+
+ # might a 'html' useflag make sense?
+ docinto html
+ dohtml -r doc/arm/* || die
+
+ docinto draft
+ dodoc doc/draft/* || die
+
+ docinto rfc
+ dodoc doc/rfc/* || die
+
+ docinto contrib
+ dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl || die
+
+ # some handy-dandy dynamic dns examples
+ cd "${D}"/usr/share/doc/${PF}
+ tar xf "${DISTDIR}"/dyndns-samples.tbz2 || die
+ fi
+
+ newenvd "${FILESDIR}"/10bind.env 10bind || die
+
+ keepdir /var/bind/sec
+
+ insinto /etc/bind
+ newins "${FILESDIR}"/named.conf-r3 named.conf || die
+
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind
+ doins "${FILESDIR}"/named.ca || die
+
+ insinto /var/bind/pri
+ newins "${FILESDIR}"/127.zone-r1 127.zone || die
+ newins "${FILESDIR}"/localhost.zone-r3 localhost.zone || die
+
+ newinitd "${FILESDIR}"/named.init-r7 named || die
+ newconfd "${FILESDIR}"/named.confd-r3 named || die
+
+ dosym /var/bind/named.ca /var/bind/root.cache
+ dosym /var/bind/pri /etc/bind/pri
+ dosym /var/bind/sec /etc/bind/sec
+
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f "${D}"/usr/share/man/man1/{dig,host,nslookup}.1*
+ rm -f "${D}"/usr/share/man/man8/{dnssec-keygen,nsupdate}.8*
+ rm -f "${D}"/usr/bin/{dig,host,nslookup,dnssec-keygen,nsupdate}
+ rm -f "${D}"/usr/sbin/{dig,host,nslookup,dnssec-keygen,nsupdate}
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ if [ -c /dev/urandom ]; then
+ einfo "Using /dev/urandom for generating rndc.key"
+ /usr/sbin/rndc-confgen -r /dev/urandom -a -u named
+ echo
+ else
+ einfo "Using /dev/random for generating rndc.key"
+ /usr/sbin/rndc-confgen -a -u named
+ echo
+ fi
+ fi
+
+ install -d -o named -g named "${ROOT}"/var/run/named \
+ "${ROOT}"/var/bind/{pri,sec} "${ROOT}"/var/log/named
+ chown -R named:named "${ROOT}"/var/bind
+
+ elog "The default zone files are now installed as *.zone,"
+ elog "be careful merging config files if you have modified"
+ elog "/var/bind/pri/127 or /var/bind/pri/localhost"
+ elog
+ elog "You can edit /etc/conf.d/named to customize named settings"
+ elog
+ elog "The BIND ebuild now includes chroot support."
+ elog "If you like to run bind in chroot AND this is a new install OR"
+ elog "your bind doesn't already run in chroot, simply run:"
+ elog "\`emerge --config '=${CATEGORY}/${PF}'\`"
+ elog "Before running the above command you might want to change the chroot"
+ elog "dir in /etc/conf.d/named. Otherwise /chroot/dns will be used."
+ elog
+ elog "Recently verisign added a wildcard A record to the .COM and .NET TLD"
+ elog "zones making all .com and .net domains appear to be registered"
+ elog "This causes many problems such as breaking important anti-spam checks"
+ elog "which verify source domains exist. ISC released a patch for BIND which"
+ elog "adds 'delegation-only' zones to allow admins to return the .com and .net"
+ elog "domain resolution to their normal function."
+ elog
+ elog "There is no need to create a com or net data file. Just the"
+ elog "entries to the named.conf file is enough."
+ elog
+ elog " zone "com" IN { type delegation-only; };"
+ elog " zone "net" IN { type delegation-only; };"
+
+ ewarn
+ ewarn "BIND >=9.2.5 makes the priority argument to MX records mandatory"
+ ewarn "when it was previously optional. If the priority is missing, BIND"
+ ewarn "won't load the zone file at all."
+ ewarn
+
+ ewarn "NOTE: as of 'bind-9.6.1' the chroot part of the init-script got some major changes."
+}
+
+pkg_config() {
+ CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/named 2>/dev/null`
+ EXISTS="no"
+
+ if [ -z "${CHROOT}" -a ! -d "/chroot/dns" ]; then
+ CHROOT="/chroot/dns"
+ elif [ -d ${CHROOT} ]; then
+ eerror; eerror "${CHROOT:-/chroot/dns} already exists. Quitting."; eerror; EXISTS="yes"
+ fi
+
+ if [ ! "$EXISTS" = yes ]; then
+ einfo ; einfon "Setting up the chroot directory..."
+
+ mkdir -m 750 -p ${CHROOT}
+ mkdir -p ${CHROOT}/{dev,proc,etc/bind,var/{run,log}/named,var/bind}
+ chown -R named:named ${CHROOT}
+ chown root:named ${CHROOT}
+
+ cp /etc/localtime ${CHROOT}/etc/localtime
+
+ mknod ${CHROOT}/dev/zero c 1 5
+ chmod 666 ${CHROOT}/dev/zero
+
+ if use urandom; then
+ mknod ${CHROOT}/dev/urandom c 1 9
+ chmod 666 ${CHROOT}/dev/urandom
+ else
+ mknod ${CHROOT}/dev/random c 1 8
+ chmod 666 ${CHROOT}/dev/random
+ fi
+
+ if [ -f '/etc/syslog-ng/syslog-ng.conf' ]; then
+ echo "source jail { unix-stream(\"${CHROOT}/dev/log\"); };" >>/etc/syslog-ng/syslog-ng.conf
+ fi
+
+ grep -q "^#[[:blank:]]\?CHROOT" /etc/conf.d/named ; RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ sed -i 's/^# \?\(CHROOT.*\)$/\1/' /etc/conf.d/named 2>/dev/null
+ fi
+ else
+ ewarn "NOTE: as of 'bind-9.6.1' the chroot part of the init-script got some major changes."
+ fi
+}
diff --git a/net-dns/bind/files/named.confd-r3 b/net-dns/bind/files/named.confd-r3
new file mode 100644
index 000000000000..02fa8980c9a5
--- /dev/null
+++ b/net-dns/bind/files/named.confd-r3
@@ -0,0 +1,20 @@
+# Set various named options here.
+#
+OPTIONS=""
+
+# Set this to the number of processors you want bind to use.
+# Leave this unchanged if you want bind to automatically detect the number
+#CPU="1"
+
+# If you wish to run bind in a chroot, run:
+# emerge --config =<bind-version>
+# and un-comment the following line.
+# You can specify a different chroot directory but MAKE SURE it's empty.
+# CHROOT="/chroot/dns"
+
+# Default pid file location
+PIDFILE="${CHROOT}/var/run/named/named.pid"
+
+# Scheduling priority: 19 is the lowest and -20 is the highest.
+#
+NAMED_NICELEVEL="0"
diff --git a/net-dns/bind/files/named.init-r7 b/net-dns/bind/files/named.init-r7
new file mode 100644
index 000000000000..0ad8dca54cb1
--- /dev/null
+++ b/net-dns/bind/files/named.init-r7
@@ -0,0 +1,140 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/files/named.init-r7,v 1.1 2009/11/12 08:37:16 scarabeus Exp $
+
+opts="start stop reload restart"
+
+depend() {
+ need net
+ use logger
+ after pg_autovacuum postgresql mysql ldap
+ provide dns
+}
+
+_mount() {
+ local from
+ local to
+ local opts
+
+ if [[ $# -lt 3 ]];
+ then
+ eerror "_mount(): to few arguments"
+ return 1
+ fi
+
+ from=$1
+ to=$2
+ shift 2
+
+ opts="${*}"
+ shift $#
+
+ if [[ -z $(grep "${to}" /proc/mounts) ]];
+ then
+ einfo "mounting ${from} to ${to}"
+ mount ${from} ${to} ${opts} || return 1
+ fi
+}
+
+_umount() {
+ local dir=$1
+
+ if [[ -n $(grep "${dir}" /proc/mounts) ]];
+ then
+ einfo "umount ${dir}"
+ umount ${dir}
+ fi
+}
+
+checkconfig() {
+ if [ ! -f ${CHROOT}/etc/bind/named.conf ] ; then
+ eerror "No ${CHROOT}/etc/bind/named.conf file exists!"
+ fi
+
+ # In case someone have $CPU set in /etc/conf.d/named
+ if [ ${CPU} ] ; then
+ CPU="-n ${CPU}"
+ fi
+
+ # as suggested in bug #107724
+ [ -n "${PIDFILE}" ] || PIDFILE=${CHROOT}$(\
+ egrep -v \
+ "^([[:cntrl:] ]+(#|//|/\*)|(#|//|/\*))" \
+ ${CHROOT}/etc/bind/named.conf \
+ | egrep -o -m1 "pid\-file +\".+\" *;" \
+ | cut -d\" -f2
+ )
+
+ KEY="${CHROOT}/etc/bind/rndc.key"
+}
+
+start() {
+ ebegin "Starting ${CHROOT:+chrooted }named"
+
+ if [[ -n ${CHROOT} ]];
+ then
+ einfo "Mounting chroot dirs"
+ _mount /etc/bind ${CHROOT}/etc/bind -o bind
+ _mount /var/bind ${CHROOT}/var/bind -o bind
+ _mount /var/log/named ${CHROOT}/var/log/named -o bind
+ fi
+
+ checkconfig || return 1
+
+ start-stop-daemon --start --quiet --pidfile ${PIDFILE} \
+ --nicelevel ${NAMED_NICELEVEL:-0} \
+ --exec /usr/sbin/named \
+ -- -u named ${CPU} ${OPTIONS} ${CHROOT:+-t} ${CHROOT}
+ eend $?
+}
+
+stop() {
+ local reported=0
+
+ ebegin "Stopping ${CHROOT:+chrooted }named"
+ checkconfig || return 2
+ if [ -f $KEY ] ; then
+ rndc -k $KEY stop &>/dev/null
+ else
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --exec /usr/sbin/named -- stop
+ fi
+
+ if [[ -n ${CHROOT} ]];
+ then
+ einfo "Umounting chroot dirs"
+
+ # just to be sure everything gets clean
+ while [[ -n $(fuser ${CHROOT} 2>&1) ]]
+ do
+ if [[ ${reported} -eq 0 ]];
+ then
+ einfo "Waiting until all named processes are stopped"
+ reported=1
+ fi
+ sleep 1
+ done
+
+ _umount ${CHROOT}/etc/bind
+ _umount ${CHROOT}/var/log/named
+ _umount ${CHROOT}/var/bind
+ fi
+
+ eend $?
+}
+
+reload() {
+ checkconfig || return 3
+ if [ ! -f $PIDFILE ] ; then
+ /etc/init.d/named start &>/dev/null
+ exit
+ fi
+
+ if [ -f $KEY ] ; then
+ ebegin "Reloading named.conf and zone files"
+ rndc -k $KEY reload &>/dev/null
+ eend $?
+ else /etc/init.d/named restart &>/dev/null
+ fi
+}