summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-03-03 17:23:31 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-03-03 17:23:31 +0000
commit40f9923b1a065a7d0d2e4cf0474e293437d4c33a (patch)
treec2f37d4ce73f1859b7ab11d0056e89f4f04b7093 /net-dns/dlint/dlint-1.4.0-r2.ebuild
parentDependency update: sys-apps/supervise-scripts -> sys-process/supervise-scripts. (diff)
downloadgentoo-2-40f9923b1a065a7d0d2e4cf0474e293437d4c33a.tar.gz
gentoo-2-40f9923b1a065a7d0d2e4cf0474e293437d4c33a.tar.bz2
gentoo-2-40f9923b1a065a7d0d2e4cf0474e293437d4c33a.zip
Fix 'tail' occurances not caught by fixheadtails.eclass. Bug #83932.
(Portage version: 2.0.51.18)
Diffstat (limited to 'net-dns/dlint/dlint-1.4.0-r2.ebuild')
-rw-r--r--net-dns/dlint/dlint-1.4.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-dns/dlint/dlint-1.4.0-r2.ebuild b/net-dns/dlint/dlint-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..93050bbf01f5
--- /dev/null
+++ b/net-dns/dlint/dlint-1.4.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0-r2.ebuild,v 1.1 2005/03/03 17:23:31 ticho Exp $
+
+inherit eutils fixheadtails
+
+S=${WORKDIR}/${P/-/}
+DESCRIPTION="Dlint analyzes any DNS zone you specify, and reports any problems it finds by displaying errors and warnings"
+SRC_URI="http://www.domtools.com/pub/${P/-/}.tar.gz"
+HOMEPAGE="http://www.domtools.com/dns/dlint.shtml"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE=""
+LICENSE="GPL-2"
+
+DEPEND=""
+RDEPEND="sys-apps/coreutils
+ net-dns/bind-tools
+ dev-lang/perl
+ app-shells/bash"
+
+src_compile() {
+ sed -i -e 's:rrfilt=\"/usr/local/bin/digparse\":rrfilt=\"/usr/bin/digparse\":' \
+ dlint
+ ht_fix_file dlint
+ sed -i -e "s:+\$i:-n +\$i:g" dlint
+}
+
+src_install () {
+ dobin digparse
+ dobin dlint
+ doman dlint.1
+ dodoc BUGS COPYING INSTALL README CHANGES COPYRIGHT TESTCASES
+}