summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2009-07-20 19:56:47 +0000
committerPatrick McLean <chutzpah@gentoo.org>2009-07-20 19:56:47 +0000
commit009ad5d86718131b1d4e50f893fdfa5fba448a27 (patch)
treec5f85e545844afc8e97a3d4c66d14e2eeb668ccb /net-dns/dnsmasq
parentAdd "dhcp" USE flag for net-dns/dnsmasq. (diff)
downloadgentoo-2-009ad5d86718131b1d4e50f893fdfa5fba448a27.tar.gz
gentoo-2-009ad5d86718131b1d4e50f893fdfa5fba448a27.tar.bz2
gentoo-2-009ad5d86718131b1d4e50f893fdfa5fba448a27.zip
Version bump. Add USE flag for dhcp which is now optional and change to EAPI=2 for default USE flag support.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/ChangeLog8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.49.ebuild69
-rw-r--r--net-dns/dnsmasq/metadata.xml1
3 files changed, 77 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 75950a27270f..96ed1437145e 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.176 2009/03/30 04:14:34 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.177 2009/07/20 19:56:47 chutzpah Exp $
+
+*dnsmasq-2.49 (20 Jul 2009)
+
+ 20 Jul 2009; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.49.ebuild:
+ Version bump. Add USE flag for dhcp which is now optional and change to
+ EAPI=2 for default USE flag support.
*dnsmasq-2.47 (30 Mar 2009)
diff --git a/net-dns/dnsmasq/dnsmasq-2.49.ebuild b/net-dns/dnsmasq/dnsmasq-2.49.ebuild
new file mode 100644
index 000000000000..38804784913a
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.49.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.49.ebuild,v 1.1 2009/07/20 19:56:47 chutzpah Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="dbus +dhcp ipv6 nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ sed -i '/^AWK/s:nawk:gawk:' Makefile #214865
+
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
+}
+
+src_configure() {
+ use tftp || append-flags -DNO_TFTP
+ use dhcp || append-flags -DNO_DHCP
+ use ipv6 || append-flags -DNO_IPV6
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+}
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ all$(use nls && echo "-i18n") || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n") || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}
diff --git a/net-dns/dnsmasq/metadata.xml b/net-dns/dnsmasq/metadata.xml
index 1b1c2743b300..b9446fe6c3c9 100644
--- a/net-dns/dnsmasq/metadata.xml
+++ b/net-dns/dnsmasq/metadata.xml
@@ -7,6 +7,7 @@
<name>Patrick McLean</name>
</maintainer>
<use>
+ <flag name='dhcp'>Enable support for reading ISC DHCPd lease files</flag>
<flag name='isc'>Enable support for reading ISC DHCPd lease files</flag>
<flag name='tftp'>Enables built in TFTP server for netbooting</flag>
</use>