summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-09-22 19:34:04 +0000
committerSven Wegener <swegener@gentoo.org>2007-09-22 19:34:04 +0000
commit7d9d4f29c6f276b8cdbe3fe5606f152d4c0fd227 (patch)
treec630dd4f7a350804c4455255d2195c0720046423 /net-dns/pdns-recursor
parentBump to 0.1.13. (diff)
downloadgentoo-2-7d9d4f29c6f276b8cdbe3fe5606f152d4c0fd227.tar.gz
gentoo-2-7d9d4f29c6f276b8cdbe3fe5606f152d4c0fd227.tar.bz2
gentoo-2-7d9d4f29c6f276b8cdbe3fe5606f152d4c0fd227.zip
Fix compilation with gcc-4.2, bug #185602.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/ChangeLog6
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-3.1.4-gcc42.patch22
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 54577c3aab53..3f839015e601 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/pdns-recursor
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.13 2007/06/08 22:28:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.14 2007/09/22 19:34:04 swegener Exp $
+
+ 22 Sep 2007; Sven Wegener <swegener@gentoo.org>
+ +files/pdns-recursor-3.1.4-gcc42.patch, pdns-recursor-3.1.4.ebuild:
+ Fix compilation with gcc-4.2, bug #185602.
08 Jun 2007; Sven Wegener <swegener@gentoo.org>
+files/pdns-recursor-3.1.4-chdir.patch,
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-3.1.4-gcc42.patch b/net-dns/pdns-recursor/files/pdns-recursor-3.1.4-gcc42.patch
new file mode 100644
index 000000000000..f20d25baa19a
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-3.1.4-gcc42.patch
@@ -0,0 +1,22 @@
+--- pdns/recursor_cache.cc
++++ pdns/recursor_cache.cc
+@@ -11,7 +11,10 @@
+ #include "config.h"
+
+ #ifdef GCC_SKIP_LOCKING
+-#include <bits/atomicity.h>
++#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 2))
++# include <ext/atomicity.h>
++#else
++# include <bits/atomicity.h>
+ // This code is ugly but does speedup the recursor tremendously on multi-processor systems, and even has a large effect (20, 30%) on uniprocessor
+ namespace __gnu_cxx
+ {
+@@ -32,6 +35,7 @@
+ }
+ }
+ #endif
++#endif
+
+ string simpleCompress(const string& label)
+ {
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild
index 3de33a6f8810..a780a638bfc4 100644
--- a/net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild
+++ b/net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild,v 1.5 2007/06/11 19:13:10 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.4.ebuild,v 1.6 2007/09/22 19:34:04 swegener Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -23,6 +23,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-statedir.patch
epatch "${FILESDIR}"/${P}-chdir.patch
+ epatch "${FILESDIR}"/${P}-gcc42.patch
}
src_compile() {