summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-04-09 20:15:36 +0000
committerRoy Marples <uberlord@gentoo.org>2007-04-09 20:15:36 +0000
commit02265dadb6107fef842bd3d5b61d5856a08d6c5f (patch)
treebda7e19ecc0aed9abfe3fe7f77731db07010ea76 /net-dns/resolvconf-gentoo
parentRemoved old development-branch ebuild. (diff)
downloadgentoo-2-02265dadb6107fef842bd3d5b61d5856a08d6c5f.tar.gz
gentoo-2-02265dadb6107fef842bd3d5b61d5856a08d6c5f.tar.bz2
gentoo-2-02265dadb6107fef842bd3d5b61d5856a08d6c5f.zip
This version works with the ash, busybox and dash shells :)
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-dns/resolvconf-gentoo')
-rw-r--r--net-dns/resolvconf-gentoo/ChangeLog8
-rw-r--r--net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.33
-rw-r--r--net-dns/resolvconf-gentoo/resolvconf-gentoo-1.3.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/net-dns/resolvconf-gentoo/ChangeLog b/net-dns/resolvconf-gentoo/ChangeLog
index 71752ab1dd14..3340e48c06cf 100644
--- a/net-dns/resolvconf-gentoo/ChangeLog
+++ b/net-dns/resolvconf-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/resolvconf-gentoo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/ChangeLog,v 1.25 2007/01/30 05:49:17 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/ChangeLog,v 1.26 2007/04/09 20:15:36 uberlord Exp $
+
+*resolvconf-gentoo-1.3 (09 Apr 2007)
+
+ 09 Apr 2007; Roy Marples <uberlord@gentoo.org>
+ +resolvconf-gentoo-1.3.ebuild:
+ This version works fine with the ash, busybox and dash shells :)
30 Jan 2007; Steve Dibb <beandog@gentoo.org> resolvconf-gentoo-1.2.ebuild:
amd64 stable, bug 159450
diff --git a/net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.3 b/net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.3
new file mode 100644
index 000000000000..88b28352f301
--- /dev/null
+++ b/net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.3
@@ -0,0 +1,3 @@
+MD5 011f925e8bb43ed70a4038957d9f7dc5 resolvconf-gentoo-1.3.tar.bz2 5397
+RMD160 e129e8c9ce61ce7a9dd7faa763444c3b3899c2b8 resolvconf-gentoo-1.3.tar.bz2 5397
+SHA256 0b1b36dd221bdd82d952ed66c5accfdbf8ff2287d5d5d599b5e83a3339ecc56e resolvconf-gentoo-1.3.tar.bz2 5397
diff --git a/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.3.ebuild b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.3.ebuild
new file mode 100644
index 000000000000..aad1c9a40254
--- /dev/null
+++ b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.3.ebuild,v 1.1 2007/04/09 20:15:36 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~uberlord/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ make ROOT="${D}" install || die "Failed to install"
+}
+
+pkg_postinst() {
+ if [ ! -"L ${ROOT}/etc/resolv.conf" ] \
+ || [ "$(readlink "${ROOT}/etc/resolv.conf")" != \
+ "resolvconf/run/resolv.conf" ] ; then
+ ewarn "resolvconf requires ${ROOT}etc/resolv.conf to be a symbolic"
+ ewarn "to resolvconf/run/resolv.conf"
+ einfo "To set this up automatically type"
+ einfo " emerge --config =${PF}"
+ fi
+}
+
+pkg_config() {
+ cd "${ROOT}/etc"
+ if [ -L resolv.conf -a "$(readlink resolv.conf)" = \
+ "resolvconf/run/resolv.conf" ] ; then
+ einfo "${ROOT}etc/resolv.conf is already configured for ${PN}"
+ else
+ if [ -e resolv.conf ] ; then
+ einfo "Your existing resolv.conf is will be mapped to an"
+ einfo "interface called \"dummy\" in resolvconf. This will"
+ einfo "disappear when you reboot."
+ cp resolv.conf resolvconf/run/resolv.conf
+ [ ! -d resolvconf/run/interfaces ] \
+ && mkdir resolvconf/run/interfaces
+ cp resolv.conf resolvconf/run/interfaces/dummy
+ echo "dummy" > resolvconf/run/add_order
+ fi
+ rm -f resolv.conf
+ ln -snf resolvconf/run/resolv.conf .
+ einfo "${ROOT}etc/resolv.conf is now correctly configured for ${PN}"
+ fi
+}