summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-07-28 20:39:03 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-07-28 20:39:03 +0000
commit02f6262652ee8b642c7b09237f39a1521b2d7b7a (patch)
tree420cd852b13a53038d8b8377e9fba442ae1e781d /net-dns
parentCleanup (diff)
downloadgentoo-2-02f6262652ee8b642c7b09237f39a1521b2d7b7a.tar.gz
gentoo-2-02f6262652ee8b642c7b09237f39a1521b2d7b7a.tar.bz2
gentoo-2-02f6262652ee8b642c7b09237f39a1521b2d7b7a.zip
Version bump, #279508
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/ChangeLog8
-rw-r--r--net-dns/bind-tools/bind-tools-9.4.3_p3.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index ec4f7ae33d98..e7f813da8d6d 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/bind-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.133 2009/07/28 20:37:07 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.134 2009/07/28 20:39:03 dertobi123 Exp $
+
+*bind-tools-9.4.3_p3 (28 Jul 2009)
+
+ 28 Jul 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +bind-tools-9.4.3_p3.ebuild:
+ Version bump, #279508
28 Jul 2009; Tobias Scherbaum <dertobi123@gentoo.org>
-bind-tools-9.4.2_p2.ebuild, -bind-tools-9.4.3_p1.ebuild,
diff --git a/net-dns/bind-tools/bind-tools-9.4.3_p3.ebuild b/net-dns/bind-tools/bind-tools-9.4.3_p3.ebuild
new file mode 100644
index 000000000000..dedb1626a730
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.4.3_p3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.3_p3.ebuild,v 1.1 2009/07/28 20:39:03 dertobi123 Exp $
+
+inherit flag-o-matic
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p3/-P3}
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="idn ipv6"
+
+DEPEND="idn? ( || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd "${S}" || die
+
+ use idn && {
+ # BIND 9.4.0 doesn't have this patch
+ # epatch ${S}/contrib/idn/idnkit-1.0-src/patch/bind9/bind-${PV}-patch
+
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd -
+ }
+
+ # bug #151839
+ sed -e \
+ 's:struct isc_socket {:#undef SO_BSDCOMPAT\n\nstruct isc_socket {:' \
+ -i lib/isc/unix/socket.c
+}
+
+src_compile() {
+ local myconf=
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+ use idn && myconf="${myconf} --with-idn"
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+
+ econf ${myconf} || die "Configure failed"
+
+ cd "${S}"/lib
+ emake -j1 || die "make failed in /lib"
+
+ cd "${S}"/bin/dig
+ emake -j1 || die "make failed in /bin/dig"
+
+ cd "${S}"/lib/lwres/
+ emake -j1 || die "make failed in /lib/lwres"
+
+ cd "${S}"/bin/nsupdate/
+ emake -j1 || die "make failed in /bin/nsupdate"
+
+ cd "${S}"/bin/dnssec/
+ emake -j1 || die "make failed in /bin/dnssec"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman dig.1 host.1 nslookup.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.1 || die
+ dohtml nsupdate.html || die
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ dohtml dnssec-keygen.html || die
+}