summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-24 07:46:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-24 07:46:50 +0000
commit8c93b6ac6f630a0c9292f05e542a960f8b38e6df (patch)
tree92d08d8e50c719848cbda89fbef3bd0eb41fa85f /net-dns
parentCompile problem fixed, see bug #13244 (Manifest recommit) (diff)
downloadgentoo-2-8c93b6ac6f630a0c9292f05e542a960f8b38e6df.tar.gz
gentoo-2-8c93b6ac6f630a0c9292f05e542a960f8b38e6df.tar.bz2
gentoo-2-8c93b6ac6f630a0c9292f05e542a960f8b38e6df.zip
filter-flags in src_unpack; header fix
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/hesiod/hesiod-3.0.2-r1.ebuild5
-rw-r--r--net-dns/hesiod/hesiod-3.0.2.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/net-dns/hesiod/hesiod-3.0.2-r1.ebuild b/net-dns/hesiod/hesiod-3.0.2-r1.ebuild
index c89c3e77fe6c..78cc97261157 100644
--- a/net-dns/hesiod/hesiod-3.0.2-r1.ebuild
+++ b/net-dns/hesiod/hesiod-3.0.2-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2-r1.ebuild,v 1.4 2004/02/05 03:03:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2-r1.ebuild,v 1.5 2004/02/24 07:46:50 mr_bones_ Exp $
inherit flag-o-matic eutils
-filter-flags -fstack-protector
DESCRIPTION="system which uses existing DNS functionality to provide access to databases of information that changes infrequently"
HOMEPAGE="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod"
@@ -19,6 +18,8 @@ src_unpack() {
unpack ${A}
cd ${S}
+ filter-flags -fstack-protector
+
#Patches stolen from RH
epatch ${FILESDIR}/hesiod-${PV}-redhat.patch.gz
autoconf || die "autoconf failed"
diff --git a/net-dns/hesiod/hesiod-3.0.2.ebuild b/net-dns/hesiod/hesiod-3.0.2.ebuild
index 9d538dd31224..9b181663b44e 100644
--- a/net-dns/hesiod/hesiod-3.0.2.ebuild
+++ b/net-dns/hesiod/hesiod-3.0.2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2.ebuild,v 1.8 2003/09/07 16:30:26 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2.ebuild,v 1.9 2004/02/24 07:46:50 mr_bones_ Exp $
inherit flag-o-matic
-filter-flags -fstack-protector
S=${WORKDIR}/${P}
DESCRIPTION="Hesiod is a system which uses existing DNS functionality to provide access to databases of information that changes infrequently."
@@ -19,6 +18,9 @@ DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
+
+ filter-flags -fstack-protector
+
#Patches stolen from RH
cat ${FILESDIR}/hesiod-3.0.2-shlib.patch | patch -d ${S} -p1
cat ${FILESDIR}/hesiod-3.0.2-env.patch | patch -d ${S} -p1