summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-12-30 18:28:17 +0000
committerAlin Năstac <mrness@gentoo.org>2007-12-30 18:28:17 +0000
commit3425f0f2455bfc3cde6a1be488262674699118f5 (patch)
tree14b1140e9e06b22413588fed375c01a7b1de660d /net-firewall/ipp2p
parentAdd debug USE flags to 1.0 and live versions. Fix SRC_URI for 1.0. (diff)
downloadgentoo-2-3425f0f2455bfc3cde6a1be488262674699118f5.tar.gz
gentoo-2-3425f0f2455bfc3cde6a1be488262674699118f5.tar.bz2
gentoo-2-3425f0f2455bfc3cde6a1be488262674699118f5.zip
Fix incompatibilities with iptables-1.4.0 (#203744).
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-firewall/ipp2p')
-rw-r--r--net-firewall/ipp2p/ChangeLog7
-rw-r--r--net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.0.patch45
-rw-r--r--net-firewall/ipp2p/files/ipp2p-0.8.2-kernel-2.6.22.patch44
-rw-r--r--net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild5
4 files changed, 93 insertions, 8 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index 7f12e76d320c..d9dc50b096a3 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipp2p
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.35 2007/08/17 19:31:50 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.36 2007/12/30 18:28:16 mrness Exp $
+
+ 30 Dec 2007; Alin Năstac <mrness@gentoo.org>
+ +files/ipp2p-0.8.2-iptables-1.4.0.patch,
+ files/ipp2p-0.8.2-kernel-2.6.22.patch, ipp2p-0.8.2-r4.ebuild:
+ Fix incompatibilities with iptables-1.4.0 (#203744).
17 Aug 2007; Alin Năstac <mrness@gentoo.org>
-files/ipp2p-0.8.2-kernel-2.6.21.patch, -ipp2p-0.8.2-r3.ebuild:
diff --git a/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.0.patch b/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.0.patch
new file mode 100644
index 000000000000..b55fb54f8ff6
--- /dev/null
+++ b/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.0.patch
@@ -0,0 +1,45 @@
+diff -Nru ipp2p-0.8.2.orig/libipt_ipp2p.c ipp2p-0.8.2/libipt_ipp2p.c
+--- ipp2p-0.8.2.orig/libipt_ipp2p.c 2006-01-04 18:24:19.000000000 +0200
++++ ipp2p-0.8.2/libipt_ipp2p.c 2007-12-30 20:20:26.000000000 +0200
+@@ -64,12 +64,10 @@
+
+
+ static void
+-init(struct ipt_entry_match *m, unsigned int *nfcache)
++init(struct ipt_entry_match *m)
+ {
+ struct ipt_p2p_info *info = (struct ipt_p2p_info *)m->data;
+
+- *nfcache |= NFC_UNKNOWN;
+-
+ /*init the module with default values*/
+ info->cmd = 0;
+ info->debug = 0;
+@@ -79,8 +77,7 @@
+
+ static int
+ parse(int c, char **argv, int invert, unsigned int *flags,
+- const struct ipt_entry *entry,
+- unsigned int *nfcache,
++ const void *entry,
+ struct ipt_entry_match **match)
+ {
+ struct ipt_p2p_info *info = (struct ipt_p2p_info *)(*match)->data;
+@@ -315,7 +312,7 @@
+
+
+ static void
+-print(const struct ipt_ip *ip,
++print(const void *ip,
+ const struct ipt_entry_match *match,
+ int numeric)
+ {
+@@ -347,7 +344,7 @@
+
+
+ static void
+-save(const struct ipt_ip *ip, const struct ipt_entry_match *match)
++save(const void *ip, const struct ipt_entry_match *match)
+ {
+ struct ipt_p2p_info *info = (struct ipt_p2p_info *)match->data;
+
diff --git a/net-firewall/ipp2p/files/ipp2p-0.8.2-kernel-2.6.22.patch b/net-firewall/ipp2p/files/ipp2p-0.8.2-kernel-2.6.22.patch
index d0695e5a7d53..8d5b0531b104 100644
--- a/net-firewall/ipp2p/files/ipp2p-0.8.2-kernel-2.6.22.patch
+++ b/net-firewall/ipp2p/files/ipp2p-0.8.2-kernel-2.6.22.patch
@@ -1,6 +1,6 @@
diff -Nru ipp2p-0.8.2.orig/ipt_ipp2p.c ipp2p-0.8.2/ipt_ipp2p.c
---- ipp2p-0.8.2.orig/ipt_ipp2p.c 2006-09-27 12:52:00.000000000 +0300
-+++ ipp2p-0.8.2/ipt_ipp2p.c 2007-07-11 08:00:26.000000000 +0300
+--- ipp2p-0.8.2.orig/ipt_ipp2p.c 2007-12-04 07:50:55.000000000 +0200
++++ ipp2p-0.8.2/ipt_ipp2p.c 2007-12-04 07:50:43.000000000 +0200
@@ -2,9 +2,18 @@
#include <linux/modversions.h>
#endif
@@ -21,7 +21,27 @@ diff -Nru ipp2p-0.8.2.orig/ipt_ipp2p.c ipp2p-0.8.2/ipt_ipp2p.c
#include "ipt_ipp2p.h"
#include <net/tcp.h>
#include <net/udp.h>
-@@ -748,7 +757,11 @@
+@@ -725,7 +734,11 @@
+ };
+
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
++static bool
++#else
+ static int
++#endif
+ match(const struct sk_buff *skb,
+ const struct net_device *in,
+ const struct net_device *out,
+@@ -744,11 +757,19 @@
+ u_int16_t datalen,
+ #endif
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
++ bool *hotdrop)
++#else
+ int *hotdrop)
++#endif
{
const struct ipt_p2p_info *info = matchinfo;
unsigned char *haystack;
@@ -33,7 +53,19 @@ diff -Nru ipp2p-0.8.2.orig/ipt_ipp2p.c ipp2p-0.8.2/ipt_ipp2p.c
int p2p_result = 0, i = 0;
// int head_len;
int hlen = ntohs(ip->tot_len)-(ip->ihl*4); /*hlen = packet-data length*/
-@@ -831,7 +844,9 @@
+@@ -822,7 +843,11 @@
+
+
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
++static bool
++#else
+ static int
++#endif
+ checkentry(const char *tablename,
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
+ const void *ip,
+@@ -831,7 +856,9 @@
const struct ipt_ip *ip,
#endif
void *matchinfo,
@@ -43,7 +75,7 @@ diff -Nru ipp2p-0.8.2.orig/ipt_ipp2p.c ipp2p-0.8.2/ipt_ipp2p.c
unsigned int hook_mask)
{
/* Must specify -p tcp */
-@@ -843,15 +858,6 @@
+@@ -843,15 +870,6 @@
}
@@ -59,7 +91,7 @@ diff -Nru ipp2p-0.8.2.orig/ipt_ipp2p.c ipp2p-0.8.2/ipt_ipp2p.c
static struct ipt_match ipp2p_match = {
#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
{ NULL, NULL },
-@@ -860,17 +866,16 @@
+@@ -860,17 +878,16 @@
&checkentry,
NULL,
THIS_MODULE
diff --git a/net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild b/net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild
index 3bc570641578..6b5a74a5bf78 100644
--- a/net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild
+++ b/net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild,v 1.5 2007/08/13 07:07:52 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.2-r4.ebuild,v 1.6 2007/12/30 18:28:16 mrness Exp $
inherit linux-mod eutils
@@ -37,6 +37,9 @@ src_unpack() {
sed -i -e "s/^IPTABLES_VERSION/#IPTABLES_VERSION/" Makefile
if has_version '>=net-firewall/iptables-1.3.6' ; then
sed -i -e "s/ld -shared/\$\(CC\) -shared/" Makefile
+ if has_version '>=net-firewall/iptables-1.4.0' ; then
+ epatch "${FILESDIR}"/${P}-iptables-1.4.0.patch
+ fi
fi
}