summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-12-16 21:41:26 +0000
committerPeter Johanson <latexer@gentoo.org>2004-12-16 21:41:26 +0000
commit2ceac0ce38f0177e9a31dd1c876c50d5c23f682d (patch)
treec5487457a13fc3bddb070914891dc1cd34214bc2 /net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild
parentfix for -O3 & P4 (Manifest recommit) (diff)
downloadgentoo-2-2ceac0ce38f0177e9a31dd1c876c50d5c23f682d.tar.gz
gentoo-2-2ceac0ce38f0177e9a31dd1c876c50d5c23f682d.tar.bz2
gentoo-2-2ceac0ce38f0177e9a31dd1c876c50d5c23f682d.zip
Bump to new release. Add my self to the maintainers list.
Diffstat (limited to 'net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild')
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild
new file mode 100644
index 000000000000..4dc03f4dfc9f
--- /dev/null
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.4.ebuild,v 1.1 2004/12/16 21:41:26 latexer Exp $
+
+inherit eutils
+
+DESCRIPTION="IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."
+HOMEPAGE="http://ipsec-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~x86 ~amd64 ~sparc"
+SLOT="0"
+IUSE="selinux"
+DEPEND="virtual/libc
+ >=dev-libs/openssl-0.9.6"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-ipsec-tools )"
+
+pkg_setup() {
+ my_KV=`echo ${KV} | cut -f-2 -d "."`
+ if [ ${my_KV} != "2.6" ] ; then
+ echo; eerror "You need a 2.6.x kernel to use the ipsec tools!"; die "You need a 2.6 kernel to use ipsec-tools!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.diff
+}
+
+src_compile() {
+ unset CC
+ ./configure --prefix=/usr --sysconfdir=/etc --with-kernel-headers=/usr/src/linux/include || die
+ sed -e 's:AM_CFLAGS = :AM_CFLAGS = -include /usr/src/linux/include/linux/compiler.h :' -i src/setkey/Makefile || die
+ sed -e 's:CPPFLAGS=:CPPFLAGS = -include /usr/src/linux/include/linux/compiler.h :' -i src/racoon/Makefile || die
+ sed -e 's:va_copy:__va_copy:g' -i src/racoon/plog.c || die # GCC 2 Fix
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ rm ${D}/usr/bin
+ dosbin src/racoon/racoon
+ insinto /etc && doins ${FILESDIR}/ipsec.conf.sample
+ insinto /etc/conf.d && newins ${FILESDIR}/racoon.conf.d racoon
+ exeinto /etc/init.d && newexe ${FILESDIR}/racoon.init.d racoon
+
+ dodoc ChangeLog README NEWS
+ dodoc ${S}/src/racoon/samples/racoon.conf.sample*
+}