summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-07-04 11:42:58 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-07-04 11:42:58 +0000
commit07595a163148ee02526ec8967bae4ccdb4ca6ee2 (patch)
tree6c6680cbda2cd3f1b849ecebb950195205890b60 /net-firewall/iptables
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-07595a163148ee02526ec8967bae4ccdb4ca6ee2.tar.gz
gentoo-2-07595a163148ee02526ec8967bae4ccdb4ca6ee2.tar.bz2
gentoo-2-07595a163148ee02526ec8967bae4ccdb4ca6ee2.zip
More bugs fixed.
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog9
-rw-r--r--net-firewall/iptables/iptables-1.2.11-r2.ebuild15
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r4.ebuild5
3 files changed, 20 insertions, 9 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 63ea76dc5116..88b9fa79f5c8 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.36 2004/07/03 17:50:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.37 2004/07/04 11:42:58 aliz Exp $
+
+ 04 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.11-r2.ebuild:
+ + Fix installation path, initscript and config script. Closing #55978.
+ + Fix dependencies. Closing #55605
+
+ 04 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r4.ebuild:
+ + Fix dependencies. Closing #55605
03 Jul 2004; Seemant Kulleen <seemant@gentoo.org> iptables-1.2.11-r2.ebuild:
sed statement fix, thanks to x1bncwn in #gentoo
diff --git a/net-firewall/iptables/iptables-1.2.11-r2.ebuild b/net-firewall/iptables/iptables-1.2.11-r2.ebuild
index 61f977871543..d5d5e383970a 100644
--- a/net-firewall/iptables/iptables-1.2.11-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.2.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.11-r2.ebuild,v 1.2 2004/07/03 17:50:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.11-r2.ebuild,v 1.3 2004/07/04 11:42:58 aliz Exp $
inherit eutils flag-o-matic
@@ -14,7 +14,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
IUSE="ipv6 static extensions"
-DEPEND="virtual/linux-sources"
+DEPEND="virtual/os-headers
+ extensions? ( virtual/linux-sources )"
pkg_setup() {
if use extensions; then
@@ -100,6 +101,7 @@ src_compile() {
src_install() {
if use extensions; then
make DESTDIR=${D} ${myconf} \
+ PREFIX= \
LIBDIR=/lib \
MANDIR=/usr/share/man \
INCDIR=/usr/include \
@@ -107,6 +109,7 @@ src_install() {
install || die "Please check http://cvs.iptables.org/patch-o-matic-ng/updates/ if your kernel needs to be patched for iptables"
make DESTDIR=${D} ${myconf} \
+ PREFIX= \
LIBDIR=/usr/lib \
MANDIR=/usr/share/man \
INCDIR=/usr/include \
@@ -131,16 +134,16 @@ src_install() {
dodoc COPYING
dodir /var/lib/iptables ; keepdir /var/lib/iptables
exeinto /etc/init.d
- newexe ${FILESDIR}/${PN}-${PV}-r1.init iptables
+ newexe ${FILESDIR}/${PN}-1.2.9-r1.init iptables
insinto /etc/conf.d
- newins ${FILESDIR}/${PN}-${PV}-r1.confd iptables
+ newins ${FILESDIR}/${PN}-1.2.9-r1.confd iptables
if use ipv6; then
dodir /var/lib/ip6tables ; keepdir /var/lib/ip6tables
exeinto /etc/init.d
- newexe ${FILESDIR}/${PN/iptables/ip6tables}-${PV}-r1.init ip6tables
+ newexe ${FILESDIR}/${PN/iptables/ip6tables}-1.2.9-r1.init ip6tables
insinto /etc/conf.d
- newins ${FILESDIR}/${PN/iptables/ip6tables}-${PV}-r1.confd ip6tables
+ newins ${FILESDIR}/${PN/iptables/ip6tables}-1.2.9-r1.confd ip6tables
fi
}
diff --git a/net-firewall/iptables/iptables-1.2.9-r4.ebuild b/net-firewall/iptables/iptables-1.2.9-r4.ebuild
index bcaffe0874b9..f01d5fca8d57 100644
--- a/net-firewall/iptables/iptables-1.2.9-r4.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r4.ebuild,v 1.1 2004/07/03 15:36:32 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r4.ebuild,v 1.2 2004/07/04 11:42:58 aliz Exp $
inherit eutils flag-o-matic
@@ -12,7 +12,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc ~mips alpha arm hppa amd64 ia64"
IUSE="ipv6 static extensions"
-DEPEND="virtual/linux-sources"
+DEPEND="virtual/os-headers
+ extensions? ( virtual/linux-sources )"
pkg_setup() {
if use extensions; then