summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-06-04 09:53:57 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-06-04 09:53:57 +0000
commit850199492d6a286389f0547e76f0ab05d2687eea (patch)
tree3c6d3773961a967c3e147e435765b574ff0ecc52 /net-firewall/rtsp-conntrack
parentStable on amd64 and x86, wrt bug #471354 (diff)
downloadgentoo-2-850199492d6a286389f0547e76f0ab05d2687eea.tar.gz
gentoo-2-850199492d6a286389f0547e76f0ab05d2687eea.tar.bz2
gentoo-2-850199492d6a286389f0547e76f0ab05d2687eea.zip
Initial commit, wrt bug #376155
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-firewall/rtsp-conntrack')
-rw-r--r--net-firewall/rtsp-conntrack/ChangeLog10
-rw-r--r--net-firewall/rtsp-conntrack/metadata.xml8
-rw-r--r--net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild35
3 files changed, 53 insertions, 0 deletions
diff --git a/net-firewall/rtsp-conntrack/ChangeLog b/net-firewall/rtsp-conntrack/ChangeLog
new file mode 100644
index 000000000000..aa1484090040
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-firewall/rtsp-conntrack
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/rtsp-conntrack/ChangeLog,v 1.1 2013/06/04 09:53:57 pinkbyte Exp $
+
+*rtsp-conntrack-3.7 (04 Jun 2013)
+
+ 04 Jun 2013; Sergey Popov <pinkbyte@gentoo.org> +rtsp-conntrack-3.7.ebuild,
+ +metadata.xml:
+ Initial commit, wrt bug #376155
+
diff --git a/net-firewall/rtsp-conntrack/metadata.xml b/net-firewall/rtsp-conntrack/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild b/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
new file mode 100644
index 000000000000..8acca3387b21
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild,v 1.1 2013/06/04 09:53:57 pinkbyte Exp $
+
+EAPI=5
+inherit eutils linux-mod versionator
+
+DESCRIPTION="RTSP conntrack module for Netfilter"
+HOMEPAGE="http://mike.it-loops.com/rtsp"
+SRC_URI="http://mike.it-loops.com/rtsp/rtsp-module-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/rtsp"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="
+ nf_conntrack_rtsp(net/netfilter::)
+ nf_nat_rtsp(net/ipv4/netfilter::)"
+
+CONFIG_CHECK="NF_CONNTRACK"
+WARNING_NF_CONNTRACK="You must enable NF_CONNTRACK in your kernel, otherwise ${PN} would not work"
+
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR} V=1"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ kernel_is -lt $(get_version_components) && die "This version of ${PN} would not work on kernels <= ${PV}"
+}
+
+src_prepare() {
+ epatch_user
+}