summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-10-21 06:43:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-10-21 06:43:36 +0000
commit9cd694ceb2a6df744e00f7cec574a62eba83e963 (patch)
tree0e8f70bdf7cc41b4ee877bf0cb10063a26cd566c /net-firewall
parentversion bump + fixes (diff)
downloadgentoo-2-9cd694ceb2a6df744e00f7cec574a62eba83e963.tar.gz
gentoo-2-9cd694ceb2a6df744e00f7cec574a62eba83e963.tar.bz2
gentoo-2-9cd694ceb2a6df744e00f7cec574a62eba83e963.zip
version bump + fixes
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/psad/ChangeLog11
-rw-r--r--net-firewall/psad/Manifest4
-rw-r--r--net-firewall/psad/files/digest-psad-1.2.41
-rw-r--r--net-firewall/psad/psad-1.2.4.ebuild119
4 files changed, 132 insertions, 3 deletions
diff --git a/net-firewall/psad/ChangeLog b/net-firewall/psad/ChangeLog
index ce42cc7b90a7..598970d800fa 100644
--- a/net-firewall/psad/ChangeLog
+++ b/net-firewall/psad/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-firewall/psad
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.4 2003/10/07 06:22:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.5 2003/10/21 06:43:34 seemant Exp $
+
+*psad-1.2.4 (20 Oct 2003)
+
+ 20 Oct 2003; Seemant Kulleen <seemant@gentoo.org> psad-1.2.4.ebuild:
+ version bump, with fixes: This one seds the machine's hostname (based on
+ /etc/hostname and /etc/dnsdomainname) into the psad.conf file. I also fixed a
+ problem regarding the perl modules bundled with psad (they needed to be put
+ into subdirs of the /usr/lib/psad directory). And finally, diskmond has been
+ removed from the package
*psad-1.2.3-r1 (06 Oct 2003)
diff --git a/net-firewall/psad/Manifest b/net-firewall/psad/Manifest
index fdf09696efad..c83f8db06a3e 100644
--- a/net-firewall/psad/Manifest
+++ b/net-firewall/psad/Manifest
@@ -1,8 +1,8 @@
MD5 d53d8f350b98cb2c133a02ed1bb7b17f psad-1.2.3-r1.ebuild 2318
MD5 3f67eca9c08b0f4c00febb141781d3bc psad-1.2.1.ebuild 2177
MD5 1b47f1cbc333cef8864f9c143321eb4c psad-1.2.3.ebuild 2324
-MD5 d7725542a9f8c5b6229c85d1f23a791e psad-1.2.4.ebuild 2715
-MD5 2107911272a5933dcb2cb62861e7f9af ChangeLog 881
+MD5 cd8a79e76c6745c3eaa0d4cf8a18b9eb psad-1.2.4.ebuild 2814
+MD5 188eb284829db44d0f788db1a86d21dd ChangeLog 1319
MD5 624441f5e21afa19251eedc583e0c4e7 metadata.xml 433
MD5 13ac645fa87957507ebc86576fb4e76b files/digest-psad-1.2.1 62
MD5 2958d8637b53c70d3e7c1fc812265c96 files/digest-psad-1.2.3 62
diff --git a/net-firewall/psad/files/digest-psad-1.2.4 b/net-firewall/psad/files/digest-psad-1.2.4
new file mode 100644
index 000000000000..5f9f33ef07e3
--- /dev/null
+++ b/net-firewall/psad/files/digest-psad-1.2.4
@@ -0,0 +1 @@
+MD5 7233ac8929e7ee5e3b66edaae72b4c92 psad-1.2.4.tar.bz2 454610
diff --git a/net-firewall/psad/psad-1.2.4.ebuild b/net-firewall/psad/psad-1.2.4.ebuild
new file mode 100644
index 000000000000..efe26cd7ab4e
--- /dev/null
+++ b/net-firewall/psad/psad-1.2.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.2.4.ebuild,v 1.1 2003/10/21 06:43:34 seemant Exp $
+
+inherit eutils
+inherit perl-module
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Port Scannning Attack Detection daemon"
+SRC_URI="http://www.cipherdyne.org/psad/download/psad-${PV}.tar.bz2"
+HOMEPAGE="http://www.cipherdyne.org/psad"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~alpha ~sparc ~hppa ~mips ~arm"
+
+DEPEND="${DEPEND}
+ dev-lang/perl"
+
+RDEPEND="virtual/logger
+ dev-perl/Unix-Syslog
+ dev-perl/Date-Calc
+ net-mail/mailx
+ net-firewall/iptables"
+
+src_compile() {
+ cd ${S}/Psad
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/Net-IPv4Addr
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/IPTables/Parse
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/whois
+ emake || die
+
+ cd ${S}
+ # We'll use the C binaries
+ emake || die
+}
+
+src_install() {
+ local myhostname=
+ local mydomain=
+
+ keepdir /var/lib/psad /var/log/psad /var/run/psad /var/lock/subsys/${PN}
+ dodir /etc/psad
+ cd ${S}/Psad
+ insinto /usr/lib/psad
+ doins Psad.pm
+
+ cd ${S}/Net-IPv4Addr
+ insinto /usr/lib/psad/Net
+ doins IPv4Addr.pm
+
+ cd ${S}/IPTables/Parse
+ insinto /usr/lib/psad/IPTables
+ doins Parse.pm
+
+ cd ${S}/whois
+ # Makefile seems borken, do install by hand...
+ insinto /usr
+ newbin whois whois_psad
+ newman whois.1 whois_psad.1
+
+ cd ${S}
+ insinto /usr
+ dosbin kmsgsd psad psadwatchd
+ dobin pscan
+
+ cd ${S}
+
+ # Ditch the _CHANGEME_ for hostname, substituting in our real hostname
+ myhostname="$(< /etc/hostname)"
+ [ -e /etc/dnsdomainname ] && mydomain=".$(< /etc/dnsdomainname)"
+ cp psad.conf psad.conf.orig
+ sed -i "s:HOSTNAME\(.\+\)\_CHANGEME\_;:HOSTNAME\1${myhostname}${mydomain};:" psad.conf || die "Sed failed."
+
+ insinto /etc/psad
+ doins *.conf
+ doins psad_*
+
+ insinto /etc/init.d
+ newins psad-init.gentoo psad
+
+ cd ${S}/snort_rules
+ dodir /etc/psad/snort_rules
+ insinto /etc/psad/snort_rules
+ doins *.rules
+
+ cd ${S}
+ dodoc BENCHMARK CREDITS Change* FW_EXAMPLE_RULES README LICENSE SCAN_LOG
+}
+
+pkg_postinst() {
+ if [ ! -p ${ROOT}/var/lib/psad/psadfifo ]
+ then
+ ebegin "Creating syslog FIFO for PSAD"
+ mknod -m 600 ${ROOT}/var/lib/psad/psadfifo p
+ eend $?
+ fi
+
+ echo
+ einfo "Please be sure to edit /etc/psad/psad.conf to reflect your system's"
+ einfo "configuration or it may not work correctly or start up. Specifically, check"
+ einfo "the validity of the HOSTNAME setting and replace the EMAIL_ADDRESSES setting"
+ einfo "at the least."
+ echo
+ ewarn "If you're using metalog as your system logger, please be aware that PSAD does"
+ ewarn "not officially support it, and it probably won't work. Syslog-ng and sysklogd"
+ ewarn "do seem to work fine, though."
+}