summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-11-21 09:59:51 +0000
committerEldad Zack <eldad@gentoo.org>2004-11-21 09:59:51 +0000
commitbd21433a8afef3c3943ce6c6d2be92a6da6857c4 (patch)
tree85f7ebd0dede1b8b263b1a39a34f682d9d81db00 /net-firewall
parentAdded to ~amd64, bug #71887 (Manifest recommit) (diff)
downloadgentoo-2-bd21433a8afef3c3943ce6c6d2be92a6da6857c4.tar.gz
gentoo-2-bd21433a8afef3c3943ce6c6d2be92a6da6857c4.tar.bz2
gentoo-2-bd21433a8afef3c3943ce6c6d2be92a6da6857c4.zip
initscript updates
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall/ChangeLog6
-rw-r--r--net-firewall/shorewall/files/shorewall15
2 files changed, 17 insertions, 4 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index 862d14659d4f..694a8ae10f72 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/shorewall
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.55 2004/08/22 21:11:37 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.56 2004/11/21 09:59:51 eldad Exp $
+
+ 21 Nov 2004; Eldad Zack <eldad@gentoo.org> files/shorewall:
+ initscript: added clear function to remove firewall rules, /dev/null'd restart
+ output. Closes #24882.
22 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> shorewall-2.0.4.ebuild:
Stable on alpha.
diff --git a/net-firewall/shorewall/files/shorewall b/net-firewall/shorewall/files/shorewall
index f688ee6bc5ff..ca6a562eecf3 100644
--- a/net-firewall/shorewall/files/shorewall
+++ b/net-firewall/shorewall/files/shorewall
@@ -1,9 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall,v 1.6 2004/07/14 23:31:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall,v 1.7 2004/11/21 09:59:51 eldad Exp $
-opts="start stop restart"
+opts="start stop restart clear"
depend() {
need net
@@ -28,6 +28,15 @@ restart() {
# here. Note that this comment is required to fix bug 55576;
# runscript.sh greps this script... (09 Jul 2004 agriffis)
ebegin "Restarting firewall"
- /sbin/shorewall restart
+ /sbin/shorewall restart 1>/dev/null
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all firewall rules and setting policy to ACCEPT"
+ /sbin/shorewall clear
eend $?
}