summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-11-05 14:23:32 +0000
committerPeter Volkov <pva@gentoo.org>2007-11-05 14:23:32 +0000
commitda6d4bdddc2393eb6754ce3e3b0e675cc8e785f9 (patch)
treed9a6b2be30e365af83bccd05da7193bad32520a8 /net-firewall
parentia64 stable wrt #197693 (diff)
downloadgentoo-2-da6d4bdddc2393eb6754ce3e3b0e675cc8e785f9.tar.gz
gentoo-2-da6d4bdddc2393eb6754ce3e3b0e675cc8e785f9.tar.bz2
gentoo-2-da6d4bdddc2393eb6754ce3e3b0e675cc8e785f9.zip
Version bump. Added myself in metadata. Added emerge --config to patch the kernel.
(Portage version: 2.1.3.17)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.3.0.200708286
-rw-r--r--net-firewall/ipset/ipset-2.3.0.20070828.ebuild81
-rw-r--r--net-firewall/ipset/metadata.xml3
4 files changed, 97 insertions, 1 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index f4c3c928d3ea..871dc702f4f4 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.10 2007/04/12 18:37:15 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.11 2007/11/05 14:23:31 pva Exp $
+
+*ipset-2.3.0.20070828 (05 Nov 2007)
+
+ 05 Nov 2007; <pva@gentoo.org> metadata.xml, +ipset-2.3.0.20070828.ebuild:
+ Version bump. Added myself in metadata. Added emerge --config to patch the
+ kernel.
12 Apr 2007; Stefan Schweizer <genstef@gentoo.org>
-ipset-2.1.0.20050119.ebuild:
diff --git a/net-firewall/ipset/files/digest-ipset-2.3.0.20070828 b/net-firewall/ipset/files/digest-ipset-2.3.0.20070828
new file mode 100644
index 000000000000..8aefb0736d49
--- /dev/null
+++ b/net-firewall/ipset/files/digest-ipset-2.3.0.20070828
@@ -0,0 +1,6 @@
+MD5 9e17798dfd8ed87c63a1f3498f9fe64d ipset-2.3.0-20070828.tar.bz2 29442
+RMD160 f87edd407fdda85d8fefb8ca31865a22a65753a4 ipset-2.3.0-20070828.tar.bz2 29442
+SHA256 216f9bc128c2d0afab549baf1586ab9f2359e32fd1ccfe5ed0dc57e193d8f66a ipset-2.3.0-20070828.tar.bz2 29442
+MD5 71528acdf62d41316727c0763ca65750 patch-o-matic-ng-20071021.tar.bz2 136199
+RMD160 3e211f5a2c930d582d0d7e4d47b1f6313b68e302 patch-o-matic-ng-20071021.tar.bz2 136199
+SHA256 558d3f1cb35e92faedc067bb34073f77db065c7a5c88ce1d4d6ea5588266e3ae patch-o-matic-ng-20071021.tar.bz2 136199
diff --git a/net-firewall/ipset/ipset-2.3.0.20070828.ebuild b/net-firewall/ipset/ipset-2.3.0.20070828.ebuild
new file mode 100644
index 000000000000..52390ed4a5de
--- /dev/null
+++ b/net-firewall/ipset/ipset-2.3.0.20070828.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.3.0.20070828.ebuild,v 1.1 2007/11/05 14:23:31 pva Exp $
+
+inherit eutils versionator toolchain-funcs
+
+POM_PV="20071021"
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="IPset userspace tool for iptables, successor to ippool."
+HOMEPAGE="http://ipset.netfilter.org/"
+SRC_URI="http://ipset.netfilter.org/${PN}-${MY_PV}.tar.bz2
+ http://ipset.netfilter.org/patch-o-matic-ng-${POM_PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+RDEPEND=">=net-firewall/iptables-1.3"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/ipset-${MY_PV%-*}
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ myconf="${myconf} KERNEL_DIR=${WORKDIR}/patch-o-matic-ng/patchlets/set/linux-2.6"
+ export myconf
+}
+
+src_compile() {
+ src_defs
+ emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} || die "failed to build"
+}
+
+src_install() {
+ src_defs
+ emake DESTDIR="${D}" ${myconf} install || die "failed to package"
+}
+
+pkg_postinst() {
+ elog "To use ${PN} you must have the ip_set kernel module compiled!"
+ elog "To patch your kernel run:"
+ elog
+ elog " # emerge --config ipset"
+ elog
+ elog "And follow on-screen instructions."
+}
+
+pkg_config() {
+ cd "${ROOT}${PORTAGE_TMPDIR}"
+ mkdir patch-o-matic-ng
+ cd patch-o-matic-ng
+
+ IPTVERINS=`echo $(best_version net-firewall/iptables) | \
+ sed -n 's:^[^/]*/[[:alpha:]]*-\([0-9]\+\([.][0-9]\+\)*[a-z]\?\(_\(pre\|p\|beta\|alpha\|rc\)[0-9]*\)*\)\(-r[0-9]\+\)\?$:\1:p'`
+
+ einfo "Unpacking patch-o-matic-ng-${POM_PV}"
+ tar -jxf "${DISTDIR}"/patch-o-matic-ng-${POM_PV}.tar.bz2 || \
+ die "Unable to unpack patch-o-matic-ng-${POM_PV}"
+ einfo "Unpacking iptables-${IPTVERINS}"
+ tar -jxf "${DISTDIR}"/iptables-${IPTVERINS}.tar.bz2 || \
+ die "Unable to unpack iptables-${IPTVERINS}.tar.bz2"
+
+ cd patch-o-matic-ng
+ einfo "Enter path to your kernel sources, relative to ${ROOT}"
+ echo -n "[/usr/src/linux]: "
+ read K_DIR
+ [ "${ROOT}${K_DIR}" == "/" ] && K_DIR=${ROOT}/usr/src/linux
+ if [ -d "${K_DIR}" ] ; then
+ pwd
+ einfo "Running KERNEL_DIR=${K_DIR} IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set"
+ KERNEL_DIR=${K_DIR} IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set
+ else
+ eerror "${K_DIR} is not a directory"
+ fi
+
+ rm -rf "${ROOT}${PORTAGE_TMPDIR}"/patch-o-matic-ng
+}
diff --git a/net-firewall/ipset/metadata.xml b/net-firewall/ipset/metadata.xml
index 5d9f5be9d49d..f38b7dc9f3be 100644
--- a/net-firewall/ipset/metadata.xml
+++ b/net-firewall/ipset/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>robbat2@gentoo.org</email>
</maintainer>
+<maintainer>
+ <email>pva@gentoo.org</email>
+</maintainer>
</pkgmetadata>