summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-06-08 17:10:21 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-06-08 17:10:21 +0000
commitdb480dd9a77b1bcaa9c6d6d83f06e965f68eae62 (patch)
tree1e3a069c83dd16ca1a8dcb0ed215d286836d3521 /net-firewall
parentVersion bump. (diff)
downloadgentoo-2-db480dd9a77b1bcaa9c6d6d83f06e965f68eae62.tar.gz
gentoo-2-db480dd9a77b1bcaa9c6d6d83f06e965f68eae62.tar.bz2
gentoo-2-db480dd9a77b1bcaa9c6d6d83f06e965f68eae62.zip
Version bump with new config file
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-core/ChangeLog8
-rw-r--r--net-firewall/shorewall-core/files/shorewallrc21
-rw-r--r--net-firewall/shorewall-core/shorewall-core-4.5.4.2.ebuild40
3 files changed, 68 insertions, 1 deletions
diff --git a/net-firewall/shorewall-core/ChangeLog b/net-firewall/shorewall-core/ChangeLog
index 30fd18f33172..9bb5242ab0b3 100644
--- a/net-firewall/shorewall-core/ChangeLog
+++ b/net-firewall/shorewall-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.4 2012/04/24 08:20:46 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.5 2012/06/08 17:10:21 constanze Exp $
+
+*shorewall-core-4.5.4.2 (08 Jun 2012)
+
+ 08 Jun 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-core-4.5.4.2.ebuild, +files/shorewallrc:
+ Version bump with new config file
*shorewall-core-4.5.0.1-r3 (24 Apr 2012)
diff --git a/net-firewall/shorewall-core/files/shorewallrc b/net-firewall/shorewall-core/files/shorewallrc
new file mode 100644
index 000000000000..4f13769114a4
--- /dev/null
+++ b/net-firewall/shorewall-core/files/shorewallrc
@@ -0,0 +1,21 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+HOST=linux #Generic Linux
+BUILD= #Default is to detect the build system
+PREFIX=/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=/etc #Directory where subsystem configurations are installed
+SBINDIR=/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=etc/init.d #Directory where SysV init scripts are installed.
+INITFILE=$PRODUCT #Name of the product's installed SysV init script
+INITSOURCE=init.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD= #Directory where .service files are installed (systems running systemd only)
+SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR= #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARDIR=/var/lib #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall-core/shorewall-core-4.5.4.2.ebuild b/net-firewall/shorewall-core/shorewall-core-4.5.4.2.ebuild
new file mode 100644
index 000000000000..2effd4bcea33
--- /dev/null
+++ b/net-firewall/shorewall-core/shorewall-core-4.5.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/shorewall-core-4.5.4.2.ebuild,v 1.1 2012/06/08 17:10:21 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="shorewall-${MY_PV_BASE}"
+
+DESCRIPTION="Core libraries of shorewall / shorewall(6)-lite"
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ !<net-firewall/shorewall-4.5.0.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( changelog.txt releasenotes.txt )
+
+src_configure() {
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc || die "install.sh failed"
+ default
+}