summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-10 22:06:51 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-10 22:06:51 +0000
commit76112ebf54d1051265f3f05da628328289624ba8 (patch)
tree93b992ea14cfb70b46de530d735f648e94e78ee3 /net-fs/am-utils/am-utils-6.0.9.ebuild
parentinitial ebuild for am-utils (diff)
downloadgentoo-2-76112ebf54d1051265f3f05da628328289624ba8.tar.gz
gentoo-2-76112ebf54d1051265f3f05da628328289624ba8.tar.bz2
gentoo-2-76112ebf54d1051265f3f05da628328289624ba8.zip
initial ebuild for am-utils
Diffstat (limited to 'net-fs/am-utils/am-utils-6.0.9.ebuild')
-rw-r--r--net-fs/am-utils/am-utils-6.0.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-fs/am-utils/am-utils-6.0.9.ebuild b/net-fs/am-utils/am-utils-6.0.9.ebuild
new file mode 100644
index 000000000000..8dcb19d51e44
--- /dev/null
+++ b/net-fs/am-utils/am-utils-6.0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9.ebuild,v 1.1 2003/04/10 22:06:42 liquidx Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="amd automounter and utilities"
+HOMEPAGE="http://www.am-utils.org"
+SRC_URI="ftp://ftp.am-utils.org/pub/am-utils/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ldap? ( >=net-nds/openldap-1.2 )"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf
+
+ use ldap \
+ && myconf="${myconf} --without-ldap" \
+ || myconf="${myconf} --with-ldap"
+
+ myconf="${myconf} --sysconfdir=/etc/amd"
+
+ cd ${S}
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ cp ${FILESDIR}/amd.conf ${D}/etc/amd
+ cp ${FILESDIR}/amd.net ${D}/etc/amd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/amd.rc amd
+}