summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-09 18:26:21 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-09 18:26:21 +0000
commitdf97eba9309a1d7fc3e5ba84f2e04f87c7714f94 (patch)
tree684da8c0f815b0067e481263d4850eaf71fc5733 /net-fs/nfs-utils
parentCall elibtoolize #269003 by Sven Rebhan. (diff)
downloadgentoo-2-df97eba9309a1d7fc3e5ba84f2e04f87c7714f94.tar.gz
gentoo-2-df97eba9309a1d7fc3e5ba84f2e04f87c7714f94.tar.bz2
gentoo-2-df97eba9309a1d7fc3e5ba84f2e04f87c7714f94.zip
old
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-1.1.2-mount-eacces.patch28
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.2-r1.ebuild116
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.2.ebuild115
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.3.ebuild116
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.4.ebuild111
5 files changed, 0 insertions, 486 deletions
diff --git a/net-fs/nfs-utils/files/nfs-utils-1.1.2-mount-eacces.patch b/net-fs/nfs-utils/files/nfs-utils-1.1.2-mount-eacces.patch
deleted file mode 100644
index 5f2a358cd12a..000000000000
--- a/net-fs/nfs-utils/files/nfs-utils-1.1.2-mount-eacces.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-http://bugs.gentoo.org/219729
-
-commit 697e28939b7d0a3e0ffe3b6bd516213a55f5a063
-Author: Jeff Layton <jlaton@redhat.com>
-Date: Mon Apr 14 09:03:13 2008 -0400
-
- Change how mount.nfs handles EACCES errors. Currently,
- EACCES is a non-fatal error which means the mount will be
- retied. This caused mounts to hang for 2mins when the client
- does not have permission to access the export. In a strict
- interpretation, the error that should be returned is EPERM, but
- this is not always the case. So due to the fuzzy interpretation,
- of EPERM and EACCES, EACCESS is now a fatal error
-
- Signed-off-by: Steve Dickson <steved@redhat.com>
-
-diff --git a/utils/mount/stropts.c b/utils/mount/stropts.c
-index cadb1f4..cdd610e 100644
---- a/utils/mount/stropts.c
-+++ b/utils/mount/stropts.c
-@@ -252,7 +252,6 @@ static int set_mandatory_options(const char *type,
- static int is_permanent_error(int error)
- {
- switch (error) {
-- case EACCES:
- case ESTALE:
- case ETIMEDOUT:
- case ECONNREFUSED:
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.2-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.2-r1.ebuild
deleted file mode 100644
index 190deebb46e0..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.2-r1.ebuild,v 1.2 2008/10/26 09:02:47 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-rpcgen-ioctl.patch
- epatch "${FILESDIR}"/${P}-mount-eacces.patch #219729
-}
-
-src_compile() {
- local myconf
- if use nonfsv4; then
- myconf="--disable-gss"
- else
- myconf="$(use_enable kerberos gss)"
- fi
-
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- ${myconf} \
- || die "Configure failed"
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- if use !nonfsv4 ; then
- list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- fi
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.2.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.2.ebuild
deleted file mode 100644
index 45be3895313e..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.2.ebuild,v 1.4 2008/10/26 09:02:47 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-rpcgen-ioctl.patch
-}
-
-src_compile() {
- local myconf
- if use nonfsv4; then
- myconf="--disable-gss"
- else
- myconf="$(use_enable kerberos gss)"
- fi
-
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- ${myconf} \
- || die "Configure failed"
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- if use !nonfsv4 ; then
- list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- fi
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.3.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.3.ebuild
deleted file mode 100644
index c06d7983e713..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.3.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.3.ebuild,v 1.9 2008/12/30 20:15:38 bluebird Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- sys-libs/e2fsprogs-libs
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.1.2-rpcgen-ioctl.patch
-}
-
-src_compile() {
- local myconf
- if use nonfsv4 ; then
- myconf="--disable-gss"
- else
- myconf="$(use_enable kerberos gss)"
- fi
-
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- ${myconf} \
- || die "Configure failed"
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- if use !nonfsv4 ; then
- list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- fi
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.4.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.4.ebuild
deleted file mode 100644
index 419237483307..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.4.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.4.ebuild,v 1.4 2008/11/09 07:20:35 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- sys-libs/e2fsprogs-libs
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.21-r1
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.1.2-rpcgen-ioctl.patch
-}
-
-src_compile() {
- local myconf
- if use nonfsv4 ; then
- myconf="--disable-gss"
- else
- myconf="$(use_enable kerberos gss)"
- fi
-
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- ${myconf} \
- || die "Configure failed"
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- if use !nonfsv4 ; then
- list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- fi
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}