summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2012-09-26 17:55:07 +0000
committerVictor Ostorga <vostorga@gentoo.org>2012-09-26 17:55:07 +0000
commitd4bb2519df2aa19f8ddd1da311dee8c46dd5d176 (patch)
tree1f068af76645bc0667381f937baf25b24fe8a89a /net-fs/samba
parentRemove old. (diff)
downloadgentoo-2-d4bb2519df2aa19f8ddd1da311dee8c46dd5d176.tar.gz
gentoo-2-d4bb2519df2aa19f8ddd1da311dee8c46dd5d176.tar.bz2
gentoo-2-d4bb2519df2aa19f8ddd1da311dee8c46dd5d176.zip
Version bump of the ongoing samba 4. Ebuild based on the work of Torsten Kurbad, Ewoud Kohl van Wijngaarden et all at bug 195703
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'net-fs/samba')
-rw-r--r--net-fs/samba/ChangeLog9
-rw-r--r--net-fs/samba/metadata.xml2
-rw-r--r--net-fs/samba/samba-4.0.0_alpha11.ebuild157
-rw-r--r--net-fs/samba/samba-4.0.0_rc1.ebuild159
4 files changed, 167 insertions, 160 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 26b33bba7d7b..e00cfb5bff3a 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.523 2012/09/04 09:32:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.524 2012/09/26 17:55:07 vostorga Exp $
+
+*samba-4.0.0_rc1 (26 Sep 2012)
+
+ 26 Sep 2012; Víctor Ostorga <vostorga@gentoo.org>
+ -samba-4.0.0_alpha11.ebuild, +samba-4.0.0_rc1.ebuild:
+ Version bump of the ongoing samba 4. Ebuild based on the work of Torsten
+ Kurbad, Ewoud Kohl van Wijngaarden et all at bug 195703
04 Sep 2012; Patrick Lauer <patrick@gentoo.org> samba-3.5.17.ebuild:
Restricting cups 1.6
diff --git a/net-fs/samba/metadata.xml b/net-fs/samba/metadata.xml
index bd9570e510b7..78f801fa7ff8 100644
--- a/net-fs/samba/metadata.xml
+++ b/net-fs/samba/metadata.xml
@@ -16,8 +16,6 @@ Samba is an Open Source/Free Software suite that provides seamless file and prin
<flag name="client">Enables the client part</flag>
<flag name="server">Enables the server part</flag>
<flag name="netapi">Enable building of netapi bits</flag>
- <flag name="tools">Enable extra tools</flag>
- <flag name="dso">Enable dso support</flag>
<flag name="addns">Enable AD DNS integration</flag>
<flag name="aio">Enable asynchronous IO support</flag>
<flag name="cluster">Enable support for clustering</flag>
diff --git a/net-fs/samba/samba-4.0.0_alpha11.ebuild b/net-fs/samba/samba-4.0.0_alpha11.ebuild
deleted file mode 100644
index 269c7117499a..000000000000
--- a/net-fs/samba/samba-4.0.0_alpha11.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.0_alpha11.ebuild,v 1.6 2011/09/30 14:51:47 vostorga Exp $
-
-EAPI="2"
-
-inherit confutils
-
-MY_PV="${PV/_alpha/alpha}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Samba Server component"
-HOMEPAGE="http://www.samba.org/"
-SRC_URI="mirror://samba/samba4/${MY_P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="caps debug dso gnutls +netapi sqlite threads +client +server +tools +python"
-
-DEPEND="!net-fs/samba-libs
- !net-fs/samba-server
- !net-fs/samba-client
- dev-libs/popt
- sys-libs/readline
- virtual/libiconv
- caps? ( sys-libs/libcap )
- gnutls? ( net-libs/gnutls )
- sqlite? ( >=dev-db/sqlite-3 )
- >=sys-libs/talloc-2.0.1
- >=sys-libs/tdb-1.2.0
- >=sys-libs/tevent-0.9.8"
- #=sys-libs/ldb-0.9.10 No release yet
-# See source4/min_versions.m4 for the minimal versions
-RDEPEND="${DEPEND}"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}/${MY_P}/source4"
-
-pkg_setup() {
- SBINPROGS=""
- if use server ; then
- SBINPROGS="${SBINPROGS} bin/samba"
- fi
- if use client ; then
- SBINPROGS="${SBINPROGS} bin/mount.cifs bin/umount.cifs"
- fi
-
- BINPROGS=""
- if use client ; then
- BINPROGS="${BINPROGS} bin/smbclient bin/net bin/nmblookup bin/ntlm_auth"
- fi
- if use server ; then
- BINPROGS="${BINPROGS} bin/testparm bin/smbtorture"
- fi
- if use tools ; then
- # Should be in sys-libs/ldb, but there's no ldb release yet
- BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename"
- fi
- confutils_use_depend_all server python
-}
-
-src_configure() {
- # Upstream refuses to make this configurable
- use caps && export ac_cv_header_sys_capability_h=yes || export ac_cv_header_sys_capability_h=no
-
- econf \
- --sysconfdir=/etc \
- --localstatedir=/var \
- $(use_enable debug) \
- --enable-developer \
- $(use_enable dso) \
- --disable-external-heimdal \
- --enable-external-libtalloc \
- --enable-external-libtdb \
- --enable-external-libtevent \
- --disable-external-libldb \
- --enable-fhs \
- --enable-largefile \
- $(use_enable gnutls) \
- $(use_enable netapi) \
- --enable-socket-wrapper \
- --enable-nss-wrapper \
- --with-modulesdir=/usr/lib/samba/modules \
- --with-privatedir=/var/lib/samba/private \
- --with-ntp-signd-socket-dir=/var/run/samba \
- --with-lockdir=/var/cache/samba \
- --with-logfilebase=/var/log/samba \
- --with-piddir=/var/run/samba \
- --without-included-popt \
- $(use_with sqlite sqlite3) \
- $(use_with threads pthreads) \
- --with-setproctitle \
- --with-readline
-}
-
-src_compile() {
- # compile libs
- emake basics || die "emake basics failed"
- emake libraries || die "emake libraries failed"
-
- # compile python
- if use python ; then
- emake pythonmods || die "emake pythonmods failed"
- fi
-
- # compile binaries tools
- emake ${BINPROGS} || die "emake BINPROGS failed"
- emake ${SBINPROGS} || die "emake SBINPROGS failed"
-}
-
-src_install() {
- # install libs
- emake installlib DESTDIR="${D}" || die "emake installib failed"
- emake installheader DESTDIR="${D}" || die "emake installheader failed"
- emake installpc DESTDIR="${D}" || die "make installpc failed"
-
- # compile python
- if use python ; then
- emake installpython DESTDIR="${D}" || die "emake installpython failed"
- fi
-
- # binaries
- dosbin ${SBINPROGS} || die "installing SBINPROGS failed"
- dobin ${BINPROGS} || die "installing BINPROGS failed"
-
- # install server components
- if use server ; then
- # provision scripts
- insinto /usr/share/${PN}
- doins -r setup
- exeinto /usr/share/${PN}/setup
- doexe setup/{domainlevel,enableaccount,newuser,provision,pwsettings}
- doexe setup/{setexpiry,setpassword,upgrade_from_s3}
-
- # init script
- newinitd "${FILESDIR}/samba4.initd" samba
- fi
-}
-
-src_test() {
- emake test DESTDIR="${D}" || die "Test failed"
-}
-
-pkg_postinst() {
- # Optimize the python modules so they get properly removed
- use python && python_mod_optimize $(python_get_sitedir)/${PN}
-
- # Warn that it's an alpha
- ewarn "Samba 4 is an alpha and therefore not considered stable. It's only"
- ewarn "meant to test and experiment and definitely not for production"
-}
-
-pkg_postrm() {
- # Clean up the python modules
- use python && python_mod_cleanup $(python_get_sitedir)/${PN}
-}
diff --git a/net-fs/samba/samba-4.0.0_rc1.ebuild b/net-fs/samba/samba-4.0.0_rc1.ebuild
new file mode 100644
index 000000000000..038de96ccbfd
--- /dev/null
+++ b/net-fs/samba/samba-4.0.0_rc1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.0_rc1.ebuild,v 1.1 2012/09/26 17:55:07 vostorga Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.4"
+
+inherit confutils python waf-utils multilib linux-info
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+if [ "${PV}" = "4.9999" ]; then
+ EGIT_REPO_URI="git://git.samba.org/samba.git"
+ KEYWORDS=""
+ inherit git-2
+else
+ SRC_URI="mirror://samba/rc/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addns ads aio avahi client cluster cups debug fulltest gnutls iprint
+ldap pam quota swat syslog winbind"
+
+RDEPEND="dev-libs/iniparser
+ dev-libs/popt
+ sys-libs/readline
+ virtual/libiconv
+ >=dev-lang/python-2.4.2
+ dev-python/subunit
+ sys-libs/libcap
+ >=sys-libs/ldb-1.1.12
+ >=sys-libs/tdb-1.2.10[python]
+ >=sys-libs/talloc-2.0.7[python]
+ >=sys-libs/tevent-0.9.17
+ sys-libs/zlib
+ >=app-crypt/heimdal-1.5[-ssl]
+ ads? ( client? ( net-fs/cifs-utils[ads] ) )
+ client? ( net-fs/cifs-utils )
+ cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ ldap? ( net-nds/openldap )
+ gnutls? ( >=net-libs/gnutls-1.4.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ confutils_use_depend_all fulltest test
+
+ python_set_active_version 2
+ python_pkg_setup
+
+ if use aio; then
+ if ! linux_config_exists || ! linux_chkconfig_present AIO; then
+ ewarn "You must enable AIO support in your kernel config, "
+ ewarn "to be able to support asynchronous I/O. "
+ ewarn "You can find it at"
+ ewarn
+ ewarn "General Support"
+ ewarn " Enable AIO support "
+ ewarn
+ ewarn "and recompile your kernel..."
+ fi
+ fi
+}
+
+src_configure() {
+ local myconf=''
+ if use "debug"; then
+ myconf="${myconf} --enable-developer"
+ fi
+ if use "cluster"; then
+ myconf="${myconf} --with-ctdb-dir=/usr"
+ fi
+ myconf="${myconf} \
+ --enable-fhs \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-modulesdir=/usr/$(get_libdir) \
+ --disable-rpath \
+ --disable-rpath-install \
+ --nopyc \
+ --nopyo \
+ --disable-ntdb \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(use_with addns dnsupdate) \
+ $(use_with acl) \
+ $(use_with ads) \
+ $(use_with aio aio-support) \
+ $(use_enable avahi) \
+ $(use_with cluster cluster-support) \
+ $(use_enable cups) \
+ $(use_enable gnutls) \
+ $(use_enable iprint) \
+ $(use_with ldap) \
+ $(use_with pam) \
+ $(use_with pam pam_smbpass) \
+ $(use_with quota) \
+ $(use_with syslog) \
+ $(use_with swat) \
+ $(use_with winbind)"
+ CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
+ waf-utils_src_configure ${myconf}
+}
+
+src_install() {
+ waf-utils_src_install
+
+ # Make all .so files executable
+ find "${D}" -type f -name "*.so" -exec chmod +x {} +
+
+ # Move all LDB modules to their correct path
+ mkdir -p "${D}"/usr/$(get_libdir)/ldb/modules/ldb
+ mv "${D}"/usr/$(get_libdir)/ldb/*.so "${D}"/usr/$(get_libdir)/ldb/modules/ldb
+
+ # Install init script
+ newinitd "${CONFDIR}/samba4.initd" samba || die "newinitd failed"
+}
+
+src_test() {
+ local extra_opts=""
+ use fulltest || extra_opts+="--quick"
+ "${WAF_BINARY}" test ${extra_opts} || die "test failed"
+}
+
+pkg_postinst() {
+ # Optimize the python modules so they get properly removed
+ python_mod_optimize "${PN}"
+
+ # Warn that it's a release candidate
+ ewarn "This is not a final Samba release, however the Samba Team is now making"
+ ewarn "good progress towards a Samba 4.0 release, of which this is a preview."
+ ewarn "Be aware the this release contains the best of all of Samba's"
+ ewarn "technology parts, both a file server (that you can reasonably expect"
+ ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+ ewarn "controller work previously known as 'samba4'."
+
+ einfo "See http://wiki.samba.org/index.php/Samba4/HOWTO for more"
+ einfo "information about samba 4."
+}
+
+pkg_postrm() {
+ # Clean up the python modules
+ python_mod_cleanup "${PN}"
+}