summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-03-22 21:00:47 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-03-22 21:00:47 +0000
commit0d860f9cd4051972f8b364ee05d286e13c804f0f (patch)
tree64d8f5832d6b7ad04bd37012d5cc6f644fea4eb6 /net-fs
parentamd64 stable wrt bug #544034 (diff)
downloadgentoo-2-0d860f9cd4051972f8b364ee05d286e13c804f0f.tar.gz
gentoo-2-0d860f9cd4051972f8b364ee05d286e13c804f0f.tar.bz2
gentoo-2-0d860f9cd4051972f8b364ee05d286e13c804f0f.zip
version bump
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs-kernel/ChangeLog9
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.6.11.ebuild117
2 files changed, 125 insertions, 1 deletions
diff --git a/net-fs/openafs-kernel/ChangeLog b/net-fs/openafs-kernel/ChangeLog
index d699b02c4ca5..e9054078c58c 100644
--- a/net-fs/openafs-kernel/ChangeLog
+++ b/net-fs/openafs-kernel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/openafs-kernel
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.163 2015/03/17 18:47:57 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.164 2015/03/22 21:00:47 bircoph Exp $
+
+*openafs-kernel-1.6.11 (22 Mar 2015)
+
+ 22 Mar 2015; Andrew Savchenko <bircoph@gentoo.org>
+ +openafs-kernel-1.6.11.ebuild:
+ Version bump based on proxied maintainer commit from NP-hardass
+ <np.hardass@gmail.com>. Fixes bugs 476332, 497006, 500378.
17 Mar 2015; Andrew Savchenko <bircoph@gentoo.org> metadata.xml:
Update maintainers information.
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.6.11.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.6.11.ebuild
new file mode 100644
index 000000000000..258d48ab34f5
--- /dev/null
+++ b/net-fs/openafs-kernel/openafs-kernel-1.6.11.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.6.11.ebuild,v 1.1 2015/03/22 21:00:47 bircoph Exp $
+
+EAPI="5"
+
+inherit autotools eutils linux-mod multilib toolchain-funcs versionator
+
+MY_PV=$(delete_version_separator '_')
+MY_P="${PN/-kernel}-${MY_PV}"
+PVER="1"
+OAFS_PVER="1.6.5"
+
+DESCRIPTION="The OpenAFS distributed file system kernel module"
+HOMEPAGE="http://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+[[ ${PV} == *_pre* ]] && MY_PRE="candidate/" || MY_PRE=""
+SRC_URI="
+ http://openafs.org/dl/openafs/${MY_PRE}${MY_PV}/${MY_P}-src.tar.bz2
+ http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-doc.tar.bz2
+ http://dev.gentoo.org/~bircoph/patches/${MY_P}-patches.tar.xz
+"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS KEYS"
+ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
+ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
+ERROR_KEYS="OpenAFS needs CONFIG_KEYS option enabled"
+
+QA_TEXTRELS_x86_fbsd="/boot/modules/libafs.ko"
+QA_TEXTRELS_amd64_fbsd="/boot/modules/libafs.ko"
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is ge 4 ; then
+ ewarn "Gentoo supports kernels which are supported by OpenAFS"
+ ewarn "which are limited to the kernel versions: <4.0"
+ ewarn ""
+ ewarn "You are free to utilize epatch_user to provide whatever"
+ ewarn "support you feel is appropriate, but will not receive"
+ ewarn "support as a result of those changes."
+ ewarn ""
+ ewarn "Please do not file a bug report about this."
+ fi
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ linux-mod_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # do not tamper with CFLAGS for the kernel module
+ EPATCH_EXCLUDE="040_all_flags.patch" \
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/gentoo/patches
+ epatch_user
+
+ # packaging is f-ed up, so we can't run eautoreconf
+ # run autotools commands based on what is listed in regen.sh
+ eaclocal -I src/cf
+ eautoconf
+ eautoconf -o configure-libafs configure-libafs.ac
+ eautoheader
+ einfo "Deleting autom4te.cache directory"
+ rm -rf autom4te.cache
+}
+
+src_configure() {
+ local myconf=""
+ # OpenAFS 1.6.11 has a bug with kernels 3.17-3.17.2 that requires a config option
+ if use kernel_linux && kernel_is -ge 3 17 && kernel_is -le 3 17 2; then
+ myconf="--enable-linux-d_splice_alias-extra-iput"
+ fi
+
+ ARCH="$(tc-arch-kernel)" \
+ econf \
+ --with-linux-kernel-headers=${KV_DIR} \
+ --with-linux-kernel-build=${KV_OUT_DIR} \
+ ${myconf}
+}
+
+src_compile() {
+ ARCH="$(tc-arch-kernel)" AR="$(tc-getAR)" emake V=1 -j1 only_libafs
+}
+
+src_install() {
+ if use kernel_linux; then
+ local srcdir=$(expr "${S}"/src/libafs/MODLOAD-*)
+ [[ -f ${srcdir}/libafs.${KV_OBJ} ]] || die "Couldn't find compiled kernel module"
+
+ MODULE_NAMES="libafs(fs/openafs:${srcdir})"
+
+ linux-mod_src_install
+ elif use kernel_FreeBSD; then
+ insinto /boot/modules
+ doins "${S}"/src/libafs/MODLOAD/libafs.ko
+ fi
+}
+
+pkg_postinst() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+ use kernel_linux && linux-mod_pkg_postinst
+}
+
+pkg_postrm() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+ use kernel_linux && linux-mod_pkg_postrm
+}