summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-07 11:21:21 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-08-07 11:21:21 +0000
commit1cc7243dcb95171eb2c13bcec6f59df351108be7 (patch)
tree31ee6ac2e3c0d41ab8d91844e74d1834a9180054 /net-fs
parentAdd a live ebuild, remove unnecessary inherit from -2.4.0. (diff)
downloadgentoo-2-1cc7243dcb95171eb2c13bcec6f59df351108be7.tar.gz
gentoo-2-1cc7243dcb95171eb2c13bcec6f59df351108be7.tar.bz2
gentoo-2-1cc7243dcb95171eb2c13bcec6f59df351108be7.zip
Version bump. Removed old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 981CA6FC)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog8
-rw-r--r--net-fs/samba/files/samba-4.2.3-heimdal_compilefix.patch22
-rw-r--r--net-fs/samba/samba-4.2.3.ebuild (renamed from net-fs/samba/samba-4.2.0.ebuild)16
3 files changed, 40 insertions, 6 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 764bda7d5975..0e662b70eb23 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.718 2015/06/28 03:34:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.719 2015/08/07 11:21:21 polynomial-c Exp $
+
+*samba-4.2.3 (07 Aug 2015)
+
+ 07 Aug 2015; Lars Wendler <polynomial-c@gentoo.org> -samba-4.2.0.ebuild,
+ +samba-4.2.3.ebuild, +files/samba-4.2.3-heimdal_compilefix.patch:
+ Version bump. Removed old.
28 Jun 2015; Patrick Lauer <patrick@gentoo.org> samba-4.0.26.ebuild,
samba-4.1.18.ebuild, samba-4.1.19.ebuild, samba-4.2.0.ebuild:
diff --git a/net-fs/samba/files/samba-4.2.3-heimdal_compilefix.patch b/net-fs/samba/files/samba-4.2.3-heimdal_compilefix.patch
new file mode 100644
index 000000000000..c6f50073317a
--- /dev/null
+++ b/net-fs/samba/files/samba-4.2.3-heimdal_compilefix.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/542638
+
+From: Stephan Wolf <stephan@letzte-bankreihe.de>
+
+Samba uses the build in implementation of heimdal from year 2011.
+The ebuild uses the portage version of heimdal.
+I got it fixed to patch samba kdc_init function.
+
+--- samba-4.2.3/source4/kdc/kdc.c
++++ samba-4.2.3/source4/kdc/kdc.c
+@@ -967,9 +967,9 @@
+ * The old behavior in the _kdc_get_preferred_key()
+ * function is use_strongest_server_key=TRUE.
+ */
+- kdc->config->as_use_strongest_session_key = false;
++ kdc->config->tgt_use_strongest_session_key = false;
+ kdc->config->preauth_use_strongest_session_key = false;
+- kdc->config->tgs_use_strongest_session_key = false;
++ kdc->config->svc_use_strongest_session_key = false;
+ kdc->config->use_strongest_server_key = true;
+
+ /* Register hdb-samba4 hooks for use as a keytab */
diff --git a/net-fs/samba/samba-4.2.0.ebuild b/net-fs/samba/samba-4.2.3.ebuild
index 9343253cef52..e3733af8b094 100644
--- a/net-fs/samba/samba-4.2.0.ebuild
+++ b/net-fs/samba/samba-4.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.2.0.ebuild,v 1.3 2015/06/28 03:34:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.2.3.ebuild,v 1.1 2015/08/07 11:21:21 polynomial-c Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -42,9 +42,9 @@ CDEPEND="${PYTHON_DEPS}
>=sys-libs/ldb-1.1.20
>=sys-libs/nss_wrapper-1.0.2
>=sys-libs/ntdb-1.0[python,${PYTHON_USEDEP}]
- >=sys-libs/talloc-2.1.1[python,${PYTHON_USEDEP}]
- >=sys-libs/tdb-1.3.4[python,${PYTHON_USEDEP}]
- >=sys-libs/tevent-0.9.24
+ >=sys-libs/talloc-2.1.2[python,${PYTHON_USEDEP}]
+ >=sys-libs/tdb-1.3.6[python,${PYTHON_USEDEP}]
+ >=sys-libs/tevent-0.9.25
>=sys-libs/uid_wrapper-1.0.1
sys-libs/zlib
virtual/pam
@@ -66,13 +66,15 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-samba )
"
-REQUIRED_USE="ads? ( acl ldap )
+REQUIRED_USE="ads? ( acl gnutls ldap )
${PYTHON_REQUIRED_USE}"
RESTRICT="mirror"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${PN}-4.2.3-heimdal_compilefix.patch" )
+
CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
WAF_BINARY="${S}/buildtools/bin/waf"
@@ -93,6 +95,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch ${PATCHES[@]}
+}
+
src_configure() {
local myconf=''
use "cluster" && myconf+=" --with-ctdb-dir=/usr"