summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-07 17:34:17 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-07 17:34:17 +0000
commit69c8e3216342d150746daf4fab021eb878192c2f (patch)
treee5d3c1ec94595883ed6657fa4e1497036db04bc2 /net-fs
parentMake gv read its config, bug 158322 (diff)
downloadgentoo-2-69c8e3216342d150746daf4fab021eb878192c2f.tar.gz
gentoo-2-69c8e3216342d150746daf4fab021eb878192c2f.tar.bz2
gentoo-2-69c8e3216342d150746daf4fab021eb878192c2f.zip
old
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.12-r23
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.12-r2.ebuild109
2 files changed, 0 insertions, 112 deletions
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.12-r2 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.12-r2
deleted file mode 100644
index bdb8c3cf47a5..000000000000
--- a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.12-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 acf3656cec3872deb597aa7ac13f3c3a nfs-utils-1.0.12.tar.gz 778576
-RMD160 a00dbdae386acf3f969714a1571749182c5a19a8 nfs-utils-1.0.12.tar.gz 778576
-SHA256 67d81a53d84777c733ff8a5cf5f3eed9ecda17fb9f949bc65727c1a3427af8ac nfs-utils-1.0.12.tar.gz 778576
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.12-r2.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.12-r2.ebuild
deleted file mode 100644
index fb6f28442691..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.0.12-r2.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.12-r2.ebuild,v 1.3 2007/04/07 10:58:43 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- )
- kerberos? (
- net-libs/librpcsecgss
- app-crypt/mit-krb5
- )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${P}-mountd-memleak.patch #172014
- #epatch "${DISTDIR}"/nfs-utils-${PV}-CITI_NFS4_ALL-1.dif
-}
-
-src_compile() {
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- $(use_enable kerberos gss) \
- || die "Configure failed"
-
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.{lockd,statd} "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f
- for f in nfs nfsmount rpc.statd ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
-
- if use kerberos ; then
- doins utils/idmapd/idmapd.conf
- for f in rpc.gssd rpc.idmapd ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- fi
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}