summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-08-08 08:16:31 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-08-08 08:16:31 +0000
commitb99c0cc349783bdcd5ee56db139f7089a461fbf6 (patch)
tree90f1ba56754ae3fe2d4a174d9835bb9c1580fd0f /net-fs
parentCleanup (diff)
downloadgentoo-2-b99c0cc349783bdcd5ee56db139f7089a461fbf6.tar.gz
gentoo-2-b99c0cc349783bdcd5ee56db139f7089a461fbf6.tar.bz2
gentoo-2-b99c0cc349783bdcd5ee56db139f7089a461fbf6.zip
Removed vulnerable versions
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog6
-rw-r--r--net-fs/samba/samba-4.0.19.ebuild179
-rw-r--r--net-fs/samba/samba-4.1.9.ebuild172
3 files changed, 5 insertions, 352 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 1004247cc203..571e1076cfae 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.680 2014/08/07 19:32:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.681 2014/08/08 08:16:31 polynomial-c Exp $
+
+ 08 Aug 2014; Lars Wendler <polynomial-c@gentoo.org> -samba-4.0.19.ebuild,
+ -samba-4.1.9.ebuild:
+ Removed vulnerable versions.
07 Aug 2014; Jeroen Roovers <jer@gentoo.org> samba-3.6.23-r1.ebuild:
Stable for HPPA (bug #512012).
diff --git a/net-fs/samba/samba-4.0.19.ebuild b/net-fs/samba/samba-4.0.19.ebuild
deleted file mode 100644
index a3aa382ba50d..000000000000
--- a/net-fs/samba/samba-4.0.19.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.19.ebuild,v 1.1 2014/07/11 13:07:20 polynomial-c Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-r1 waf-utils multilib linux-info systemd
-
-MY_PV="${PV/_rc/rc}"
-MY_P="${PN}-${MY_PV}"
-
-if [ "${PV}" = "4.9999" ]; then
- EGIT_REPO_URI="git://git.samba.org/samba.git"
- KEYWORDS=""
- inherit git-2
-else
- SRC_URI="mirror://samba/stable/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~hppa ~x86"
-fi
-
-DESCRIPTION="Samba Suite Version 4"
-HOMEPAGE="http://www.samba.org/"
-LICENSE="GPL-3"
-
-SLOT="0"
-
-IUSE="acl addns ads aio avahi client cluster cups dmapi fam gnutls iprint
-ldap quota selinux swat syslog test winbind"
-
-# sys-apps/attr is an automagic dependency (see bug #489748)
-# sys-libs/pam is an automagic dependency (see bug #489770)
-CDEPEND="${PYTHON_DEPS}
- >=app-crypt/heimdal-1.5[-ssl]
- dev-libs/iniparser
- dev-libs/popt
- sys-libs/readline
- virtual/libiconv
- dev-python/subunit
- sys-apps/attr
- sys-libs/libcap
- >=sys-libs/ldb-1.1.16
- >=sys-libs/tdb-1.2.11[python]
- >=sys-libs/talloc-2.0.8[python]
- >=sys-libs/tevent-0.9.18
- sys-libs/zlib
- virtual/pam
- acl? ( virtual/acl )
- addns? ( net-dns/bind-tools[gssapi] )
- aio? ( dev-libs/libaio )
- cluster? ( >=dev-db/ctdb-1.0.114_p1 )
- cups? ( net-print/cups )
- dmapi? ( sys-apps/dmapi )
- fam? ( virtual/fam )
- gnutls? ( dev-libs/libgcrypt:0
- >=net-libs/gnutls-1.4.0 )
- ldap? ( net-nds/openldap )
- selinux? ( sec-policy/selinux-samba )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- client? ( net-fs/cifs-utils[ads?] )"
-
-REQUIRED_USE="ads? ( acl ldap )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}/${MY_P}"
-
-CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
-
-# sys-apps/dmapi is an automagic dependency (see bug #474492)
-PATCHES=(
- "${FILESDIR}/${PN}-4.1.0-remove-dmapi-automagic.patch"
- "${FILESDIR}/named.conf.dlz.patch"
- "${FILESDIR}/${PN}-4.0.19-automagic_aio_fix.patch"
-)
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python_export_best
- if use aio; then
- if ! linux_config_exists || ! linux_chkconfig_present AIO; then
- ewarn "You must enable AIO support in your kernel config, "
- ewarn "to be able to support asynchronous I/O. "
- ewarn "You can find it at"
- ewarn
- ewarn "General Support"
- ewarn " Enable AIO support "
- ewarn
- ewarn "and recompile your kernel..."
- fi
- fi
-}
-
-src_configure() {
- local myconf=''
- use "cluster" && myconf+=" --with-ctdb-dir=/usr"
- use "test" && myconf+=" --enable-selftest"
- myconf="${myconf} \
- --enable-fhs \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-modulesdir=/usr/$(get_libdir)/samba \
- --with-pammodulesdir=/$(get_libdir)/security \
- --with-piddir=/var/run/${PN} \
- --disable-rpath \
- --disable-rpath-install \
- --nopyc \
- --nopyo \
- --disable-ntdb \
- --bundled-libraries=NONE \
- --builtin-libraries=NONE \
- $(use_with addns dnsupdate) \
- $(use_with acl acl-support) \
- $(use_with ads) \
- $(use_with aio aio-support) \
- $(use_enable avahi) \
- $(use_with cluster cluster-support) \
- $(use_enable cups) \
- $(use_with dmapi) \
- $(use_with fam) \
- $(use_enable gnutls) \
- $(use_enable iprint) \
- $(use_with ldap) \
- --with-pam \
- --with-pam_smbpass \
- $(use_with quota quotas) \
- $(use_with syslog) \
- $(use_with swat) \
- $(use_with winbind)
- "
- use "ads" && myconf+=" --with-shared-modules=idmap_ad"
-
- CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
- waf-utils_src_configure ${myconf}
-}
-
-src_install() {
- waf-utils_src_install
-
- # install ldap schema for server (bug #491002)
- if use ldap ; then
- insinto /etc/openldap/schema
- doins examples/LDAP/samba.schema
- fi
-
- # Make all .so files executable
- find "${D}" -type f -name "*.so" -exec chmod +x {} +
-
- # Install init script and conf.d file
- newinitd "${CONFDIR}/samba4.initd-r1" samba
- newconfd "${CONFDIR}/samba4.confd" samba
-
- systemd_dotmpfilesd "${FILESDIR}"/samba.conf
- systemd_dounit "${FILESDIR}"/nmbd.service
- systemd_dounit "${FILESDIR}"/smbd.{service,socket}
- systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
- systemd_dounit "${FILESDIR}"/winbindd.service
-}
-
-src_test() {
- "${WAF_BINARY}" test || die "test failed"
-}
-
-pkg_postinst() {
- elog "This is is the first stable release of Samba 4.0"
-
- ewarn "Be aware the this release contains the best of all of Samba's"
- ewarn "technology parts, both a file server (that you can reasonably expect"
- ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
- ewarn "controller work previously known as 'samba4'."
-
- elog "For further information and migration steps make sure to read "
- elog "http://samba.org/samba/history/${P}.html "
- elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
- elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
-}
diff --git a/net-fs/samba/samba-4.1.9.ebuild b/net-fs/samba/samba-4.1.9.ebuild
deleted file mode 100644
index e247f1e4fac7..000000000000
--- a/net-fs/samba/samba-4.1.9.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.9.ebuild,v 1.1 2014/07/11 13:07:20 polynomial-c Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-r1 waf-utils multilib linux-info systemd
-
-MY_PV="${PV/_rc/rc}"
-MY_P="${PN}-${MY_PV}"
-
-SRC_URI="mirror://samba/stable/${MY_P}.tar.gz"
-KEYWORDS="~amd64 ~hppa ~x86"
-
-DESCRIPTION="Samba Suite Version 4"
-HOMEPAGE="http://www.samba.org/"
-LICENSE="GPL-3"
-
-SLOT="0"
-
-IUSE="acl addns ads aio avahi client cluster cups dmapi fam gnutls iprint
-ldap quota selinux syslog test winbind"
-
-# sys-apps/attr is an automagic dependency (see bug #489748)
-# dev-libs/libaio is an automagic dependency (see bug #489764)
-# sys-libs/pam is an automagic dependency (see bug #489770)
-CDEPEND="${PYTHON_DEPS}
- >=app-crypt/heimdal-1.5[-ssl]
- dev-libs/iniparser
- dev-libs/popt
- sys-libs/readline
- virtual/libiconv
- dev-python/subunit
- sys-apps/attr
- sys-libs/libcap
- >=sys-libs/ntdb-1.0[python]
- >=sys-libs/ldb-1.1.16
- >=sys-libs/tdb-1.2.11[python]
- >=sys-libs/talloc-2.0.8[python]
- >=sys-libs/tevent-0.9.18
- sys-libs/zlib
- virtual/pam
- acl? ( virtual/acl )
- addns? ( net-dns/bind-tools[gssapi] )
- aio? ( dev-libs/libaio )
- cluster? ( >=dev-db/ctdb-1.0.114_p1 )
- cups? ( net-print/cups )
- dmapi? ( sys-apps/dmapi )
- fam? ( virtual/fam )
- gnutls? ( dev-libs/libgcrypt:0
- >=net-libs/gnutls-1.4.0 )
- ldap? ( net-nds/openldap )
- selinux? ( sec-policy/selinux-samba )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- client? ( net-fs/cifs-utils[ads?] )"
-
-REQUIRED_USE="ads? ( acl ldap )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}/${MY_P}"
-
-CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
-
-# sys-apps/dmapi is an automagic dependency (see bug #474492)
-PATCHES=(
- "${FILESDIR}/${PN}-4.1.0-remove-dmapi-automagic.patch"
- "${FILESDIR}/named.conf.dlz.patch"
- "${FILESDIR}/${PN}-4.0.19-automagic_aio_fix.patch"
-)
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python_export_best
- if use aio; then
- if ! linux_config_exists || ! linux_chkconfig_present AIO; then
- ewarn "You must enable AIO support in your kernel config, "
- ewarn "to be able to support asynchronous I/O. "
- ewarn "You can find it at"
- ewarn
- ewarn "General Support"
- ewarn " Enable AIO support "
- ewarn
- ewarn "and recompile your kernel..."
- fi
- fi
-}
-
-src_configure() {
- local myconf=''
- use "cluster" && myconf+=" --with-ctdb-dir=/usr"
- use "test" && myconf+=" --enable-selftest"
- myconf="${myconf} \
- --enable-fhs \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-modulesdir=/usr/$(get_libdir)/samba \
- --with-pammodulesdir=/$(get_libdir)/security \
- --with-piddir=/var/run/${PN} \
- --disable-rpath \
- --disable-rpath-install \
- --nopyc \
- --nopyo \
- --bundled-libraries=NONE \
- --builtin-libraries=NONE \
- $(use_with addns dnsupdate) \
- $(use_with acl acl-support) \
- $(use_with ads) \
- $(use_with aio aio-support) \
- $(use_enable avahi) \
- $(use_with cluster cluster-support) \
- $(use_enable cups) \
- $(use_with dmapi) \
- $(use_with fam) \
- $(use_enable gnutls) \
- $(use_enable iprint) \
- $(use_with ldap) \
- --with-pam \
- --with-pam_smbpass \
- $(use_with quota quotas) \
- $(use_with syslog) \
- $(use_with winbind)
- "
- use "ads" && myconf+=" --with-shared-modules=idmap_ad"
-
- CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
- waf-utils_src_configure ${myconf}
-}
-
-src_install() {
- waf-utils_src_install
-
- # install ldap schema for server (bug #491002)
- if use ldap ; then
- insinto /etc/openldap/schema
- doins examples/LDAP/samba.schema
- fi
-
- # Make all .so files executable
- find "${D}" -type f -name "*.so" -exec chmod +x {} +
-
- # Install init script and conf.d file
- newinitd "${CONFDIR}/samba4.initd-r1" samba
- newconfd "${CONFDIR}/samba4.confd" samba
-
- systemd_dotmpfilesd "${FILESDIR}"/samba.conf
- systemd_dounit "${FILESDIR}"/nmbd.service
- systemd_dounit "${FILESDIR}"/smbd.{service,socket}
- systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
- systemd_dounit "${FILESDIR}"/winbindd.service
- systemd_dounit "${FILESDIR}"/samba.service
-}
-
-src_test() {
- "${WAF_BINARY}" test || die "test failed"
-}
-
-pkg_postinst() {
- ewarn "Be aware the this release contains the best of all of Samba's"
- ewarn "technology parts, both a file server (that you can reasonably expect"
- ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
- ewarn "controller work previously known as 'samba4'."
-
- elog "For further information and migration steps make sure to read "
- elog "http://samba.org/samba/history/${P}.html "
- elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
- elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
-}