summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-17 06:02:52 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-17 06:02:52 +0000
commitd35b8d1a70babbb1e2b3375d0d4fa05cf0dddff8 (patch)
tree7fc3329c4a719a7611f4f423a9e75c432186aa85 /net-fs
parentupdated samba-2.2.1a to samba-2.2.2 (diff)
downloadgentoo-2-d35b8d1a70babbb1e2b3375d0d4fa05cf0dddff8.tar.gz
gentoo-2-d35b8d1a70babbb1e2b3375d0d4fa05cf0dddff8.tar.bz2
gentoo-2-d35b8d1a70babbb1e2b3375d0d4fa05cf0dddff8.zip
updated from samba-2.2.1a to samba-2.2.2. launched the spaces in the
ebuilds and initscript for tabs. pretty major cleanup of the docs installation. previous it was a huge dodoc affair, and basically completely unmaintainable. ive just made it include *all* its docs now. hehe. i dont see a problem doing this.
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/files/digest-samba-2.2.1a-r21
-rw-r--r--net-fs/samba/files/digest-samba-2.2.1a-r61
-rw-r--r--net-fs/samba/files/digest-samba-2.2.21
-rw-r--r--net-fs/samba/files/digest-samba-2.2.2-r61
-rw-r--r--net-fs/samba/files/samba.rc638
-rw-r--r--net-fs/samba/samba-2.2.1a-r2.ebuild160
-rw-r--r--net-fs/samba/samba-2.2.1a-r6.ebuild157
-rw-r--r--net-fs/samba/samba-2.2.2-r6.ebuild145
-rw-r--r--net-fs/samba/samba-2.2.2.ebuild125
9 files changed, 291 insertions, 338 deletions
diff --git a/net-fs/samba/files/digest-samba-2.2.1a-r2 b/net-fs/samba/files/digest-samba-2.2.1a-r2
deleted file mode 100644
index cf8c8070105a..000000000000
--- a/net-fs/samba/files/digest-samba-2.2.1a-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c8810245887bc080191d755fab961760 samba-2.2.1a.tar.gz
diff --git a/net-fs/samba/files/digest-samba-2.2.1a-r6 b/net-fs/samba/files/digest-samba-2.2.1a-r6
deleted file mode 100644
index cf8c8070105a..000000000000
--- a/net-fs/samba/files/digest-samba-2.2.1a-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c8810245887bc080191d755fab961760 samba-2.2.1a.tar.gz
diff --git a/net-fs/samba/files/digest-samba-2.2.2 b/net-fs/samba/files/digest-samba-2.2.2
new file mode 100644
index 000000000000..4fba34463fc1
--- /dev/null
+++ b/net-fs/samba/files/digest-samba-2.2.2
@@ -0,0 +1 @@
+MD5 d0aba688a1b6189f09f3ba0b44b1da8e samba-2.2.2.tar.gz
diff --git a/net-fs/samba/files/digest-samba-2.2.2-r6 b/net-fs/samba/files/digest-samba-2.2.2-r6
new file mode 100644
index 000000000000..4fba34463fc1
--- /dev/null
+++ b/net-fs/samba/files/digest-samba-2.2.2-r6
@@ -0,0 +1 @@
+MD5 d0aba688a1b6189f09f3ba0b44b1da8e samba-2.2.2.tar.gz
diff --git a/net-fs/samba/files/samba.rc6 b/net-fs/samba/files/samba.rc6
index ea82199cc1d5..d25a8fd9bc80 100644
--- a/net-fs/samba/files/samba.rc6
+++ b/net-fs/samba/files/samba.rc6
@@ -1,32 +1,32 @@
#!/sbin/runscript
depend() {
- need net
+ need net
}
checkconfig() {
- if [ ! -e /etc/smb/smb.conf ] ; then
- eerror "You need an /etc/smb/smb.conf file first"
- eerror "There is a sample in /usr/share/doc/samba"
- return 1
- fi
+ if [ ! -e /etc/smb/smb.conf ] ; then
+ eerror "You need an /etc/smb/smb.conf file first"
+ eerror "There is a sample in /usr/share/doc/samba"
+ return 1
+ fi
}
start() {
- checkconfig || return 1
- ebegin "Starting samba"
- start-stop-daemon --start --quiet --exec /usr/sbin/nmbd
- result=$?
- start-stop-daemon --start --quiet --exec /usr/sbin/smbd
- result=$(( $result + $? ))
- eend $result
+ checkconfig || return 1
+ ebegin "Starting samba"
+ start-stop-daemon --start --quiet --exec /usr/sbin/nmbd
+ result=$?
+ start-stop-daemon --start --quiet --exec /usr/sbin/smbd
+ result=$(( $result + $? ))
+ eend $result
}
stop() {
- ebegin "Stopping samba"
- start-stop-daemon --stop --quiet --exec /usr/sbin/nmbd
- result=$?
- start-stop-daemon --stop --quiet --exec /usr/sbin/smbd
- result=$(( $result + $? ))
- eend $result
+ ebegin "Stopping samba"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/nmbd
+ result=$?
+ start-stop-daemon --stop --quiet --exec /usr/sbin/smbd
+ result=$(( $result + $? ))
+ eend $result
}
diff --git a/net-fs/samba/samba-2.2.1a-r2.ebuild b/net-fs/samba/samba-2.2.1a-r2.ebuild
deleted file mode 100644
index 8204dd34d634..000000000000
--- a/net-fs/samba/samba-2.2.1a-r2.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.1a-r2.ebuild,v 1.3 2001/09/02 11:21:31 woodchip Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Samba :)"
-SRC_URI="http://us1.samba.org/samba/ftp/${P}.tar.gz"
-HOMEPAGE="http://www.samba.org"
-
-DEPEND="virtual/glibc sys-devel/autoconf
- cups? ( net-print/cups )
- pam? ( >=sys-libs/pam-0.72 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-
-RDEPEND="virtual/glibc cups? ( net-print/cups )"
-# PAM support can cause lots of problems. We want the admin of the box to
-# do this on his own. There is a mailing list thread on samba-devel that's
-# about 40 posts long about this
-# pam? ( >=sys-libs/pam-0.72 )"
-
-
-src_unpack() {
-
- unpack ${A}
- if [ "`use afs`" ]; then
- cd ${S}
- patch -p0 < ${FILESDIR}/patch.221a.10 || die
- fi
-
- if [ ! "`use cups`" ] ; then
- cd ${S}/source
- cp configure.in configure.in.orig
- sed -e "s:AC_CHECK_LIB(cups,httpConnect)::" configure.in.orig > configure.in
- autoconf || die
- fi
-}
-
-
-src_compile() {
-
- local myconf
- use afs && myconf="$myconf --with-afs"
-
- # Again same as above, PAM and Samba not good. Consult samba.org for
- # details. Only enable if you KNOW what you're doing and you really really
- # wanna venture down this path.
- # use pam && myconf="${myconf} --with-pam"
- myconf="${myconf} --without-pam"
-
- # Samba doesn't seem to work well with ssl support but I'll add the check
- # anyway (otherwise it seems to be built with ssl if it finds it). This should
- # be tested. I'll mail gentoo-dev and add a todo in wiki. /Hallski
- # use ssl && myconf="${myconf} --with-ssl"
- myconf="${myconf} --without-ssl"
-
- cd ${S}/source
- # Disabled automout support, because it failed
- ./configure --prefix=/usr --sysconfdir=/etc/smb --localstatedir=/var/log \
- --libdir=/etc/smb --sbindir=/usr/sbin --without-automount --with-utmp \
- --without-sambabook --with-netatalk --with-privatedir=/etc/smb/private \
- --with-smbmount --with-msdfs --with-vfs --with-spinlocks \
- --with-lockdir=/var/run/smb --with-swatdir=/usr/share/swat \
- --with-mandir=/usr/share/man --with-profile ${myconf}
- assert
- make || die
-}
-
-
-src_install() {
-
- cd ${S}/source
- dodir /usr
- dodir /etc/smb
- dodir /usr/share/swat
- dodir /usr/share/doc/${PF}/html/book
- dodir /var/log
- dodir /var/run/smb
-
- make install prefix=${D}/usr BASEDIR=${D}/usr PRIVATEDIR=${D}/etc/smb/private \
- LIBDIR=${D}/etc/smb VARDIR=${D}/var/log SWATDIR=${D}/usr/share/swat \
- LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man
- assert
-
- # we specified PRIVATEDIR=/etc/smb/private
- rm -rf ${D}/usr/private
- diropts -m 0700
- dodir /etc/smb/private
-
- # move smbmount from /usr/sbin to /sbin, and rename it to mount.smbfs
- # which allows it to work transparently with standard 'mount' command
- diropts -m 0755 ; dodir /sbin
- mv ${D}/usr/bin/smbmount ${D}/sbin/mount.smbfs
-
- cd ${S}/source/script
- exeinto /usr/sbin
- doexe convert_smbpasswd mknissmbpasswd.sh mknissmbpwdtbl.sh mksmbpasswd.sh smbtar
-
- # docs. samba has some really good ones.
- cd ${S}
- cp -a examples ${D}/usr/doc/${PF}
- insinto /etc/smb ; insopts -m 0644 ; newins examples/smb.conf.default smb.conf.eg
- insinto /usr/share/sgml/docbook/dbsgml ; doins docs/docbook/dbsgml/*
- insinto /usr/share/sgml/docbook/dbsgml/ent ; doins docs/docbook/dbsgml/ent/*
- dodoc COPYING Manifest README Roadmap WHATSNEW.txt
- cd ${S}/docs ; dodoc announce history samba.lsm THANKS
- docinto reg ; dodoc *.reg
- docinto html ; dodoc htmldocs/*.html
- docinto html/book ; dodoc htmldocs/using_samba/*.html
- docinto html/book/gifs ; dodoc htmldocs/using_samba/gifs/*
- docinto html/book/figs ; dodoc htmldocs/using_samba/figs/*
- docinto faq ; dodoc faq/*.txt
- docinto html/faq ; dodoc faq/*.html
- docinto textdocs ; dodoc textdocs/*.txt textdocs/README*
- docinto print ; dodoc textdocs/*.{tex,ps,pdf}
- docinto sgml/faq ; dodoc faq/*.sgml
- docinto sgml/docbook/faq ; dodoc docbook/faq/*.sgml
- docinto sgml/docbook/howto ; dodoc docbook/howto/*.sgml
- docinto sgml/docbook/manpages ; dodoc docbook/manpages/*.sgml
- docinto sgml/docbook/projdoc ; dodoc docbook/projdoc/*.sgml
-
- # install a standard, standalone-type init script
- exeinto /etc/rc.d/init.d ; exeopts -m 0755
- newexe ${FILESDIR}/samba.rc5 samba
-}
-
-
-pkg_preinst() {
-
- if [ "$ROOT" = "/" ] && [ -e /etc/rc.d/init.d/samba ] ; then
- /etc/rc.d/init.d/samba stop
- fi
- return 0
-}
-
-
-pkg_postinst() {
-
- # we touch ${D}/etc/smb/smb.conf so that people installing samba just to mount smb shares
- # don't get annoying warnings all the time.
- if [ ! -e ${ROOT}etc/smb/smb.conf ] ; then
- touch ${ROOT}etc/smb/smb.conf
- fi
-
- echo " #"
- echo " To configure samba (the server) to start on boot, type:"
- echo " % rc-update add samba [ for normal standalone samba ]"
- echo
- echo " If you had samba running earlier, you'll need to start it again. Also, please note"
- echo " that you must configure /etc/smb/smb.conf before samba (the server) will work properly."
- echo " Mounting smb shares and the smbclient program should work immediately. To accomplish"
- echo " this there is an empty /etc/smb/smb.conf file installed."
- echo
- echo " To mount smb shares, type something like this. You will need kernel SMB support first:"
- echo " % mount -t smbfs -o username=drobbins,password=foo,ip=192.168.1.1 //mybox/drobbins /mnt/foo"
- echo " If you wish to allow normal users to mount smb shares, type the following as root:"
- echo " % chmod u+s /usr/bin/smbmnt"
- echo " #"
-}
diff --git a/net-fs/samba/samba-2.2.1a-r6.ebuild b/net-fs/samba/samba-2.2.1a-r6.ebuild
deleted file mode 100644
index 02092f4f91f2..000000000000
--- a/net-fs/samba/samba-2.2.1a-r6.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.1a-r6.ebuild,v 1.4 2001/09/09 09:32:13 woodchip Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Samba :)"
-SRC_URI="http://us1.samba.org/samba/ftp/${P}.tar.gz"
-HOMEPAGE="http://www.samba.org"
-
-DEPEND="virtual/glibc sys-devel/autoconf
- cups? ( net-print/cups )
- pam? ( >=sys-libs/pam-0.72 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-
-RDEPEND="virtual/glibc cups? ( net-print/cups )"
-# PAM support can cause lots of problems. We want the admin of the box to
-# do this on his own. There is a mailing list thread on samba-devel that's
-# about 40 posts long about this
-# pam? ( >=sys-libs/pam-0.72 )"
-
-
-src_unpack() {
-
- unpack ${A}
- if [ "`use afs`" ]; then
- cd ${S}
- patch -p0 < ${FILESDIR}/patch.221a.10 || die
- fi
-
- if [ ! "`use cups`" ] ; then
- cd ${S}/source
- cp configure.in configure.in.orig
- sed -e "s:AC_CHECK_LIB(cups,httpConnect)::" configure.in.orig > configure.in
- autoconf || die
- fi
-}
-
-
-src_compile() {
-
- local myconf
- use afs && myconf="$myconf --with-afs"
-
- # Again same as above, PAM and Samba not good. Consult samba.org for
- # details. Only enable if you KNOW what you're doing and you really really
- # wanna venture down this path.
- # use pam && myconf="${myconf} --with-pam"
- myconf="${myconf} --without-pam"
-
- # Samba doesn't seem to work well with ssl support but I'll add the check
- # anyway (otherwise it seems to be built with ssl if it finds it). This should
- # be tested. I'll mail gentoo-dev and add a todo in wiki. /Hallski
- # use ssl && myconf="${myconf} --with-ssl"
- myconf="${myconf} --without-ssl"
-
- cd ${S}/source
- # Disabled automout support, because it failed
- ./configure --prefix=/usr --sysconfdir=/etc/smb --localstatedir=/var/log \
- --libdir=/etc/smb --sbindir=/usr/sbin --without-automount --with-utmp \
- --without-sambabook --with-netatalk --with-privatedir=/etc/smb/private \
- --with-smbmount --with-msdfs --with-vfs --with-spinlocks \
- --with-lockdir=/var/run/smb --with-swatdir=/usr/share/swat \
- --with-mandir=/usr/share/man --with-profile ${myconf}
- assert
- make || die
-}
-
-
-src_install() {
-
- cd ${S}/source
- dodir /usr
- dodir /etc/smb
- dodir /usr/share/swat
- dodir /usr/share/doc/${PF}/html/book
- dodir /var/log
- dodir /var/run/smb
-
- make install prefix=${D}/usr BASEDIR=${D}/usr PRIVATEDIR=${D}/etc/smb/private \
- LIBDIR=${D}/etc/smb VARDIR=${D}/var/log SWATDIR=${D}/usr/share/swat \
- LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man || die
-
- # we specified PRIVATEDIR=/etc/smb/private
- rm -rf ${D}/usr/private
- diropts -m 0700
- dodir /etc/smb/private
-
- # move smbmount from /usr/sbin to /sbin, and rename it to mount.smbfs
- # which allows it to work transparently with standard 'mount' command
- dodir /sbin
- mv ${D}/usr/bin/smbmount ${D}/sbin/mount.smbfs
-
- cd ${S}/source/script
- exeinto /usr/sbin
- doexe convert_smbpasswd mknissmbpasswd.sh mknissmbpwdtbl.sh mksmbpasswd.sh smbtar
-
- # docs. samba has some really good ones.
- cd ${S}
- cp -a examples ${D}/usr/doc/${PF}
- insinto /etc/smb ; newins examples/smb.conf.default smb.conf.example
- insinto /usr/share/sgml/docbook/dbsgml ; doins docs/docbook/dbsgml/*
- insinto /usr/share/sgml/docbook/dbsgml/ent ; doins docs/docbook/dbsgml/ent/*
- dodoc COPYING Manifest README Roadmap WHATSNEW.txt
- cd ${S}/docs ; dodoc announce history samba.lsm THANKS
- docinto reg ; dodoc *.reg
- docinto html ; dodoc htmldocs/*.html
- docinto html/book ; dodoc htmldocs/using_samba/*.html
- docinto html/book/gifs ; dodoc htmldocs/using_samba/gifs/*
- docinto html/book/figs ; dodoc htmldocs/using_samba/figs/*
- docinto faq ; dodoc faq/*.txt
- docinto html/faq ; dodoc faq/*.html
- docinto textdocs ; dodoc textdocs/*.txt textdocs/README*
- docinto print ; dodoc textdocs/*.{tex,ps,pdf}
- docinto sgml/faq ; dodoc faq/*.sgml
- docinto sgml/docbook/faq ; dodoc docbook/faq/*.sgml
- docinto sgml/docbook/howto ; dodoc docbook/howto/*.sgml
- docinto sgml/docbook/manpages ; dodoc docbook/manpages/*.sgml
- docinto sgml/docbook/projdoc ; dodoc docbook/projdoc/*.sgml
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/samba.rc6 samba
-}
-
-
-pkg_preinst() {
-
- if [ "$ROOT" = "/" ] && [ -e /etc/init.d/samba ] ; then
- if [ -e /dev/shm/.init.d/started/samba ] ; then
- /etc/init.d/samba stop
- fi
- fi
- return # dont fail
-}
-
-
-pkg_postinst() {
-
- # we touch ${D}/etc/smb/smb.conf so that people installing samba just to mount smb shares
- # don't get annoying warnings all the time.
- if [ ! -e ${ROOT}etc/smb/smb.conf ] ; then
- touch ${ROOT}etc/smb/smb.conf
- fi
-
- echo " #"
- echo " If you had samba running earlier, you'll need to start it again. Also, please note"
- echo " that you must configure /etc/smb/smb.conf before samba (the server) will work properly."
- echo " Mounting smb shares and the smbclient program should work immediately. To accomplish"
- echo " this there is an empty /etc/smb/smb.conf file installed."
- echo
- echo " To mount smb shares, type something like this. You will need kernel SMB support first:"
- echo " % mount -t smbfs -o username=drobbins,password=foo,ip=192.168.1.1 //mybox/drobbins /mnt/foo"
- echo " If you wish to allow normal users to mount smb shares, type the following as root:"
- echo " % chmod u+s /usr/bin/smbmnt"
- echo " #"
-}
diff --git a/net-fs/samba/samba-2.2.2-r6.ebuild b/net-fs/samba/samba-2.2.2-r6.ebuild
new file mode 100644
index 000000000000..30ba7a2581dd
--- /dev/null
+++ b/net-fs/samba/samba-2.2.2-r6.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.2-r6.ebuild,v 1.1 2001/10/17 06:02:52 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Samba :)"
+SRC_URI="http://us1.samba.org/samba/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.samba.org"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ cups? ( net-print/cups )
+ pam? ( >=sys-libs/pam-0.72 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="virtual/glibc
+ cups? ( net-print/cups )
+ pam? ( >=sys-libs/pam-0.72 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`use afs`" ] ; then
+ cd ${S}
+ patch -p0 < ${FILESDIR}/patch.221a.10 || die
+ fi
+
+ if [ ! "`use cups`" ] ; then
+ cd ${S}/source
+ cp configure.in configure.in.orig
+ sed -e "s:AC_CHECK_LIB(cups,httpConnect)::" configure.in.orig > configure.in
+ autoconf || die
+ fi
+}
+
+src_compile() {
+
+ local myconf
+ use afs && myconf="${myconf} --with-afs"
+
+ # PAM support can cause lots of problems. There is a mailing list thread on
+ # samba-devel that's about 40 posts long about this
+ myconf="${myconf} --without-pam"
+
+ # Samba doesn't seem to work well with ssl support
+ myconf="${myconf} --without-ssl"
+
+ cd ${S}/source
+ # Disabled automout support, because it failed
+ ./configure --prefix=/usr --sysconfdir=/etc/smb --localstatedir=/var/log \
+ --libdir=/etc/smb --sbindir=/usr/sbin --without-automount --with-utmp \
+ --without-sambabook --with-netatalk --with-privatedir=/etc/smb/private \
+ --with-smbmount --with-msdfs --with-vfs --with-spinlocks \
+ --with-lockdir=/var/run/smb --with-swatdir=/usr/share/swat \
+ --with-mandir=/usr/share/man --with-profile ${myconf}
+ assert "bad configure"
+
+ make || die "compile problem"
+}
+
+
+src_install() {
+
+ cd ${S}/source
+ dodir /sbin
+ dodir /usr
+ dodir /etc/smb
+ dodir /usr/share/swat
+ dodir /var/log
+ dodir /var/run/smb
+
+ make install prefix=${D}/usr BASEDIR=${D}/usr PRIVATEDIR=${D}/etc/smb/private \
+ LIBDIR=${D}/etc/smb VARDIR=${D}/var/log SWATDIR=${D}/usr/share/swat \
+ LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man
+ assert "install problem"
+
+ # we specified PRIVATEDIR=/etc/smb/private
+ rm -rf ${D}/usr/private
+ diropts -m 0700 ; dodir /etc/smb/private
+
+ # move smbmount from /usr/sbin to /sbin, and rename it to mount.smbfs
+ # which allows it to work transparently with standard 'mount' command
+ mv ${D}/usr/bin/smbmount ${D}/sbin/mount.smbfs
+
+ cd ${S}/source/script
+ exeinto /usr/sbin
+ doexe convert_smbpasswd mknissmbpasswd.sh mknissmbpwdtbl.sh mksmbpasswd.sh smbtar
+
+ # docs -- lots and lots.
+ cd ${S}
+ dodoc COPYING Manifest README Roadmap WHATSNEW.txt
+ docinto full_docs
+ cp -a docs/* ${D}/usr/share/doc/${PF}/full_docs
+ docinto examples
+ cp -a examples/* ${D}/usr/share/doc/${PF}/examples
+ prepalldocs
+
+ insinto /etc/smb ; newins examples/smb.conf.default smb.conf.example
+ exeinto /etc/init.d ; newexe ${FILESDIR}/samba.rc6 samba
+}
+
+pkg_preinst() {
+
+ if [ "$ROOT" = "/" ] && [ -e /etc/init.d/samba ] ; then
+ if [ -e /dev/shm/.init.d/started/samba ] ; then
+ /etc/init.d/samba stop
+ fi
+ fi
+ return # dont fail
+}
+
+pkg_prerm() {
+
+ if [ "$ROOT" = "/" ] && [ -e /etc/init.d/samba ] ; then
+ if [ -e /dev/shm/.init.d/started/samba ] ; then
+ /etc/init.d/samba stop
+ fi
+ fi
+ return # dont fail
+}
+
+pkg_postinst() {
+
+ # we touch ${D}/etc/smb/smb.conf so that people installing samba just to mount smb shares
+ # don't get annoying warnings all the time.
+ if [ ! -e ${ROOT}etc/smb/smb.conf ] ; then
+ touch ${ROOT}etc/smb/smb.conf
+ fi
+
+ echo " #"
+ echo " If you had samba running earlier, you'll need to start it again. Also, please note"
+ echo " that you must configure /etc/smb/smb.conf before samba (the server) will work properly."
+ echo " Mounting smb shares and the smbclient program should work immediately. To accomplish"
+ echo " this there is an empty /etc/smb/smb.conf file installed."
+ echo
+ echo " To mount smb shares, type something like this. You will need kernel SMB support first:"
+ echo " % mount -t smbfs -o username=drobbins,password=foo,ip=192.168.1.1 //mybox/drobbins /mnt/foo"
+ echo " If you wish to allow normal users to mount smb shares, type the following as root:"
+ echo " % chmod u+s /usr/bin/smbmnt"
+ echo " #"
+}
diff --git a/net-fs/samba/samba-2.2.2.ebuild b/net-fs/samba/samba-2.2.2.ebuild
new file mode 100644
index 000000000000..6c1f8da4ed59
--- /dev/null
+++ b/net-fs/samba/samba-2.2.2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.2.ebuild,v 1.1 2001/10/17 06:02:52 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Samba :)"
+SRC_URI="http://us1.samba.org/samba/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.samba.org"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ cups? ( net-print/cups )
+ pam? ( >=sys-libs/pam-0.72 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="virtual/glibc
+ cups? ( net-print/cups )
+ pam? ( >=sys-libs/pam-0.72 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`use afs`" ] ; then
+ cd ${S}
+ patch -p0 < ${FILESDIR}/patch.221a.10 || die
+ fi
+
+ if [ ! "`use cups`" ] ; then
+ cd ${S}/source
+ cp configure.in configure.in.orig
+ sed -e "s:AC_CHECK_LIB(cups,httpConnect)::" configure.in.orig > configure.in
+ autoconf || die
+ fi
+}
+
+src_compile() {
+
+ local myconf
+ use afs && myconf="${myconf} --with-afs"
+
+ # PAM support can cause lots of problems. There is a mailing list thread on
+ # samba-devel that's about 40 posts long about this
+ myconf="${myconf} --without-pam"
+
+ # Samba doesn't seem to work well with ssl support
+ myconf="${myconf} --without-ssl"
+
+ cd ${S}/source
+ # Disabled automout support, because it failed
+ ./configure --prefix=/usr --sysconfdir=/etc/smb --localstatedir=/var/log \
+ --libdir=/etc/smb --sbindir=/usr/sbin --without-automount --with-utmp \
+ --without-sambabook --with-netatalk --with-privatedir=/etc/smb/private \
+ --with-smbmount --with-msdfs --with-vfs --with-spinlocks \
+ --with-lockdir=/var/run/smb --with-swatdir=/usr/share/swat \
+ --with-mandir=/usr/share/man --with-profile ${myconf}
+ assert "bad configure"
+
+ make || die "compile problem"
+}
+
+
+src_install() {
+
+ cd ${S}/source
+ dodir /sbin
+ dodir /usr
+ dodir /etc/smb
+ dodir /usr/share/swat
+ dodir /var/log
+ dodir /var/run/smb
+
+ make install prefix=${D}/usr BASEDIR=${D}/usr PRIVATEDIR=${D}/etc/smb/private \
+ LIBDIR=${D}/etc/smb VARDIR=${D}/var/log SWATDIR=${D}/usr/share/swat \
+ LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man
+ assert "install problem"
+
+ # we specified PRIVATEDIR=/etc/smb/private
+ rm -rf ${D}/usr/private
+ diropts -m 0700 ; dodir /etc/smb/private
+
+ # move smbmount from /usr/sbin to /sbin, and rename it to mount.smbfs
+ # which allows it to work transparently with standard 'mount' command
+ mv ${D}/usr/bin/smbmount ${D}/sbin/mount.smbfs
+
+ cd ${S}/source/script
+ exeinto /usr/sbin
+ doexe convert_smbpasswd mknissmbpasswd.sh mknissmbpwdtbl.sh mksmbpasswd.sh smbtar
+
+ # docs -- lots and lots.
+ cd ${S}
+ dodoc COPYING Manifest README Roadmap WHATSNEW.txt
+ docinto full_docs
+ cp -a docs/* ${D}/usr/share/doc/${PF}/full_docs
+ docinto examples
+ cp -a examples/* ${D}/usr/share/doc/${PF}/examples
+ prepalldocs
+
+ insinto /etc/smb ; newins examples/smb.conf.default smb.conf.example
+ exeinto /etc/rc.d/init.d ; newexe ${FILESDIR}/samba.rc5 samba
+}
+
+pkg_postinst() {
+
+ # we touch ${D}/etc/smb/smb.conf so that people installing samba just to mount smb shares
+ # don't get annoying warnings all the time.
+ if [ ! -e ${ROOT}etc/smb/smb.conf ] ; then
+ touch ${ROOT}etc/smb/smb.conf
+ fi
+
+ echo " #"
+ echo " If you had samba running earlier, you'll need to start it again. Also, please note"
+ echo " that you must configure /etc/smb/smb.conf before samba (the server) will work properly."
+ echo " Mounting smb shares and the smbclient program should work immediately. To accomplish"
+ echo " this there is an empty /etc/smb/smb.conf file installed."
+ echo
+ echo " To mount smb shares, type something like this. You will need kernel SMB support first:"
+ echo " % mount -t smbfs -o username=drobbins,password=foo,ip=192.168.1.1 //mybox/drobbins /mnt/foo"
+ echo " If you wish to allow normal users to mount smb shares, type the following as root:"
+ echo " % chmod u+s /usr/bin/smbmnt"
+ echo " #"
+}