summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-25 19:38:07 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-25 19:38:07 +0000
commitdf958fe6fa5a3c7afe69c05d791640331b4edec4 (patch)
tree2cf6ea847178a7ac35ba7a86266c34e0ed5db137 /net-ftp/lukemftp
parentThe HTML Document Object allows you as a programmer to quickly and easily (diff)
downloadgentoo-2-df958fe6fa5a3c7afe69c05d791640331b4edec4.tar.gz
gentoo-2-df958fe6fa5a3c7afe69c05d791640331b4edec4.tar.bz2
gentoo-2-df958fe6fa5a3c7afe69c05d791640331b4edec4.zip
made a use flag out of ipv6, cleanup of tabs and spaces. ick.
Diffstat (limited to 'net-ftp/lukemftp')
-rw-r--r--net-ftp/lukemftp/files/digest-lukemftp-1.5-r21
-rw-r--r--net-ftp/lukemftp/lukemftp-1.5-r2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-ftp/lukemftp/files/digest-lukemftp-1.5-r2 b/net-ftp/lukemftp/files/digest-lukemftp-1.5-r2
new file mode 100644
index 000000000000..51571a363bc9
--- /dev/null
+++ b/net-ftp/lukemftp/files/digest-lukemftp-1.5-r2
@@ -0,0 +1 @@
+MD5 0cd0fc2e3fca21ca56647b2e1142a01a lukemftp-1.5.tar.gz
diff --git a/net-ftp/lukemftp/lukemftp-1.5-r2.ebuild b/net-ftp/lukemftp/lukemftp-1.5-r2.ebuild
new file mode 100644
index 000000000000..5bf1324d8fcb
--- /dev/null
+++ b/net-ftp/lukemftp/lukemftp-1.5-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2000-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lukemftp/lukemftp-1.5-r2.ebuild,v 1.1 2001/09/25 19:38:07 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="NetBSD FTP client with several advanced features"
+SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Adds a command line option: -s, which produces clean, informative output.
+ # Shows progess status, ETA, transfer speed, no server responses or login messages.
+ # ~woodchip
+ cp src/main.c src/main.orig
+ sed -e "s/Aadefgino:pP:r:RtT:u:vV/Aadefgino:pP:r:RstT:u:vV/" \
+ -e "s/case 't'/case 's':\n\t\t\tverbose = 0;\n\t\t\tprogress = 1;\n\t\t\tbreak;\n\n\t\t&/" \
+ src/main.orig > src/main.c
+}
+
+src_compile() {
+ local myconf
+ use ipv6 || myconf="${myconf} --disable-ipv6"
+
+ ./configure --host=${CHOST} --prefix=/usr --enable-editcomplete ${myconf}
+ assert ; make ; assert "compile problem :("
+}
+
+src_install() {
+ dodoc COPYING ChangeLog README* THANKS NEWS
+ newbin src/ftp lukemftp
+ newman src/ftp.1 lukemftp.1
+
+ if [ ! -e /usr/bin/ftp ]; then
+ cd ${D}/usr/bin
+ ln -s lukemftp ftp
+ fi
+}