summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-06 14:13:08 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-06 14:13:08 +0000
commit0d05feea09c02399be536b70d3f7262087a99352 (patch)
tree8a8a45227be0e26a62704fea70d45142af88904b /net-ftp
parentadded patch that now shows "Gentoo Linux" as OS instead of "Linux" :o) (diff)
downloadgentoo-2-0d05feea09c02399be536b70d3f7262087a99352.tar.gz
gentoo-2-0d05feea09c02399be536b70d3f7262087a99352.tar.bz2
gentoo-2-0d05feea09c02399be536b70d3f7262087a99352.zip
New version
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/gftp/ChangeLog7
-rw-r--r--net-ftp/gftp/files/digest-gftp-2.0.141
-rw-r--r--net-ftp/gftp/gftp-2.0.14.ebuild44
3 files changed, 51 insertions, 1 deletions
diff --git a/net-ftp/gftp/ChangeLog b/net-ftp/gftp/ChangeLog
index c30ce5d16327..351a325ee2ee 100644
--- a/net-ftp/gftp/ChangeLog
+++ b/net-ftp/gftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/gftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/ChangeLog,v 1.9 2002/11/29 19:58:52 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/ChangeLog,v 1.10 2002/12/06 14:13:08 foser Exp $
+
+*gftp-2.0.14 (06 Dec 2002)
+
+ 06 Dec 2002; foser <foser@gentoo.org> gftp-2.0.14.ebuild :
+ New version
*gftp-2.0.14_rc1 (29 Nov 2002)
diff --git a/net-ftp/gftp/files/digest-gftp-2.0.14 b/net-ftp/gftp/files/digest-gftp-2.0.14
new file mode 100644
index 000000000000..10c437204bb3
--- /dev/null
+++ b/net-ftp/gftp/files/digest-gftp-2.0.14
@@ -0,0 +1 @@
+MD5 4e846cb105a552f10b9926942a3421bb gftp-2.0.14.tar.bz2 784470
diff --git a/net-ftp/gftp/gftp-2.0.14.ebuild b/net-ftp/gftp/gftp-2.0.14.ebuild
new file mode 100644
index 000000000000..e031286986af
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/gftp-2.0.14.ebuild,v 1.1 2002/12/06 14:13:08 foser Exp $
+
+IUSE="nls gtk2"
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="virtual/x11
+ gtk2? ( >=x11-libs/gtk+-2.0.0 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ # do not use enable-{gtk20,gtkport} they are not recognized
+ # and will disable building the gtkport alltogether
+ use gtk2 \
+ && myconf="${myconf}" \
+ || myconf="${myconf} --disable-gtk20"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc COPYING ChangeLog AUTHORS README* THANKS \
+ TODO docs/USERS-GUIDE NEWS
+
+}