summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-13 21:15:09 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-13 21:15:09 +0000
commit230abd4ff71199fa63d0686ecc606cab249e703a (patch)
treeacf701bcd14b89d20f7eefd5e3973402e1a704b6 /net-ftp
parentFixed a small typo. (diff)
downloadgentoo-2-230abd4ff71199fa63d0686ecc606cab249e703a.tar.gz
gentoo-2-230abd4ff71199fa63d0686ecc606cab249e703a.tar.bz2
gentoo-2-230abd4ff71199fa63d0686ecc606cab249e703a.zip
Version bump.
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.11
-rw-r--r--net-ftp/lftp/lftp-2.6.1.ebuild48
3 files changed, 56 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index cfbc9d31dc5c..50bc93a246cd 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.6 2002/08/13 21:02:25 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.7 2002/08/13 21:15:09 raker Exp $
+
+*lftp-2.6.1 (13 Aug 2002)
+
+ 13 Aug 2002; Nick Hadaway <raker@gentoo.org>
+ lftp-2.6.1.ebuild, files/digest-lftp-2.6.1 :
+ Version bump.
*lftp-2.6.0 (10 Aug 2002)
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.1 b/net-ftp/lftp/files/digest-lftp-2.6.1
new file mode 100644
index 000000000000..2afac5490656
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.1
@@ -0,0 +1 @@
+MD5 340d2be820f9ca102483c6e788549d61 lftp-2.6.1.tar.bz2 1127246
diff --git a/net-ftp/lftp/lftp-2.6.1.ebuild b/net-ftp/lftp/lftp-2.6.1.ebuild
new file mode 100644
index 000000000000..8ba91967ff91
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.1.ebuild,v 1.1 2002/08/13 21:15:09 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LFTP is a sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}