summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2008-04-17 07:57:57 +0000
committerLuca Longinotti <chtekk@gentoo.org>2008-04-17 07:57:57 +0000
commit7f7bb022a588eb8b8ca70715d5610624f5d357f5 (patch)
tree30d6007d40af83b1987cf9951b5bead070f1d868 /net-ftp
parentAdd/fix net-ftp/proftpd local USE flags. (diff)
downloadgentoo-2-7f7bb022a588eb8b8ca70715d5610624f5d357f5.tar.gz
gentoo-2-7f7bb022a588eb8b8ca70715d5610624f5d357f5.tar.bz2
gentoo-2-7f7bb022a588eb8b8ca70715d5610624f5d357f5.zip
Version bump to ProFTPd 1.3.1.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/ChangeLog16
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.1_rc3-mod_mysql.patch16
-rw-r--r--net-ftp/proftpd/files/proftpd.rc620
-rw-r--r--net-ftp/proftpd/proftpd-1.3.1.ebuild (renamed from net-ftp/proftpd/proftpd-1.3.1_rc3.ebuild)72
4 files changed, 85 insertions, 39 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index ae9124cee7b3..7915cb3c9b56 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-ftp/proftpd
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.166 2007/11/11 15:21:30 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.167 2008/04/17 07:57:56 chtekk Exp $
+
+*proftpd-1.3.1 (17 Apr 2008)
+
+ 17 Apr 2008; Luca Longinotti <chtekk@gentoo.org>
+ -files/proftpd-1.3.1_rc3-mod_mysql.patch, files/proftpd.rc6,
+ -proftpd-1.3.1_rc3.ebuild, +proftpd-1.3.1.ebuild:
+ Version bump to ProFTPd 1.3.1. Added reload command to init-script as well
+ as improved configuration checking, fixes bug #97896. Added new modules:
+ mod_ban, mod_case, mod_deflate, mod_gzipfs, fixes bug #146888 and bug
+ #177991. Added support for LDAP TLS, fixes bug #203598. Updated mod_clamav
+ to 0.7, fixes bug #212601. Cleaned up ebuild and added support for
+ softquotas via Radius.
11 Nov 2007; Raúl Porcel <armin76@gentoo.org> proftpd-1.3.1_rc3.ebuild:
Add ~ia64 wrt #198769
diff --git a/net-ftp/proftpd/files/proftpd-1.3.1_rc3-mod_mysql.patch b/net-ftp/proftpd/files/proftpd-1.3.1_rc3-mod_mysql.patch
deleted file mode 100644
index 000f6934ff72..000000000000
--- a/net-ftp/proftpd/files/proftpd-1.3.1_rc3-mod_mysql.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: contrib/mod_sql_mysql.c
-===================================================================
-RCS file: /cvsroot/proftp/proftpd/contrib/mod_sql_mysql.c,v
-retrieving revision 1.44
-diff -u -r1.44 mod_sql_mysql.c
---- contrib/mod_sql_mysql.c 9 May 2007 17:15:18 -0000 1.44
-+++ contrib/mod_sql_mysql.c 6 Jul 2007 16:48:24 -0000
-@@ -595,7 +595,7 @@
- }
-
- if (!conn_pool) {
-- pr_log_pri(PR_LOG_WARNING, "warning: the mod_sql_mysql module has not been
-+ pr_log_pri(PR_LOG_WARNING, "warning: the mod_sql_mysql module has not been "
- "properly intialized. Please make sure your --with-modules configure "
- "option lists mod_sql *before* mod_sql_mysql, and recompile.");
-
diff --git a/net-ftp/proftpd/files/proftpd.rc6 b/net-ftp/proftpd/files/proftpd.rc6
index 47b2ef651776..c3c9fb03fbba 100644
--- a/net-ftp/proftpd/files/proftpd.rc6
+++ b/net-ftp/proftpd/files/proftpd.rc6
@@ -1,7 +1,9 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/files/proftpd.rc6,v 1.11 2006/09/23 19:07:05 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/files/proftpd.rc6,v 1.12 2008/04/17 07:57:57 chtekk Exp $
+
+opts="${opts} reload"
depend() {
need net
@@ -14,6 +16,9 @@ checkconfig() {
eerror "There is a sample file in /etc/proftpd."
return 1
fi
+ ebegin "Checking proftpd configuration"
+ /usr/sbin/proftpd -t -c /etc/proftpd/proftpd.conf &>/dev/null
+ eend $? "Configuration error: please fix your configuration file (/etc/proftpd/proftpd.conf)."
}
start() {
@@ -28,3 +33,14 @@ stop() {
start-stop-daemon --stop --retry 20 --quiet --pidfile /var/run/proftpd.pid
eend $?
}
+
+reload() {
+ if [ ! -f /var/run/proftpd.pid ] ; then
+ eerror "proftpd isn't running!"
+ return 1
+ fi
+ checkconfig || return 1
+ ebegin "Reloading proftpd"
+ kill -HUP `cat /var/run/proftpd.pid` &>/dev/null
+ eend $?
+}
diff --git a/net-ftp/proftpd/proftpd-1.3.1_rc3.ebuild b/net-ftp/proftpd/proftpd-1.3.1.ebuild
index 7246ebfa3c7a..1450ac92021a 100644
--- a/net-ftp/proftpd/proftpd-1.3.1_rc3.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.1.ebuild
@@ -1,39 +1,49 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.1_rc3.ebuild,v 1.3 2007/11/11 15:21:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.1.ebuild,v 1.1 2008/04/17 07:57:56 chtekk Exp $
inherit eutils flag-o-matic toolchain-funcs
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="acl authfile clamav hardened ifsession ipv6 ldap mysql ncurses nls noauthunix opensslcrypt pam postgres radius rewrite selinux shaper sitemisc softquota ssl tcpd vroot xinetd"
+IUSE="acl authfile ban case clamav deflate gzipfs hardened ifsession ipv6 ldap mysql ncurses nls noauthunix opensslcrypt pam postgres radius rewrite selinux shaper sitemisc softquota ssl tcpd vroot xinetd"
+CASE_VER="0.3"
+CLAMAV_VER="0.7"
+DEFLATE_VER="0.3"
+GZIPFS_VER="0.9rc4"
SHAPER_VER="0.6.3"
VROOT_VER="0.7.2"
DESCRIPTION="An advanced and very configurable FTP server."
+
SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P/_/}.tar.bz2
- clamav? ( http://www.uglyboxindustries.com/mod_clamav_new.c http://www.uglyboxindustries.com/mod_clamav_new.html )
+ case? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-case-${CASE_VER}.tar.gz )
+ clamav? ( http://www.thrallingpenguin.com/resources/mod_clamav-${CLAMAV_VER}.tar.gz )
+ deflate? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-deflate-${DEFLATE_VER}.tar.gz )
+ gzipfs? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-gzipfs-${GZIPFS_VER}.tar.gz )
shaper? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-shaper-${SHAPER_VER}.tar.gz )
vroot? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-vroot-${VROOT_VER}.tar.gz )"
+
HOMEPAGE="http://www.proftpd.org/
http://www.castaglia.org/proftpd/
- http://www.uglyboxindustries.com/open-source.php"
+ http://www.thrallingpenguin.com/resources/mod_clamav.htm"
SLOT="0"
LICENSE="GPL-2"
DEPEND="acl? ( sys-apps/acl sys-apps/attr )
clamav? ( app-antivirus/clamav )
+ gzipfs? ( sys-libs/zlib )
ldap? ( >=net-nds/openldap-1.2.11 )
mysql? ( virtual/mysql )
ncurses? ( sys-libs/ncurses )
opensslcrypt? ( >=dev-libs/openssl-0.9.6f )
pam? ( virtual/pam )
- postgres? ( >=dev-db/postgresql-7.3 )
+ postgres? ( virtual/postgresql-base )
ssl? ( >=dev-libs/openssl-0.9.6f )
tcpd? ( >=sys-apps/tcp-wrappers-7.6-r3 )
- xinetd? ( sys-apps/xinetd )"
+ xinetd? ( virtual/inetd )"
RDEPEND="${DEPEND}
net-ftp/ftpbase
@@ -56,14 +66,34 @@ src_unpack() {
# Fix stripping of files
sed -e "s| @INSTALL_STRIP@||g" -i Make*
- if use shaper ; then
- unpack ${PN}-mod-shaper-${SHAPER_VER}.tar.gz
- cp -f mod_shaper/mod_shaper.c contrib/
+ if use case ; then
+ unpack ${PN}-mod-case-${CASE_VER}.tar.gz
+ cp -f mod_case/mod_case.c contrib/
+ cp -f mod_case/mod_case.html doc/
fi
if use clamav ; then
- cp -f "${DISTDIR}/mod_clamav_new.c" contrib/mod_clamav.c
- cp -f "${DISTDIR}/mod_clamav_new.html" doc/mod_clamav.html
+ unpack mod_clamav-${CLAMAV_VER}.tar.gz
+ cp -f mod_clamav-${CLAMAV_VER}/mod_clamav.* contrib/
+ epatch mod_clamav-${CLAMAV_VER}/${PN}.patch
+ fi
+
+ if use deflate ; then
+ unpack ${PN}-mod-deflate-${DEFLATE_VER}.tar.gz
+ cp -f mod_deflate/mod_deflate.c contrib/
+ cp -f mod_deflate/mod_deflate.html doc/
+ fi
+
+ if use gzipfs ; then
+ unpack ${PN}-mod-gzipfs-${GZIPFS_VER}.tar.gz
+ cp -f mod_gzipfs/mod_gzipfs.c contrib/
+ cp -f mod_gzipfs/mod_gzipfs.html doc/
+ fi
+
+ if use shaper ; then
+ unpack ${PN}-mod-shaper-${SHAPER_VER}.tar.gz
+ cp -f mod_shaper/mod_shaper.c contrib/
+ cp -f mod_shaper/mod_shaper.html doc/
fi
if use vroot ; then
@@ -71,8 +101,6 @@ src_unpack() {
cp -f mod_vroot/mod_vroot.c contrib/
cp -f mod_vroot/mod_vroot.html doc/
fi
-
- epatch ${FILESDIR}/${P}-mod_mysql.patch
}
src_compile() {
@@ -81,7 +109,11 @@ src_compile() {
modules="mod_ratio:mod_readme"
use acl && modules="${modules}:mod_facl"
+ use ban && modules="${modules}:mod_ban"
+ use case && modules="${modules}:mod_case"
use clamav && modules="${modules}:mod_clamav"
+ use deflate && modules="${modules}:mod_deflate"
+ use gzipfs && modules="${modules}:mod_gzipfs"
use pam && modules="${modules}:mod_auth_pam"
use radius && modules="${modules}:mod_radius"
use rewrite && modules="${modules}:mod_rewrite"
@@ -97,11 +129,14 @@ src_compile() {
if use ldap ; then
modules="${modules}:mod_ldap"
append-ldflags "-lresolv"
+ if use ssl ; then
+ CFLAGS="${CFLAGS} -DUSE_LDAP_TLS"
+ fi
fi
if use opensslcrypt ; then
- append-ldflags "-lcrypto"
myconf="${myconf} --enable-openssl --with-includes=/usr/include/openssl"
+ append-ldflags "-lcrypto"
CFLAGS="${CFLAGS} -DHAVE_OPENSSL"
fi
@@ -130,6 +165,9 @@ src_compile() {
if use mysql || use postgres ; then
modules="${modules}:mod_quotatab_sql"
fi
+ if use radius ; then
+ modules="${modules}:mod_quotatab_radius"
+ fi
if use ldap ; then
modules="${modules}:mod_quotatab_file:mod_quotatab_ldap"
else
@@ -169,8 +207,6 @@ src_compile() {
}
src_install() {
- # Note rundir needs to be specified to avoid sandbox violation
- # on initial install. See Make.rules
emake DESTDIR="${D}" install || die "emake install failed"
keepdir /var/run/proftpd
@@ -181,8 +217,6 @@ src_install() {
dohtml doc/*.html
dohtml doc/howto/*.html
- use shaper && dohtml mod_shaper/mod_shaper.html
-
docinto rfc
dodoc doc/rfc/*.txt