summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-28 17:01:06 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-28 17:01:06 +0000
commitb3458c1d0e060e06cde4296f93f79e9d6f3a54e1 (patch)
tree0d9439317f97f9a7a60c2df6627b3cdcb1b5142d /net-ftp
parentVersion bump. (diff)
downloadgentoo-2-b3458c1d0e060e06cde4296f93f79e9d6f3a54e1.tar.gz
gentoo-2-b3458c1d0e060e06cde4296f93f79e9d6f3a54e1.tar.bz2
gentoo-2-b3458c1d0e060e06cde4296f93f79e9d6f3a54e1.zip
Fixed gtk+ dep and some cleanup
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pureadmin/ChangeLog8
-rw-r--r--net-ftp/pureadmin/pureadmin-0.2.2.ebuild24
-rw-r--r--net-ftp/pureadmin/pureadmin-0.3.ebuild24
-rw-r--r--net-ftp/pureadmin/pureadmin-0.4.ebuild24
4 files changed, 36 insertions, 44 deletions
diff --git a/net-ftp/pureadmin/ChangeLog b/net-ftp/pureadmin/ChangeLog
index f6d4314fb1d4..afcdc9fc861f 100644
--- a/net-ftp/pureadmin/ChangeLog
+++ b/net-ftp/pureadmin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/pureadmin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.15 2010/06/02 06:31:03 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.16 2011/03/28 17:01:06 angelos Exp $
+
+ 28 Mar 2011; Christoph Mende <angelos@gentoo.org> pureadmin-0.2.2.ebuild,
+ pureadmin-0.3.ebuild, pureadmin-0.4.ebuild:
+ Fixed gtk+ dep and some cleanup
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove chtekk from metadata.xml (#103720)
diff --git a/net-ftp/pureadmin/pureadmin-0.2.2.ebuild b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
index 2cb6f7840206..11d98078ac8e 100644
--- a/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
+++ b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
@@ -1,36 +1,32 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.2.2.ebuild,v 1.5 2008/04/21 09:56:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.2.2.ebuild,v 1.6 2011/03/28 17:01:06 angelos Exp $
+EAPI=3
inherit eutils
-KEYWORDS="amd64 ~ppc x86"
-
DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
HOMEPAGE="http://purify.sourceforge.net/"
SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
+KEYWORDS="amd64 ~ppc x86"
IUSE="debug doc"
-RDEPEND=">=gnome-base/libglade-2.0
+RDEPEND="gnome-base/libglade:2.0
sys-libs/zlib
virtual/fam
- >=x11-libs/gtk+-2.0"
-
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile() {
+src_configure() {
local myconf=""
use debug && myconf="${myconf} --enable-debug"
- econf ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ econf ${myconf}
}
src_install() {
@@ -49,8 +45,8 @@ pkg_postinst() {
ewarn "PureAdmin is at a beta-stage right now and it may break your"
ewarn "configuration. DO NOT use it for safety critical system"
ewarn "or production use!"
- elog
+ echo
elog "You need root-privileges to be able to use PureAdmin."
elog "This will probably change in the future."
- elog
+ echo
}
diff --git a/net-ftp/pureadmin/pureadmin-0.3.ebuild b/net-ftp/pureadmin/pureadmin-0.3.ebuild
index bd017b52aaf5..ad510bf4c811 100644
--- a/net-ftp/pureadmin/pureadmin-0.3.ebuild
+++ b/net-ftp/pureadmin/pureadmin-0.3.ebuild
@@ -1,36 +1,32 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.3.ebuild,v 1.4 2008/04/21 09:56:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.3.ebuild,v 1.5 2011/03/28 17:01:06 angelos Exp $
+EAPI=3
inherit eutils
-KEYWORDS="~amd64 ~ppc ~x86"
-
DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
HOMEPAGE="http://purify.sourceforge.net/"
SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug doc"
-RDEPEND=">=gnome-base/libglade-2.0
+RDEPEND="gnome-base/libglade:2.0
sys-libs/zlib
virtual/fam
- >=x11-libs/gtk+-2.0"
-
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile() {
+src_configure() {
local myconf=""
use debug && myconf="${myconf} --enable-debug"
- econf ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ econf ${myconf}
}
src_install() {
@@ -49,8 +45,8 @@ pkg_postinst() {
ewarn "PureAdmin is at a beta-stage right now and it may break your"
ewarn "configuration. DO NOT use it for safety critical system"
ewarn "or production use!"
- elog
+ echo
elog "You need root-privileges to be able to use PureAdmin."
elog "This will probably change in the future."
- elog
+ echo
}
diff --git a/net-ftp/pureadmin/pureadmin-0.4.ebuild b/net-ftp/pureadmin/pureadmin-0.4.ebuild
index 2b61027df1be..2cd318bf4a7b 100644
--- a/net-ftp/pureadmin/pureadmin-0.4.ebuild
+++ b/net-ftp/pureadmin/pureadmin-0.4.ebuild
@@ -1,36 +1,32 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.4.ebuild,v 1.1 2008/04/21 09:56:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.4.ebuild,v 1.2 2011/03/28 17:01:06 angelos Exp $
+EAPI=3
inherit eutils
-KEYWORDS="~amd64 ~ppc ~x86"
-
DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
HOMEPAGE="http://purify.sourceforge.net/"
SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug doc"
-RDEPEND=">=gnome-base/libglade-2.0
+RDEPEND="gnome-base/libglade:2.0
sys-libs/zlib
virtual/fam
- >=x11-libs/gtk+-2.0"
-
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile() {
+src_configure() {
local myconf=""
use debug && myconf="${myconf} --enable-debug"
- econf ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ econf ${myconf}
}
src_install() {
@@ -49,8 +45,8 @@ pkg_postinst() {
ewarn "PureAdmin is at a beta-stage right now and it may break your"
ewarn "configuration. DO NOT use it for safety critical system"
ewarn "or production use!"
- elog
+ echo
elog "You need root-privileges to be able to use PureAdmin."
elog "This will probably change in the future."
- elog
+ echo
}