summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-08-13 14:45:08 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-08-13 14:45:08 +0000
commitcb0b6f9d1877056d1e435732bc36ea499cdf89c1 (patch)
treea7f3c16894c6fc35e947ec15636a4c65788cc2ba /net-im/licq
parentnew package sys-apps/fakeroot (diff)
downloadgentoo-2-cb0b6f9d1877056d1e435732bc36ea499cdf89c1.tar.gz
gentoo-2-cb0b6f9d1877056d1e435732bc36ea499cdf89c1.tar.bz2
gentoo-2-cb0b6f9d1877056d1e435732bc36ea499cdf89c1.zip
- Ebuild for version 1.2.0a, closes #5661.
- Fixed indentation all over ebuild. - Removed redundant src_unpack(). - Other clean ups.
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog19
-rw-r--r--net-im/licq/files/digest-licq-1.2.0a1
-rw-r--r--net-im/licq/licq-1.2.0a.ebuild63
3 files changed, 70 insertions, 13 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 67f13203e506..c570d182d78f 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.3 2002/07/27 13:54:45 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.4 2002/08/13 14:45:08 agenkin Exp $
- 28 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+*licq-1.2.0a (13 Aug 2002)
- Use correct slot '2'.
+ 13 Aug 2002; Arcady Genkin <agenkin@thpoon.com> licq-1.2.0a.ebuild :
+
+ Update to version 1.2.0a. Thanks to Matt Rinsch <gfunkmonk@mochamail.com>
+ for the update.
*licq-1.0.4-r2 (4 Apr 2002)
@@ -12,13 +15,3 @@
Added patch from Paul de Vrieze to fix the problem that
kdeconf resets the cwd (to ${S}?).
-
-*licq-1.0.4-r1 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/net-im/licq/files/digest-licq-1.2.0a b/net-im/licq/files/digest-licq-1.2.0a
new file mode 100644
index 000000000000..7b91e3648cbf
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.0a
@@ -0,0 +1 @@
+MD5 3f977d83b36b26d1bc716be3e3336315 licq-1.2.0a.tar.bz2 1741476
diff --git a/net-im/licq/licq-1.2.0a.ebuild b/net-im/licq/licq-1.2.0a.ebuild
new file mode 100644
index 000000000000..88171e982545
--- /dev/null
+++ b/net-im/licq/licq-1.2.0a.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.0a.ebuild,v 1.1 2002/08/13 14:45:08 agenkin Exp $
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="x86"
+S=${WORKDIR}/${P}
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui-1.2.0
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui-1.2.0
+ make DESTDIR=${D} install || die
+ fi
+
+}