summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-29 07:44:47 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-29 07:44:47 +0000
commitfee01586a25d7cf57d500cce5e8d46215d527bae (patch)
treeae687d9e5731427488d1f74244a3adf07206f040 /net-im/psi
parentinitial import, closes bug# 9868 (diff)
downloadgentoo-2-fee01586a25d7cf57d500cce5e8d46215d527bae.tar.gz
gentoo-2-fee01586a25d7cf57d500cce5e8d46215d527bae.tar.bz2
gentoo-2-fee01586a25d7cf57d500cce5e8d46215d527bae.zip
Fix for #9663
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/ChangeLog13
-rw-r--r--net-im/psi/psi-0.8.6.ebuild20
2 files changed, 17 insertions, 16 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index c5d6cc0187e8..a2d8ac5cd321 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,33 +1,32 @@
# ChangeLog for net-im/psi
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.5 2002/09/14 17:43:30 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.6 2002/10/29 07:44:47 vapier Exp $
- 25 Aug 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+*psi-0.8.6 (9 July 2002)
+ 28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added pkg_setup fix for #9663
+
+ 25 Aug 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
Change qt dep to >= so that qt-5, the cvs ebuilds, can satisfy it. It will be ok
until qt 4.x is released; we should have slot-dependencies working before then.
-*psi-0.8.6 (9 July 2002)
-
14 Sep 2002; Owen Stampflee <owen@gentoo.org> :
Added PPC to KEYWORDS.
9 July 2002; Bart Verwilst <verwilst@gentoo.org> ChangeLog :
-
Emoticons, finally! Proxy support, .... Long Changelog on the site,
check it out..
*psi-0.8.5 (1 April 2002)
1 April 2002; Bart Verwilst <verwilst@gentoo.org> ChangeLog :
-
0.8.5 works, had to change the sed command from 0.8.4... New stuff are
profiles, new iconsets, sounds, and some bugfixes..
*psi-0.8.4 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/net-im/psi/psi-0.8.6.ebuild b/net-im/psi/psi-0.8.6.ebuild
index 931d2b78423a..a688f641f727 100644
--- a/net-im/psi/psi-0.8.6.ebuild
+++ b/net-im/psi/psi-0.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.8.6.ebuild,v 1.6 2002/10/05 05:39:21 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.8.6.ebuild,v 1.7 2002/10/29 07:44:47 vapier Exp $
IUSE="ssl"
@@ -18,8 +18,13 @@ KEYWORDS="x86 ppc"
DEPEND=">=x11-libs/qt-3
ssl? ( >=dev-libs/openssl-0.9.6c )"
+pkg_setup() {
+ # xfree should not install these, remove until the fixed
+ # xfree is in main use.
+ rm -f /usr/X11R6/include/{zconf.h,zlib.h}
+}
+
src_compile() {
-
export QTDIR="${QTDIR}"
export QMAKESPEC="linux-g++"
cd ${S}/src
@@ -36,14 +41,12 @@ src_compile() {
}
src_install() {
-
# We do not use the ./install method, we do it manually ##
-
+
export PSIDIR=/usr/share/psi
-
- mkdir -p ${D}/usr/bin
- mkdir -p ${D}/usr/share/psi
- #mkdir -p ${D}/usr/share/psi/iconsets
+
+ dodir /usr/bin
+ dodir /usr/share/psi/iconsets
cd ${S}
cp -rf ./image ${D}/usr/share/psi/
@@ -60,5 +63,4 @@ src_install() {
cp README ${D}/usr/share/psi/
cp COPYING ${D}/usr/share/psi/
ln -sf /usr/share/psi/psi ${D}/usr/bin/psi
-
}