summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2009-01-19 19:59:45 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2009-01-19 19:59:45 +0000
commit089f840796e7f40bc30684c4f975a82d08a209e9 (patch)
tree01b1ada3f976e13485c7dc96414b79ea757fdb99 /net-im/pyicq-t
parentAdded a patch to avoid linking to G4zlib, closing bug #255017, thanks to Benj... (diff)
downloadgentoo-2-089f840796e7f40bc30684c4f975a82d08a209e9.tar.gz
gentoo-2-089f840796e7f40bc30684c4f975a82d08a209e9.tar.bz2
gentoo-2-089f840796e7f40bc30684c4f975a82d08a209e9.zip
Bump pyicq-t to 8.1.1.1 fixing bugs #251916 and #255483.
(Portage version: 2.1.6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'net-im/pyicq-t')
-rw-r--r--net-im/pyicq-t/ChangeLog11
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild71
2 files changed, 80 insertions, 2 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index 3614398313c7..a835c844c7fc 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pyicq-t
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.9 2008/12/19 18:00:44 griffon26 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.10 2009/01/19 19:59:45 griffon26 Exp $
+
+*pyicq-t-0.8.1.1 (19 Jan 2009)
+
+ 19 Jan 2009; Maurice van der Pot <griffon26@gentoo.org>
+ +pyicq-t-0.8.1.1.ebuild:
+ Version bump as requested by lindevel@gmx.net in bug #255483.
+ Also fixes bug #251916 reported by jamatik <jamatik@wheep.de>.
*pyicq-t-0.8.1 (19 Dec 2008)
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild
new file mode 100644
index 000000000000..520cad9130b3
--- /dev/null
+++ b/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild,v 1.1 2009/01/19 19:59:45 griffon26 Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils multilib python
+
+MY_P="${P/pyicq-t/pyicqt}"
+
+DESCRIPTION="Python based jabber transport for ICQ"
+HOMEPAGE="http://code.google.com/p/pyicqt/"
+SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webinterface"
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ >=dev-python/twisted-2.2.0
+ >=dev-python/twisted-words-0.1.0
+ >=dev-python/twisted-web-0.5.0
+ webinterface? ( >=dev-python/nevow-0.4.1 )
+ >=dev-python/imaging-1.1"
+
+src_install() {
+ local inspath
+
+ python_version
+ inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ insinto ${inspath}
+ doins -r data src tools
+ newins PyICQt.py ${PN}.py
+
+ insinto /etc/jabber
+ newins config_example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ dosed \
+ "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
+ /etc/jabber/${PN}.xml
+ dosed \
+ "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ /etc/jabber/${PN}.xml
+
+ newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
+ dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+
+ elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
+ elog "Please edit it and the configuration of your Jabber server to match."
+
+ ewarn "If you are storing user accounts in MySQL and are upgrading from a "
+ ewarn "version older than 0.8.1, then you will need to run the following "
+ ewarn "command to create some new tables:"
+ ewarn " mysql -u user_name -p pyicqt < /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tools/db-setup.mysql"
+
+ elog "These instructions along with a list of new config variables are "
+ elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
+}