summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-07-03 07:25:59 +0000
committerPeter Volkov <pva@gentoo.org>2008-07-03 07:25:59 +0000
commitd0518d1d68475e24be5767c77dc02a931bc9f679 (patch)
treeab7a8a5b40878fd8e8412895bc0a1ee9b9a06723 /net-im/sim
parentReally fix bug #230443. (diff)
downloadgentoo-2-d0518d1d68475e24be5767c77dc02a931bc9f679.tar.gz
gentoo-2-d0518d1d68475e24be5767c77dc02a931bc9f679.tar.bz2
gentoo-2-d0518d1d68475e24be5767c77dc02a931bc9f679.zip
Fixed "ICQ client outdated" problem.
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-ovz005 i686)
Diffstat (limited to 'net-im/sim')
-rw-r--r--net-im/sim/ChangeLog8
-rw-r--r--net-im/sim/files/sim-0.9.4.3-old-protocol.patch36
-rw-r--r--net-im/sim/sim-0.9.4.3-r3.ebuild102
3 files changed, 145 insertions, 1 deletions
diff --git a/net-im/sim/ChangeLog b/net-im/sim/ChangeLog
index 8ab43cbc89e1..7a993b0f2bb9 100644
--- a/net-im/sim/ChangeLog
+++ b/net-im/sim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/sim
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.89 2008/05/30 07:33:53 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.90 2008/07/03 07:25:58 pva Exp $
+
+*sim-0.9.4.3-r3 (03 Jul 2008)
+
+ 03 Jul 2008; Peter Volkov <pva@gentoo.org>
+ +files/sim-0.9.4.3-old-protocol.patch, +sim-0.9.4.3-r3.ebuild:
+ Fixed "ICQ client outdated" problem.
*sim-0.9.4.3-r2 (30 May 2008)
diff --git a/net-im/sim/files/sim-0.9.4.3-old-protocol.patch b/net-im/sim/files/sim-0.9.4.3-old-protocol.patch
new file mode 100644
index 000000000000..4309be1bca8e
--- /dev/null
+++ b/net-im/sim/files/sim-0.9.4.3-old-protocol.patch
@@ -0,0 +1,36 @@
+r2233 | noragen | 2008-07-02 02:14:02 +0400 (Срд, 02 Июл 2008) | 2 lines
+
+* Fix/Application of bug/patch #14117
+Big thanx to sf_studio and reklov!
+
+Backported by pva@gentoo.org.
+
+--- plugins/icq/icqlogin.cpp 2008-07-02 16:30:39 +0000
++++ plugins/icq/icqlogin.cpp 2008-07-02 16:34:41 +0000
+@@ -110,9 +110,9 @@
+ m_socket->writeBuffer.tlv(0x0025, md.c_str(), md.length());
+ if (data.owner.Uin.value){
+ m_socket->writeBuffer.tlv(0x0003, "ICQ Inc. - Product of ICQ (TM).2003b.5.56.1.3916.85");
+- m_socket->writeBuffer.tlv(0x0016, 0x010A);
+- m_socket->writeBuffer.tlv(0x0017, 0x0002);
+- m_socket->writeBuffer.tlv(0x0018, 0x0038);
++ m_socket->writeBuffer.tlv(0x0016, 0x014A); // ID Number
++ m_socket->writeBuffer.tlv(0x0017, 0x0024); // major
++ m_socket->writeBuffer.tlv(0x0018, 0x003D); // minor
+ m_socket->writeBuffer.tlv(0x0019, 0x0001);
+ m_socket->writeBuffer.tlv(0x001A, 0x0F4C);
+ m_socket->writeBuffer.tlv(0x0014, 0x00000055L);
+@@ -205,9 +205,9 @@
+ m_socket->writeBuffer.tlv(0x0001, uin);
+ m_socket->writeBuffer.tlv(0x0002, pswd.c_str(), pswd.length());
+ m_socket->writeBuffer.tlv(0x0003, "ICQ Inc. - Product of ICQ (TM).2003b.5.56.1.3916.85");
+- m_socket->writeBuffer.tlv(0x0016, 0x010A);
+- m_socket->writeBuffer.tlv(0x0017, 0x0002);
+- m_socket->writeBuffer.tlv(0x0018, 0x0038);
++ m_socket->writeBuffer.tlv(0x0016, 0x014A); // ID Number
++ m_socket->writeBuffer.tlv(0x0017, 0x0024); // major
++ m_socket->writeBuffer.tlv(0x0018, 0x003D); // minor
+ m_socket->writeBuffer.tlv(0x0019, 0x0001);
+ m_socket->writeBuffer.tlv(0x001A, 0x0F4C);
+ m_socket->writeBuffer.tlv(0x0014, 0x00000055L);
+
diff --git a/net-im/sim/sim-0.9.4.3-r3.ebuild b/net-im/sim/sim-0.9.4.3-r3.ebuild
new file mode 100644
index 000000000000..ff893eb6f517
--- /dev/null
+++ b/net-im/sim/sim-0.9.4.3-r3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4.3-r3.ebuild,v 1.1 2008/07/03 07:25:58 pva Exp $
+
+inherit kde-functions eutils flag-o-matic
+
+DESCRIPTION="Simple Instant Messenger (with KDE support). ICQ/AIM/Jabber/MSN/Yahoo."
+HOMEPAGE="http://sim-im.org/"
+SRC_URI="mirror://berlios/sim-im/${P}.tar.bz2
+ http://dev.gentoo.org/~pva/${P}-r1919_1924.patch.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug kde spell ssl"
+
+RESTRICT="fetch"
+
+# kdebase-data provides the icon "licq.png"
+RDEPEND="kde? ( =kde-base/kdelibs-3.5*
+ || ( =kde-base/kdebase-data-3.5* =kde-base/kdebase-3.5* ) )
+ !kde? ( $(qt_min_version 3)
+ spell? ( app-text/aspell ) )
+ ssl? ( dev-libs/openssl )
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/zlib
+ x11-libs/libXScrnSaver"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-arch/zip
+ x11-proto/scrnsaverproto"
+
+pkg_nofetch() {
+ einfo "${CATEGORY}/${P} contains icons and sounds with unclear licensing and thus"
+ einfo "you have to download and it put into '${DISTDIR}' by yourself."
+ einfo "Download location:"
+ echo
+ einfo "${SRC_URI}"
+ echo
+ einfo "See http://archives.gentoo.org/gentoo-dev/msg_144003.xml for further"
+ einfo "information."
+}
+
+pkg_setup() {
+ if use kde; then
+ if use spell; then
+ if ! built_with_use "=kde-base/kdelibs-3.5*" spell; then
+ ewarn "kde-base/kdelibs were merged without spell in USE."
+ ewarn "Thus spelling will not work in sim. Please, either"
+ ewarn "reemerge kde-base/kdelibs with spell in USE or emerge"
+ ewarn 'sim with USE="-spell" to avoid this message.'
+ ebeep
+ fi
+ else
+ if built_with_use "=kde-base/kdelibs-3.5*" spell; then
+ ewarn 'kde-base/kdelibs were merged with spell in USE.'
+ ewarn 'Thus spelling will work in sim. Please, either'
+ ewarn 'reemerge kde-base/kdelibs without spell in USE or emerge'
+ ewarn 'sim with USE="spell" to avoid this message.'
+ ebeep
+ fi
+ fi
+ if ! built_with_use "=kde-base/kdelibs-3.5*" arts; then
+ myconf="--without-arts"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-double-message-fix.patch
+ epatch "${FILESDIR}"/${P}-sslv23.patch
+ epatch ../${P}-r1919_1924.patch
+ epatch "${FILESDIR}"/${P}-old-protocol.patch
+ if use kde; then
+ set-kdedir 3
+ fi
+}
+
+src_compile() {
+ filter-flags -fstack-protector -fstack-protector-all
+
+ # Workaround for bug #119906
+ append-flags -fno-stack-protector
+
+ use kde || use spell || export DO_NOT_COMPILE="$DO_NOT_COMPILE plugins/spell"
+
+ econf ${myconf} $(use_enable kde) \
+ $(use_with ssl) \
+ $(use_enable debug) || die "econf failed"
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+ dodoc TODO README AUTHORS.sim jisp-resources.txt ChangeLog
+}