summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-10-01 16:15:36 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-10-01 16:15:36 +0000
commit04629e0ddbf5c1b72a1bc57f929d01639ac203e9 (patch)
treee4f03e73b5180fb1e28004a6c9240f01d64c2629 /net-im
parentEncryption and gaim now properly detect nss/nspr (diff)
downloadgentoo-2-04629e0ddbf5c1b72a1bc57f929d01639ac203e9.tar.gz
gentoo-2-04629e0ddbf5c1b72a1bc57f929d01639ac203e9.tar.bz2
gentoo-2-04629e0ddbf5c1b72a1bc57f929d01639ac203e9.zip
Encryption and gaim now properly detect nss/nspr
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.70-r22
-rw-r--r--net-im/gaim/gaim-0.70-r2.ebuild81
4 files changed, 91 insertions, 3 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 3d672da9d236..d875e189e537 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.79 2003/09/30 17:52:25 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.80 2003/10/01 16:15:34 lostlogic Exp $
+
+*gaim-0.70-r2 (01 Oct 2003)
+
+ 01 Oct 2003; Brandon Low <lostlogic@gentoo.org> gaim-0.70-r2.ebuild:
+ Fix nss/nspr stuffxor
*gaim-0.70-r1 (30 Sep 2003)
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 3e2c387d40c9..1c3f1dd99a4f 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -6,8 +6,8 @@ MD5 d0e86a7e30272d53c1ae434ebf0d2592 gaim-0.69.ebuild 2226
MD5 836e337188a5f0b1fe7e0de396bec8b9 gaim-0.70.ebuild 2338
MD5 a08cec351051cad09f7b16f12adf5a3a gaim-0.68-r2.ebuild 2395
MD5 b2ac9eb41db9100a22760f81282f388b gaim-0.66-r3.ebuild 1968
-MD5 65e528fe798798279d5048c554a5d3bc gaim-0.70-r2.ebuild 2489
-MD5 c2301bcbd7e7c4ad70f4f1544fd60f83 ChangeLog 13575
+MD5 6ab9da84d90e8b9ae2d38a0d65c29516 gaim-0.70-r2.ebuild 2489
+MD5 2b0fe78ec985f85a7e7d58ae29564cb4 ChangeLog 13700
MD5 dc9ef26d3efea7cbe38cbe534cdeaa53 metadata.xml 510
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
MD5 dd643cd5d3960ea86bc0107cb9bdbb50 files/digest-gaim-0.69 135
diff --git a/net-im/gaim/files/digest-gaim-0.70-r2 b/net-im/gaim/files/digest-gaim-0.70-r2
new file mode 100644
index 000000000000..971c5dabe72c
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.70-r2
@@ -0,0 +1,2 @@
+MD5 13ea95aa040ac5a58c3384709e495329 gaim-0.70.tar.bz2 3178790
+MD5 fe928761b0bd11afea3137ec202dc6ef gaim-encryption-2.14.tar.gz 315964
diff --git a/net-im/gaim/gaim-0.70-r2.ebuild b/net-im/gaim/gaim-0.70-r2.ebuild
new file mode 100644
index 000000000000..eeb94e07fea2
--- /dev/null
+++ b/net-im/gaim/gaim-0.70-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.70-r2.ebuild,v 1.1 2003/10/01 16:15:34 lostlogic Exp $
+
+IUSE="nls perl spell nas ssl"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.14
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ dev-libs/nss
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${A} || die
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ local myencconf
+ cd ${S}/plugins/gaim-encryption-${EV}
+
+ myencconf="${myencconf} --with-nspr-includes=/usr/include/nspr"
+ myencconf="${myencconf} --with-nss-includes=/usr/include/nss"
+ econf ${myencconf} || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ fi
+}