summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-02-25 16:13:54 +0000
committerDon Seiler <rizzo@gentoo.org>2004-02-25 16:13:54 +0000
commit2cb61f5f1db300640c016f10dae9b61d721a70e2 (patch)
tree0031b785aa24a6d525b04b3fa65089803a1f438b /net-im
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-2cb61f5f1db300640c016f10dae9b61d721a70e2.tar.gz
gentoo-2-2cb61f5f1db300640c016f10dae9b61d721a70e2.tar.bz2
gentoo-2-2cb61f5f1db300640c016f10dae9b61d721a70e2.zip
Added support for gnome-url-handler if USE=gnome. Thanks to Chris 'wolf31o2' Gianelloni
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog9
-rw-r--r--net-im/gaim/files/digest-gaim-0.75-r101
-rw-r--r--net-im/gaim/files/gaim-0.74-gnome-url-handler.patch46
-rw-r--r--net-im/gaim/gaim-0.75-r10.ebuild103
4 files changed, 158 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index e8481392abfd..80deeab3f18b 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.133 2004/02/18 20:17:41 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.134 2004/02/25 16:13:54 rizzo Exp $
+
+*gaim-0.75-r10 (25 Feb 2004)
+
+ 25 Feb 2004; Don Seiler <rizzo@gentoo.org>; gaim-0.75-r10.ebuild,
+ files/gaim-0.74-gnome-url-handler.patch:
+ Added support for gnome-url-handler if USE=gnome. Thanks to Chris 'wolf31o2'
+ Gianelloni
18 Feb 2004; Don Seiler <rizzo@gentoo.org>; gaim-0.75-r8.ebuild,
gaim-0.75-r9.ebuild:
diff --git a/net-im/gaim/files/digest-gaim-0.75-r10 b/net-im/gaim/files/digest-gaim-0.75-r10
new file mode 100644
index 000000000000..63510235452c
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.75-r10
@@ -0,0 +1 @@
+MD5 9935155985c25dfc9b59183de0da3c30 gaim-0.75.tar.bz2 3370977
diff --git a/net-im/gaim/files/gaim-0.74-gnome-url-handler.patch b/net-im/gaim/files/gaim-0.74-gnome-url-handler.patch
new file mode 100644
index 000000000000..e322b7608ae6
--- /dev/null
+++ b/net-im/gaim/files/gaim-0.74-gnome-url-handler.patch
@@ -0,0 +1,46 @@
+diff -u -ru gaim-0.74-orig/src/gtknotify.c gaim-0.74/src/gtknotify.c
+--- gaim-0.74-orig/src/gtknotify.c 2003-11-07 01:40:07.000000000 -0500
++++ gaim-0.74/src/gtknotify.c 2004-01-04 22:47:44.000000000 -0500
+@@ -393,6 +393,15 @@
+ gtk_widget_destroy(GTK_WIDGET(ui_handle));
+ }
+
++gboolean
++running_gnome(void)
++{
++ if (g_getenv ("GNOME_DESKTOP_SESSION_ID") && g_find_program_in_path ("gnome-open") != NULL) {
++ return TRUE;
++ }
++ return FALSE;
++}
++
+ static void *
+ gaim_gtk_notify_uri(const char *uri)
+ {
+@@ -403,7 +412,10 @@
+
+ web_browser = gaim_prefs_get_string("/gaim/gtk/browsers/browser");
+
+- if (!strcmp(web_browser, "netscape")) {
++ /* if they are running gnome, use the gnome web browser */
++ if (running_gnome() == TRUE) {
++ command = g_strdup_printf("gnome-open \"%s\"", uri);
++ } else if (!strcmp(web_browser, "netscape")) {
+ command = g_strdup_printf("netscape \"%s\"", uri);
+ } else if (!strcmp(web_browser, "opera")) {
+ if (gaim_prefs_get_bool("/gaim/gtk/browsers/new_window"))
+diff -u -ru gaim-0.74-orig/src/gtkprefs.c gaim-0.74/src/gtkprefs.c
+--- gaim-0.74-orig/src/gtkprefs.c 2003-11-18 18:28:40.000000000 -0500
++++ gaim-0.74/src/gtkprefs.c 2004-01-04 22:51:21.000000000 -0500
+@@ -2268,7 +2268,10 @@
+ prefs_notebook_add_page(_("Proxy"), NULL, proxy_page(), &p, NULL, notebook_page++);
+ #ifndef _WIN32
+ /* We use the registered default browser in windows */
+- prefs_notebook_add_page(_("Browser"), NULL, browser_page(), &p, NULL, notebook_page++);
++ /* if the user is running gnome 2.x, hide the browsers tab */
++ if (running_gnome() == FALSE) {
++ prefs_notebook_add_page(_("Browser"), NULL, browser_page(), &p, NULL, notebook_page++);
++ }
+ #endif
+ prefs_notebook_add_page(_("Logging"), NULL, logging_page(), &p, NULL, notebook_page++);
+ prefs_notebook_add_page(_("Sounds"), NULL, sound_page(), &p, NULL, notebook_page++);
diff --git a/net-im/gaim/gaim-0.75-r10.ebuild b/net-im/gaim/gaim-0.75-r10.ebuild
new file mode 100644
index 000000000000..516e0ed9d5e6
--- /dev/null
+++ b/net-im/gaim/gaim-0.75-r10.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.75-r10.ebuild,v 1.1 2004/02/25 16:13:54 rizzo Exp $
+
+inherit flag-o-matic eutils gcc
+
+IUSE="nls perl spell nas cjk debug ssl gnome"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ || ( dev-libs/nss net-www/mozilla )
+ gnome? ( >=gnome-base/libgnome-2.4.0 )"
+PDEPEND="ssl? ( net-im/gaim-encryption )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2 || die
+ cd ${S}
+ epatch ${FILESDIR}/gaim-0.75-static-prpls.patch
+ epatch ${FILESDIR}/gaim-0.76cvs-signals-varargs.diff
+ epatch ${FILESDIR}/gaim-0.76cvs-yahoo-login-fix.diff
+ epatch ${FILESDIR}/gaim-0.75-yahoo-security.diff
+ epatch ${FILESDIR}/gaim-0.76cvs-yahoo-misc-fixes-1.diff
+ use cjk && epatch ${FILESDIR}/gaim-0.74_cjk_gtkconv.patch
+ use gnome && epatch ${FILESDIR}/gaim-0.74-gnome-url-handler.patch
+}
+
+src_compile() {
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ use debug && myconf="${myconf} --enable-debug"
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ has_version dev-libs/nss && {
+ # Only need to specify this if no pkgconfig from mozilla
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+ }
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+
+ # Copy header files for gaim plugin use
+ dodir /usr/include/gaim/src
+ cp config.h ${D}/usr/include/gaim/
+ cd ${S}/src
+ #tar cf - `find . -name \*.h` | (cd ${D}/usr/include/gaim/src ; tar xvf -)
+ tar cf - *.h | (cd ${D}/usr/include/gaim/src ; tar xvf -)
+ assert "Failed to install header files to /usr/include/gaim"
+}
+
+pkg_postinst() {
+ if [ `use cjk` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=cjk') to compile with"
+ ewarn "a patch for CJK support. Please be aware that this patch"
+ ewarn "causes problems with skkinput. kinput2 works fine. Details"
+ ewarn "can be found at http://bugs.gentoo.org/show_bug.cgi?id=24657#c23"
+ ewarn
+ fi
+
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim. gaim developers do not like gentoo users."
+ ewarn
+}